Jump to content
RESET Forums (homeservershow.com)

Server 2012 R2 essentials, Client restore boot failure.


hubs
 Share

Recommended Posts

Hi

 

 

I recently changed my home server 2011 over to Server 2012 RS Essentials and have almost finished tinkering around with the main setup so thought I better check that the Client back ups were actually working properly .

 

 

I have several client pcs but one is a new copy of windows 8.1 on my old server 2011 hardware, so I thought as I had nothing to loose on this machine I would test it on that.

 

 

I'm a bit back up mad so to make things easier in the even of a problem i made an Acronis back up of the drive, before I started.

 

 

For info the pc is a 

 

 

Gen 1 I3 @29Ghz

 

gigabyte MB

 

8GB Corsair 1366 DDR3

 

OCZ 120GB SSD for OS

 

 

I thought Id simulate a complete partition corruption problem so used Acronis DD to fully clean the drive, and remove any partitions or info. 

 

 

I then booted via F12 and my realtek NIC, (nice new feature)   all seems to go ok, I used the wizard to set the restore going, 10 minutes and it was done.

 

 

When I tried to boot i got the windows 8 blue screen boot failure, I was unable to run F8 for advanced options and all options for fixing boot via the windows 8 disk failed to fix the problem.

 

 

I then tried re running the client restore again, no luck, then tried again and created the partitions manually, still no luck.

 

 

So I yanked the SSD out and inserted it in to my main PC to have a look at the partitions all looked ok, although there was a extra folder on the System reserved partition called WindowsImageBackup. (See screen prints attached), there was also windows volume info and recycle bin folders.

 

 

I figured it must be to do with the BDC or system reserved partition, so booted via Acronis restore and recovered the system reserved partition and MBR only not the Windows partition (see screen shot) and it booted fine !!  

 

 

I really would like to figure out why this problem occurred before testing another client, or before I actually need to use this restore, does anyone have any ideas ?

 

 

I have copy's of the BCD files and folders from the booting and not booting system system reserved partition, if any one knows how to read them ?

 

 

Thanks in advance.

 

 

hubs

 

not booting.jpg

Booting ok.jpg

Acronis recovery.png

Win 8 boot screen fail.png

Link to comment
Share on other sites

One thing you could possibly try -- it all depends on how you created the partitions when you did it manually. Did you format the partitions and/or give them drive letters? If you did, then try it without doing that. What I mean is, create the partitions manually, but do NOT format them or give them drive letters. Of course, be sure to delete all the partitions before or during the Restore process before you create them manually ;)

Link to comment
Share on other sites

Thank to both of you for your help.  I have an update...

 

I successfully opened the BCD files, the one that did not boot seemed to be missing some information (I have screen shots but don't seem to have any way to add them to the post this time ?)

 

I tried adding the partitions manually and not formatting them or giving a drive letter, but it made no difference.

 

However I did find a useful fix, after the restore and when the Win 8 pc would not boot, I booted from my windows 8 cd and again the automated repair did not work, so I selected Advanced and command prompt and ran the following commands ;-

 

Bootrec /fixmbr

Bootrec /fixboot

Bootrec /scanos

Bootrec /rebuildbcd   (It then scans and says it found 1 OS installation on D: no 1 and asks if I want to add it to the bcd i just put Y enter.

 

Then rebooted and all fixed  :D.   (For info, this process works on server 2012 R2 Essentials too, as for some reason my install added the bcd and boot files to a second drive ?, but running the above with all other drives disconnected fixed the problem).

 

I still don't get why this problem occurs, does anyone have any idea's ? 

Link to comment
Share on other sites

Sorry to hear that using Raw partitions did not work, but glad to hear you've found a workaround that does work. And thanks for posting the info here for others to benefit from.

Link to comment
Share on other sites

Just a quick update in case anyone finds the above useful and follows the BCD fixes,

 

If you want to be able to use hyper v in your server / PC after running the fix you will need to:-

 

open an administrative command prompt, and type the below command

 

bcdedit /set hypervisorlaunchtype auto

 

Then reboot and the hyper v hypervisor will be enabled again  :D

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...