Jump to content
RESET Forums (homeservershow.com)

Hyper-V on Windows Server Essentials 2012 R2 Question


Jason
 Share

Recommended Posts

While I am asking questions - a related question is - how do I set up one of my two NICs on the Gen8 Microserver for the sole use of my VMs?

 

As I said, I once tried unchecking "Allow management operating system to share this network adapter" and was unable to remote into my host server. This didn't make sense to me because each NIC has a separate IP address on my network, but after unchecking this option I could not get remote access to the host through either of them. Does anyone know what am I doing wrong here?

Link to comment
Share on other sites

When you install a VM one of the 2 NIC's will be allocated as NIC for the VM. You can check on this in Hyper V manager. On the left is "Virtual Switch Manager". Here you can create and manage virtual switches attached to real switches.

Link to comment
Share on other sites

When you install a VM one of the 2 NIC's will be allocated as NIC for the VM. You can check on this in Hyper V manager. On the left is "Virtual Switch Manager". Here you can create and manage virtual switches attached to real switches.

 

Understood - but when you allocate one of the NICs to the virtual switch, is it automatically set aside for VM traffic or does the host use it as well? Is there any advantage to setting one NIC up just for the VMs?

Link to comment
Share on other sites

Theoretically, unchecking the "Allow management operating system to share this network adapter" option lets you dedicate it to the VMs.

However, make sure you ahve the correct NIC selected when doing this, as it essential disables it for the host.

 

If you do have everything setup properly and it's disabling all traffic to the host... then that's really weird.

Link to comment
Share on other sites

Can anyone help me with a virtual switch problem?

 

I'm running Windows Server 2012 R2 Essentials on a HP Gen8 Microserver. I'm running two Hyper-V virtual machines, one Windows 8.1 and one Debian. They are connected by an external virtual switch with the default settings. It uses one of the two NICs on the Gen8 - the same problem occurs whichever I choose. "Allow management operating system to share this network adapter" is checked - I unchecked it once and promptly lost all remote connection to my server (I was happy to have iLO that day). No SR-IOV or anything else fancy.

 

The VMs work just fine except every so often (roughly every two weeks) they both lose all connection to the network. If I delete the virtual switch, create a new one with the same settings, and connect the VMs to the new switch, all is well again. But the workaround is not very satisfactory as I have to shutdown both VMs to do it, not to mention my VMs have no network connection for some unspecified period of time until I notice the problem.

 

Does anyone have any suggestions as to what might be causing this? I assume it is a host problem as it always affects both VMs simultaneously. Could it be a network driver problem? Or is there something in the settings of Hyper-V itself that can fix it?

 

I found a blog which documented an apparently similar problem on which suggested disabling "Virtual Machine Queuing" in the settings of the host NIC. So I've tried that and will see how it goes...  

Link to comment
Share on other sites

  • 4 weeks later...

I found a blog which documented an apparently similar problem on which suggested disabling "Virtual Machine Queuing" in the settings of the host NIC. So I've tried that and will see how it goes...  

 

Ok so here we are several weeks later and it appears that disabling Virtual Machine Queuing for the host NIC did the trick. I have not had any disconnections since then. Thought this might be useful for someone in future.

Link to comment
Share on other sites

  • 5 years later...

As an update to this thread, I recently had an issue with my Hyper-V VMs refusing to shut down properly. The shut down process would hang and it would take 6-8 hours to restart the VM. I eventually tried unchecking the "Allow management operating system to share this network adapter" option, so that the VM had its own dedicated NIC. This immediately solved the issue, now my VMs restart in 30 seconds or so. Not sure why this worked though. 

 

Also be aware when you change this setting, the host will stop using the NIC and so you will likely get booted out of your remote session. I initially panicked, then waited a minute as my Gen8 re-identified itself to my network through the other NIC, and away we went. Or you can use iLO and avoid getting booted out in the first place. 

Edited by lionelhutz
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...