Jump to content
RESET Forums (homeservershow.com)

whs console stops working when I change the rdp port


Ken
 Share

Recommended Posts

If I change the rdp port on my whs v1 server, the "windows home server console" stops working.

Error msg: "This computer cannot connect to your home server..."

 

I have changed the port in the router and I am able to establish a remote desktop connection from any PC, but the "Windows Home Server Console" does not work.

 

I assume that the console client program has saved the original (3389) port somewhere?

Link to comment
Share on other sites

Why are you changing the port?  The Console is a web site which means you would have to bind the IIS port as well.

Link to comment
Share on other sites

1/ I am changing the port because I am also running whs 2011, so I have to change one of them

 

2/ If I look in IIS, I see a web site called "WHS site" which is running on port 55000.

Is there anything else in IIS that refers to the rdp port of 3389?

I guess I still do not understand how the console uses the rdp port.

 

All help is appreciated.

Link to comment
Share on other sites

To RDP into the second second server you would have to go tot the Dashboard.  To access that sitem, you would need to bind port 55000 to that site whihc sounds like you have done.  From the outside, you would connect by adding the suffix ":55000" to the remote URL

Link to comment
Share on other sites

Yes, I think everything is working except when I start the "windows Home Server Console" from one of the clients to the whs v1.

I still do not see  how the "Windows Home Server Console" program depends on the RPD port??

Link to comment
Share on other sites

If you watch is closely you will see it does open the RDP application.  You might have to modfiy the Host File in order to clear all this up.

 

 

Again, is this internal or external communications?

Link to comment
Share on other sites

Thanks for your help!

 

I guess it starts making sense now.

Any idea where the console program gets the port number from? The host file only contains IP addresses.

 

The console program is running on one of the clients that belongs to the WHS v1, so that is internal. Is that what you mean when you are asking about internal/external??

Link to comment
Share on other sites

The console gets the port from the Application as RDP uses 3389.  To be clear, you are trying to RDP to the 2011 server form one of the V1 clients?

 

If so, just create a RDP Shortcut on the desktop using the IP Address.

Link to comment
Share on other sites

There is still something that I do not understand here. I have a feeling that I have not explained everything in my setup.

 

I have tested everything I can think of, and as you see below the only thing that does not work is WHS v1 client console connecting to its own home server.

 

Would you mind explain what you think the problem is again, with all this information in mind. It sounds like you know what the problem is, but I just do not understand it.

 

Thanks again for you help.

 

1/ WHS v1 (IP=..93, name=server)

- Using port 3396 for RDP. The only thing I changed here is the RDP port in the registry, from 3389 to 3396.

 

2/ WHS 2011 (IP=..73, name=whs2011)

- Using port 3389 for RDP

 

3/ WHS v1 Client

- Connector was installed from WHS v1: http://server:55000

- Windows Home Server Console to WHS v1 does not work !!!

- RDP to server:3396. Works

- RDP to whs2011:3389. Works

- Automatic backup to WHS v1 works fine. Manual backup works if I initiate it from the server console.

 

4/ WHS 2011 Client

- Connector installed from WHS 2011: http://whs2011/connect

- Dashboard connect to whs2011: Works

- RDP to server:3396. Works

- RDP to whs2011:3389. Works

- Automatic and manual backup to whs2011 works fine

 

5/ Router

- port 3389->73 (WHS 2011)

- port 3396->93 (WHS v1)

- port 80,443,4125->73 (WHS 2011)

 

6/ PC outside of my internal network

- RDP to mydomain:3389. Works fine

- RDP to mydomain:3396. Works fine

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...