Jump to content
RESET Forums (homeservershow.com)

Hardware for 2012 E R2


Poppapete
 Share

Recommended Posts

Would be nice if they documented which boards are actually UEFI better..... (or I'd taken more time to find out if each was). Either way.... The main consideration for me was UEFI, because I didn't want to have to reinstall my server. And I didn't. Swapped out the motherboard and CPU, and booted up. Took 20 minutes for "getting devices" to finish but was up and running in no time. 

 

As for vPro, it's not entirely straight forward to setup. Unless you've done it before. It does share the NIC with the OS, and you're basically forced into use VNC to access it. But it does work well. Except, if you want to "mount ISO" and other features, you MUST use RealVNC Viewer Plus, which is $100 .... 

But as I said, it does work well.  And I'm happy with the full sized ATX board (as I'm using a Norco RPC 4220, so a uATX would look off in the case.

 

And I hope you enjoy HyperV. If you're using Server 2012R2 (and it does look like you are) definitely make sure you use the Gen2 VMs. UEFI for the VMs. And it's neat seeing "HyperV" for the boot screen. :P

And I think you get better performance out of them overall.

And are you using dynamic memory allocation for the VMs, as well?

 

As for "too cautious", no such thing. And no such thing as too many backups! :)

 

 

 

 

Though, one complaint I do have about SuperMicro... Downloading drivers was a nightmare. I think I used the 2012R2, WIndows 8.1, Windows 8, Windows 7, AND "Generic" Windows to get everything to install.

Link to comment
Share on other sites

You need the F in the board (X10SLH-F). F stands for Integrated IPMI 2.0

You do have to read the specs to see if it is UEFI but aren't they all now?

 

I did not have to load any drivers. The 2012 E R2 loaded via the IPMI 2.0 from the iso without a stop.

 

My first Hyper-V on the Server:

 

I used dynamic memory and Gen1 as suggested by the doc in his article. I will use Gen 2 next one.

Only have an 8.0 iso as I can't find a 8.1 on technet anymore.

It loaded no problem but I can't get it to upgrade from the store to 8.1. At the final boot it says "no go" and reverts back to 8.0 - have tried twice.

Also I can only run it from the Hyper-V Manager if I try to run the machine directly I get "You don't have the required permission to complete the task"

I thought I had ALL permissions.

Will have to do a little reading. Have only ever used Hyper-V on my desktop before this.

Edited by Poppapete
Link to comment
Share on other sites

My Final Choice:

 

MB:             Supermicro X10SLH-F

Chassis:     Supermicro 732D4-500B with a second fan

CPU:           Intel Xeon E3-1230 V3

RAM:           Kingston 1600MHz 4X8GB

 

This board will take ECC Ram but not sure if it is worth the extra $$$$$ !?!?

 

After reading all recent threads on this forum re 2012 E R2 have decided:

 

No Raid but use Stablebit DrivePool with duplication of important folders

 

Put OS on an SSD using an "expansion slot hard drive mount" leaving plenty of space for the 3 or 4 TB WD REDS

 

Will use "SkipDomainJoin" - No Domain.

 

Server will be used for:

 

Backup of 3 Computers

Media Server using Serviio or Plex

Storage of Security Camera files by setting up an FTP Server Folder and an NFS NAS Folder

Hyper-V for playing with new and old OS's

 

Any advice most welcome :mellow:

 

Is the Kingston RAM you're using the KVR16E11K4/32 ?

Link to comment
Share on other sites

 

"Only have an 8.0 iso as I can't find a 8.1 on technet anymore.

It loaded no problem but I can't get it to upgrade from the store to 8.1. At the final boot it says "no go" and reverts back to 8.0 - have tried twice."

 

 

Have found the answer to this: To upgrade 2GB of Ram are required which can't be accessed from dynamic ram during the upgrade.  The workaround is to change the startup ram to 2GB and after upgrade revert back to 512.

Edited by Poppapete
Link to comment
Share on other sites

I don't know, I just checked on my long ended TechNet subscrption. Windows 8.1 with Update is the first thing listed.

 

Also, "Windows 8.1 Update" is about the stupidest name I've EVER seen. Whomever allowed that to be the public name should be drawn and quartered......

 

In fact, if you have an active subscription (or not, even) the following link should take you to the technet page:

https://technet.microsoft.com/en-US/subscriptions/securedownloads/hh442904#searchTerm=&ProductFamilyId=545&Languages=en&PageSize=10&PageIndex=0&FileId=0

 

That, and you can always find the Eval ISO for the Enterprise edition.

http://technet.microsoft.com/en-us/evalcenter/hh699156.aspx

Link to comment
Share on other sites

I still have an active technet pro subscription and I have looked at all the current DL's.

If you read the fine print you will see you need a VL not an ordinary  key.  I even even created bootable media and tried but no go.

Maybe I was doing something wrong. Too late now I have installed the 8.0 upgraded to 8.1 and then updated.  Took awhile but now have W7 & W8 VM's which I can access from my desktop in full screen from a remote desktop connection.

Link to comment
Share on other sites

  • 3 weeks later...

Just to correct that I can access the 8.1 with update pro edition ISO and it works with my TechNet keys.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...