Jump to content
RESET Forums (homeservershow.com)
wizengamot

Lian Li EX-503B

Recommended Posts

wizengamot

I have seen that a number of forum users here has used the EX-503/B units and I was hoping to ask a question of those who have experience with these units.

 

I have one of these units, it is an EX-503B unit.  I had it configured for Raid 5 with 5 2tb drives in it and it was full of all of my data.  Thinking it was safe if a drive failed I would replace the drive and it would be fine.  I even had a spare 2tb drive of the same make/model as the drive that would need to be replaced handy.  (I bought six drives all at once).  

 

A drive in the unit proceeded to fail.  I replaced the defective drive based on which light lit up and proceeded to power the unit on.  It was connected to the computer via USB3.  The system showed up as the drive being blank. I have since removed the drives from the array and ran various test utilities on them (I know which drive goes in which slot) and they all indicate that the drives are GONE there is nothing on them.  I have tried using the raid recovery system from runtime software and they also indicate that there are no recoverable values on these drives.  Of course since the data on these drives is all considered "nice to have" I do not have to recover it.  It just would be nice if I could.  Not really willing to throw $$$ at it so the runtime software raid probe service is not really an option.  If someone knows of a really good software package that would recover this data I would be very grateful for the help.

 

I currently have these drives hooked up directly to the computer and they are listed as un-allocated in windows drive manager.

 

Share this post


Link to post
Share on other sites
ikon

I have 2 of these. Have you tried the JMicron Management software that comes with the unit? I would put the drive back into the unit and try that.

 

BTW the 'B' just stands for 'Black'. I believe the other colour available is silver.

Share this post


Link to post
Share on other sites
pcdoc

Do NOT do anything to those drives while attached to a computer.  A raid volume can not be read independently and will always show empty when broken from the array.  Put it back together and run the software that came with your unit.  You must add the drive back into the array and rebuild.  The rebuild process has to be done manually unless you have it set to auto rebuild.  Hopefully you did not hose the data when you ran the utilities.

Share this post


Link to post
Share on other sites
ikon

Just for clarity, the JMicron software is the software that comes with the unit and is intended to manage arrays in the EX-503s. I don't know if it will be able to do anything in your situation, but I would try it for sure.

Share this post


Link to post
Share on other sites
wizengamot

I do not have the disc that came with the unit anymore.  Does anyone have a copy that is legal to copy that I can use?  I am not asking for illegal copies but if a download is available with this software that is legal to acquire that would be great.

 

Unless windows writes something to the drives when it initializes them for display in the storage manager (and I don;t think it does, I think it writes the drives serial number to its internal index) I should not have destroyed any data on these drives.

 

Thanks for your help.

Edited by wizengamot

Share this post


Link to post
Share on other sites
wizengamot

Dude, not trying to be rude -- honest -- but 23.713 seconds ;) of searching the Lian-Li web site came up with a download for the EX-503: https://www.dropbox.com/s/xplh1fftsia6ott/EX-503-SoftwareAP.zip

 

I hope it helps. Please let us know.

I do not view your response as rude at all.  I did search the lian-li website and google both.  Google has been notoriously bad about getting lian li stuff when searching (or its a lian li problem).

 

Upon further analsis it looks like I made a simple mistake and I went to a URL I assumed to be lian li but is in fact registered erroniously by a company called silver pcs.  I did not even look at the URL it re-directed me to.  I know that is kinda dumb but everyone makes mistakes and it looks I did.  I ruined my perfect record for 2014 already and I am not even out of January... d***it...!!! _ :) 

 

All kidding aside I do appreciate your help.  Thanks.

Share this post


Link to post
Share on other sites
ikon

LOL, don't you hate it when the year goes downhill so soon? :D

 

yw. Please do let use know if it works or not. Got my fingers crossed.

Share this post


Link to post
Share on other sites
wizengamot

LOL, don't you hate it when the year goes downhill so soon? :D

 

yw. Please do let use know if it works or not. Got my fingers crossed.

 

It did not work.  The software refused to recognise that there were any drives in there at all.  In fact it is looking more and more like the Lian Li unit itself is toasted.  Changing the dip switch settings with new drives does not get it to create a new array or anything.  I lost about 7 terabytes of movies.  I own them all of course but re-ripping them will be tedious.. it was the first time....

 

I would probably run DROBO entirely if I was independently wealthy but since I am not ....  with USB3 it has the thoughput for streaming and the redundancy that I like (I have never lost data with DROBO but I have lost count the number of times I have lost data with RAID based solutions). 

Share this post


Link to post
Share on other sites
pcdoc

It did not work.  The software refused to recognise that there were any drives in there at all.  In fact it is looking more and more like the Lian Li unit itself is toasted.  Changing the dip switch settings with new drives does not get it to create a new array or anything.  I lost about 7 terabytes of movies.  I own them all of course but re-ripping them will be tedious.. it was the first time....

 

I would probably run DROBO entirely if I was independently wealthy but since I am not ....  with USB3 it has the thoughput for streaming and the redundancy that I like (I have never lost data with DROBO but I have lost count the number of times I have lost data with RAID based solutions). 

 

I suspect the issue took place with the utilities.  Raid is pretty robust if you do not inject an outside variables.  Sorry to hear about the data loss however.  Just so you know, even changing the dip switch will not override an existing raid without warning so the only way the array got hosed is if two drives where lost, the unit went bad, or the files from the array were destroyed by external forces such as "us".  If I was a betting man (which I am) I would bet that something killed the partition on the drives effectively hosing the array.  Just a theory...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...