Jump to content
RESET Forums (homeservershow.com)
tinkererguy

Connect to Windows Server 2012 R2 Essentials without affecting your DNS, staying in workgroup mode

Recommended Posts

tinkererguy

Alternative title:

How to make Windows Server 2012 R2 Essentials client connector install behave just like Windows Home Server

 

When you install your R2 connector just for daily backups, if you'd rather it skip the domain join (staying in a workgroup), AND not have it not monkey with your all your NIC's DNS settings (including Hamachi, VMware, etc), then this article is for you!  Also nice that the install is now incredibly fast on Windows 8.1, a vast improvement over all previous client connector installs (seen in the video). This is not intended to spark discussion about whether the domain model is better for you. It's really just a tip for those who have already decided they need the backup clients to stay in workgroup mode, such as a home lab environment. In other words, very much like how Windows Home Server used to work.

 

Details published earlier today at:
TinkerTry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server

 

See also:

homeservershow.com/forums/index.php?/topic/6338-server-2012-r2-essentials-stopping-dns-affecting-the-clients/#entry73408
Started By tekguru on Oct 09 2013

 

"I love that eureka moment when you finally figure something out"

plus.google.com/u/0/108099269416006256371/posts/7gwJt65BiGS

Share this post


Link to post
Share on other sites
tekguru

The only problem was when I got in tonight and booted the PC, no internet connection. I had manually set the DNS to Googles servers but alas when I went in there the DNS settings were blank.

 

Will see what happens tomorrow!

Share this post


Link to post
Share on other sites
jmwills

Nice job Paul.

Share this post


Link to post
Share on other sites
tinkererguy

The only problem was when I got in tonight and booted the PC, no internet connection. I had manually set the DNS to Googles servers but alas when I went in there the DNS settings were blank.

 

Will see what happens tomorrow!

 
tekguru:

So, are you saying that if you combine the registry tweak I suggest, along with a manually set DNS to Google (8.8.8.8 and 8.8.4.4), the combination somehow results in a blank DNS upon reboot?

If so, please let me know if that's on Windows 8.1, 8.0, 7, etc.  I'd love to try to replicate the problem.
FYI, I've rebooted and tested on 4 machines at this point, but admittedly, all had (and still have) DNS set to auto, that is, DHCP fed.
Thanks for the heads-up!

Share this post


Link to post
Share on other sites
tekguru

That was it exactly.

Share this post


Link to post
Share on other sites
oceang

Thanks Tinkertry and thanks from my daughter as well.

 

Your registry change to stop the DNS settings changing worked great for me on one problem laptop running Windows 7 Home Premium. It belongs to my daughter who lives away from home during the week and she has been having internet connection problems ever since I connected her to R2, from WHS2011.

 

One thing that is not clear from your link

 

TinkerTry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server

 

is that the registry change for SkipAutoDNS...  can be applied at any time, not just as part of the initial connection process and it does work. I applied the change yesterday, over 3 weeks after initially connecting the laptop and it works fine,

Edited by oceang

Share this post


Link to post
Share on other sites
zeus163

What's interesting is that I already had that registry setting set to true. I'm sure I didn't manually set it either. I'm also not connected to the domain either, but I also have another registry setting in the same folder that is: ServerPresenceState which is set to online. Here's the weird thing though, when I right click on Ethernet adapter (wired)>Properties>TCP/IPv4>properties I get an error message: In order to configure TCP/IP, you must install and enable a network adapter card. Which seems odd since I'm fully on the Internet.

Share this post


Link to post
Share on other sites
tinkererguy

Thanks Tinkertry and thanks from my daughter as well.

 

Your registry change to stop the DNS settings changing worked great for me on one problem laptop running Windows 7 Home Premium. It belongs to my daughter who lives away from home during the week and she has been having internet connection problems ever since I connected her to R2, from WHS2011.

 

One thing that is not clear from your link

 

TinkerTry.com/how-to-make-windows-server-2012-r2-essentials-client-connector-install-behave-just-like-windows-home-server

 

is that the registry change for SkipAutoDNS...  can be applied at any time, not just as part of the initial connection process and it does work. I applied the change yesterday, over 3 weeks after initially connecting the laptop and it works fine,

 

Wow, excellent point, thanks, oceang!  I added as a footnote to my post.

What's interesting is that I already had that registry setting set to true. I'm sure I didn't manually set it either. I'm also not connected to the domain either, but I also have another registry setting in the same folder that is: ServerPresenceState which is set to online. Here's the weird thing though, when I right click on Ethernet adapter (wired)>Properties>TCP/IPv4>properties I get an error message: In order to configure TCP/IP, you must install and enable a network adapter card. Which seems odd since I'm fully on the Internet.

zeus163:

I've seen similar strangeness after restoring a system from a Windows Server 2012 Essentials backup, the NICs get in this "wonky" state, repaired by removing the NIC from Device Manager via right-click, Uninstall, rebooting, then autodetect does it's thing and reinstalls the NIC(s), then things act normal again. Any chance that could be the case here?

Share this post


Link to post
Share on other sites
zeus163

Thanks tinkererguy. I was going to try that and I don't know why I didn't do it, but that solved the problem for me. Now it is fine although I never restored the system.

Share this post


Link to post
Share on other sites
Drashna Jaelre

Is it horrible that I think that's a horrible idea, and LOVE using domains? :)

It makes Essentials easier to use and the network to manage, and no worrying about this stuff.

 

And I've been using a domain since I figured out you could do that in WHSv1. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...