Jump to content
Joe_Miner

Gen8 Kernal_Security_Check_Failure

Recommended Posts

Joe_Miner

I've been seeing Kernal_Security_Check_Failure's on my Gen8

 

I noticed it in addition to on my 2nd install of S2012R2 I used to Corsair 60GB SSD's in RAID0 as my OS drive -- I assumed the problem related to the SSD's having different FirmWare versions.  

Tried a fresh install (my 3rd) on 2 VR's in RAID0 for my OS dirve for S2012R2 and got the Kernal error during the Windows update which threw me in to a continuous boot loop -- I suspeced then that the problem was that I had only 2GB of RAM so I upgraded the RAM to 16GB 

Tried a Fresh install again (my 4th) on 2 VR's in RAID0 for my OS drive for S2012R2 but now with 16GB of RAM -- and have again gotten the Kernal error twice

 

 

I also noticed that starting with the 2nd install I would install the Server Backup function in S2012R2 -- when Server Backup runs I always get a Backup Failed to Compete Message -- the drive cannot find the sector requested -- the failures seem to occur during the volume shadow service portion of the backup

 

I've run all the Hardware diagnostics on the Gen8 and they all say the HardWare is OK which is leading me to believe the issue/problem is with the drivers possibly the RAID controller?

 

I've had the MicroServer auto-load all of the suggested drivers

Share this post


Link to post
Share on other sites
Joe_Miner

Awwwwwww, looks like I need the Supplemental Release!

 

Thanks so much!!!!!!!!!!!!!!!!!!!

Share this post


Link to post
Share on other sites
tangcla

It's just the B120i RAID controller driver you need - the latest version doesn't work, you need the older one. Let me find out which one i used.


HP update file cp020926 contained the B120i driver which allowed me to get through the installation.

Share this post


Link to post
Share on other sites
tangcla

Do you have a link to that file cp020926 -- It's probably just that it's late but I can't find it

It's included inside the HP 2012R2 supplement file.

Share this post


Link to post
Share on other sites
Joe_Miner

Well, before I updated my install of S2012R2 with cp020926 I thought I would do an install of S2012 -- which did seem to cure my Kernal-Security-Check-Failure but Server Backup still FAILS as before with S2012R2!

 

Again, every HW diagnostic says things are great.

 

I'm wondering if it is the B120i driver so I'm wondering if the cp020926 is needed for that also?  Maybe if I had done an install of S2012 in the first place -- before trying S2012R2 ......................

Share this post


Link to post
Share on other sites
LoneWolf

Have you tried using ESXi as a hypervisor, then running S2012R2? Might be a nice workaround with use in the future.

Edited by LoneWolf

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Similar Content

    • jjbrunton
      By jjbrunton
      Has anyone came across this before?
       
      https://imgur.com/a/FUk8M
       
      I've tried booting with the cache module in the card and then reinstalling the cache. I've tried reseating the card, I've tried reseating the cache module.
       
      Any ideas?
    • marty_oc
      By marty_oc
      Hi guys, this will be quite long, so be warned :-D
       
      I run Microserver Gen8 for several years now. I have one issue which happens on any cold boot (swich off the server, then switch on; no need to remove power outlet). 
      My config is following:
      * Linux Debian operating system
      * SSD in optical drive bay connected to SATA intended for ODD, intended as main system disk holding Debian Linux
      * 3.5" HDD in bay 1 used as single drive
      * 3x 3.5" HDDs in bays 2-4 used in software RAID 5 (mdraid, no LVM)
       
      To be able to boot from ODD SATA connector holding SSD with Linux, I needed to configure booting from integrated RAID controller and configure my SSD as one-disk-only RAID0 array. This works perfectly - I configure this logical volume in storage administrator and set it as bootable and server boots perfectly. I can see the SSD as /dev/sde and I can access it directly, it is seen by the system as regular SATA connected HDD. 
      Upon coldboot, HP RAID configuration is lost. If I boot from Debian Rescue disk (I have one permanently in iLO SD card slot), I can still see my SSD as /dev/sde and I can access all the data with no issues. When I open HP Storage Administrator and go through creating new array consisting of the SSD only, data is not lost and after setting it as bootable I can boot again without problems. 
       
      So what now? 
      I have a backup plan that would consist of using SD card in iLO slot as boot drive that would hold just GRUB and will be able to hand off all stuff to my SSD. 
      However, I would like to find out what is wrong with the HP RAID controller. Is it me who is stupid or just the controller does not support this unusual config?
       
      Ideas, anyone? 
    • drew_p2000
      By drew_p2000
      Hi all,

      This is my very first post in these forums so I am sorry if this topic is listed somewhere else on one of the other threads. 

      I've been using WHS 2011 for a number of years on a gen8. It boots from a SSD drive on the ODD slot and the remaining 4 drive bays are used for media/document storage. I also use drive bender to maintain duplication of some of the shared folders in place of a RAID configuration. 
       
      I am considering upgrading to Windows Server Essentials 2016 to ensure that the OS remains as secure as it can be. 
       
      Has anyone been through a similar upgrade and if so, can you share your experiences
       
      Thanks in advance
    • Bungow
      By Bungow
      Hello
       
      I have a Micreoserver gen8 with a new P222 and 4 X 4TB WD red drives forming a raid6 array. The problem is i can hear a loud noise comming from HDD like a intense reading disk operation, but when disks suposly are idle. This happen periodicaly like each 15 minutos or so. I think this can be a checking disk operation from p222 raid card but is anoying and I'm not sure. Can you provide any hint to this?
       
      Thank You


×