Jump to content

Gen8 Kernal_Security_Check_Failure

Recommended Posts


I've been seeing Kernal_Security_Check_Failure's on my Gen8


I noticed it in addition to on my 2nd install of S2012R2 I used to Corsair 60GB SSD's in RAID0 as my OS drive -- I assumed the problem related to the SSD's having different FirmWare versions.  

Tried a fresh install (my 3rd) on 2 VR's in RAID0 for my OS dirve for S2012R2 and got the Kernal error during the Windows update which threw me in to a continuous boot loop -- I suspeced then that the problem was that I had only 2GB of RAM so I upgraded the RAM to 16GB 

Tried a Fresh install again (my 4th) on 2 VR's in RAID0 for my OS drive for S2012R2 but now with 16GB of RAM -- and have again gotten the Kernal error twice



I also noticed that starting with the 2nd install I would install the Server Backup function in S2012R2 -- when Server Backup runs I always get a Backup Failed to Compete Message -- the drive cannot find the sector requested -- the failures seem to occur during the volume shadow service portion of the backup


I've run all the Hardware diagnostics on the Gen8 and they all say the HardWare is OK which is leading me to believe the issue/problem is with the drivers possibly the RAID controller?


I've had the MicroServer auto-load all of the suggested drivers

Share this post

Link to post
Share on other sites

Awwwwwww, looks like I need the Supplemental Release!


Thanks so much!!!!!!!!!!!!!!!!!!!

Share this post

Link to post
Share on other sites

It's just the B120i RAID controller driver you need - the latest version doesn't work, you need the older one. Let me find out which one i used.

HP update file cp020926 contained the B120i driver which allowed me to get through the installation.

Share this post

Link to post
Share on other sites

Do you have a link to that file cp020926 -- It's probably just that it's late but I can't find it

It's included inside the HP 2012R2 supplement file.

Share this post

Link to post
Share on other sites

Well, before I updated my install of S2012R2 with cp020926 I thought I would do an install of S2012 -- which did seem to cure my Kernal-Security-Check-Failure but Server Backup still FAILS as before with S2012R2!


Again, every HW diagnostic says things are great.


I'm wondering if it is the B120i driver so I'm wondering if the cp020926 is needed for that also?  Maybe if I had done an install of S2012 in the first place -- before trying S2012R2 ......................

Share this post

Link to post
Share on other sites

Have you tried using ESXi as a hypervisor, then running S2012R2? Might be a nice workaround with use in the future.

Edited by LoneWolf

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • milev
      By milev
      I have upgraded from G1610T to E3-1265Lv2 with success but the memory speed which is still stuck at 1333MHz instead of 1600Mhz.
      I have 2 x 4GB DIMMs with one be the original HPE DIMM and the other a Crucial 4GB 240 Pin DDR3 1600 MTps PC3-12800 CL11 Unbuffered ECC UDIMM Memory Module )(https://www.amazon.co.uk/dp/B00IW4M9PK/ref=pe_385721_37986871_TE_item)
      The iLO memory summary is always showing:

      and while I am on the latest firmware ....

      The BIOS options available are : 1066, 1333, Auto
      I have also tried the power setting to "max performance" but still the memory speed remains to 1333Mhz
      Any ideas on how to set the memory operating frequency to 1600Mhz ?
    • acidzero
      By acidzero
      So, after several days of testing various different configurations, creating custom ESXi install ISOs and numerous reinstalls, I've managed to get ESXi 6.5U1 installed on my Microserver Gen8 and have working HP Smart Array P410 Health Status showing. For those that are struggling to do the same, firstly here's how. I used original VMWare ESXi 6.5U1 ISO, build 5969303 then made the following modifications:
      Remove driver "ntg3" - If I left this in, I had a weird network issue where Port 1 or 2 would repeatedly connect/drop every few seconds. This forces ESXi to use the working net-tg3 driver Remove driver "nhpsa" - this Smart Storage Array driver is what causes array health monitoring to not work. Remove to force ESXi to use working "hpsa" driver Add the Nov 2017 HPE vib bundles Remove hpe-smx-provider v650. - This version seems to cause the B120i or P410 to crash when querying health status Add hpe-smx-provider v600. (downloaded from HPE vibsdepot)
      Add scsi-hpvsa v5.5.0-88 bundle (downloaded from HPE drivers page)
      Add scsi-hpdsa v5.5.0.54 bundle (downloaded from HPE drivers page)
      I did the above by getting a basic/working ESXi/VCSA installation and then creating a custom ISO in VCSA AutoDeploy and exporting it. But the same can be achieved by installing VMWare's original ISO and modifying via the esxcli command.
      I have a SSD connected to the SATA port, onto which I am installing ESXi. The 4 front drive bays are connected to the P410.
      Configure the Microserver Gen8 B120i to use AHCI mode - the B120i is a fake raid card so only reports physical disks to ESXi. Leaving in RAID mode works but I got a false Health Alert on Disk Bay 5 Install my modified ESXi ISO to the SSD  
      With these modifications I have a working ESXi 6.5U1 on my Gen8 with fully functioning HPE tools and array health monitoring:

      I also tested disabling the vmw_ahci driver, which is why the AHCI controller shows it is using ahci in the above image.

      If I pull out a disk to test a raid failure, when the health status next updates I can see a raid health alert in the ESXi WebGUI:

      However I'm now stuck at the next stage - getting this storage health to pass through to VCSA. VCSA can successfully see all other health monitors (under System Sensors in ESXi) just not the storage, which is the most important.

      Does anyone know how I can get the storage health working in VCSA?
    • Anatoli
      By Anatoli
      I've pinged Schoon about some questions I had regarding the Gen8 upgrade but I guess a community discussion will be more fun.
      The ultimate config
      The final config I'm planning to have is the following:
      E3-1265L CPU found on eBay at around $90 (no cheaper ones ) 16GB RAM which I'm still looking for (and want a cheap one, c'mon!) Main Drive made of two SSDs in RAID 1: Samsung MZ-75E500B/EU 500GB SSD Crucial CT500MX500SSD1(Z) 500GB SSD Storage Drive made of four HDDs in RAID 10 (I'll probably get some large Seagates)  
      Basically, what I would like from the Gen8 is to be a container host as well as a data storage unit. The OS and the VMs will be located on the SSD mainly, if larger storage is needed it could be nice to link it to the 4 disk array. I would like to RAID the thing using mdadm and virtualize using KVM so I would more likely use FreeNAS, Debian or Ubuntu as OS. Any thoughts about this? Suggestions?
      Getting down to the ports
      After looking into it for quite a long time now, I see the Gen8 motherboard has a max 5 disk capacity using all SAS/SATA ports. This won't fit my need since I need the 6th drive, and I need to get a RAID controller but since I'm going to RAID via software I won't need that and can definitely go for just a SATA PCI-e card with ya boy Marvell 88SE9215 instead.
      What do you think about this? Am I doing good at computers so far?