Jump to content
RESET Forums (homeservershow.com)

Backing Up UEFI/GPT Partitions


Technogod
 Share

Recommended Posts

I purchased an HP Split 13 x2 PC. It has a UEFI/GPT Partition. WHS 2011 won't backup FAT32 partitions. According to UEFI/GPT Partition rules the system partition must be FAT32. I don't think WS2012E will backup FAT32 partitions.

 

The only way I've found to successfully backup UEFI/GPT Partitions is with Acronis TI 2014. Acronis TI 2014 boot media also supports UEFI Boot. I backed up the partition using Acronis boot media but got a write error when I tried to restore it. I tried UEFI and Legacy modes. Possible cause, I was trying to restore to a partition that wasn't formatted.

 

I then restored my backup to a different drive using Acronis 2014 running on a Windows 8 Pro machine. Connected the drive via USB3 to my HP Split 13 x2 PC and booted from Acronis TI 2014 boot media. Tried to clone connected drive to HP Split 13 x2 PC. UEFI mode couldn't access HP Split 13 x2 PC mSATA drive. Booted in Legacy mode. Voila! I was able to clone the drive and life was good again.

 

When I upgraded from Windows 8 to Windows 8.1 it created a second system partition between the Windows and Recovery Partitions. It was NTFS instead of FAT32 and failed to backup due to lack of free space. When I backed up my HP Split 13 x2 PC using Acronis 2014 boot media I deselected this partition. Now my UEFI/GPT Partition conforms to UEFI/GPT Partition requirements.

 

I'll use WHS 2011 to backup my Windows Partition on a daily basis. Restore it using Client Restore if I have a problem. (Still needs to be tested) If mSATA drive fails I'll clone my drive and restore my latest Windows Partition.

 

Please let me know how you handle UEFI/GPT Partitions.

Link to comment
Share on other sites

I installed the hotfix as well. The hotfix states the EFI partition will be backed up even if it isn't listed. Unfortunately, WHS 2011 won't back up FAT32 partitions. The computer won't boot unless the system partition is FAT32. Here are two links describing how it must be FAT32.

 

 http://en.wikipedia.org/wiki/EFI_System_partition

 

http://technet.microsoft.com/en-us/library/hh824839.aspx

Link to comment
Share on other sites

My WHS2011 backs up my UEFI Win7x64 system just fine, including the ESP. It also restores just fine. Seems like something else must be going on here.

Link to comment
Share on other sites

I have two more issues. Client Restore USB boot drive fails authentication in Secure boot mode. FYI Acronis TI 2014 USB boot drive allows me to boot in Secure mode. There is no wireless network driver to connect to the Server. I loaded the drivers on the USB boot drive but it doesn't work.

Link to comment
Share on other sites

The issue with Secure Boot is actually part of the design of Win8. You have to disable Secure Boot temporarily in order to do the restore.

 

And yes, I generally agree with jmwills that it's inadvisable to do a restore over a wireless connection. If you absolutely have to do it that way, when using MS Restore you should be able to use the F6 option to load the drivers -- just copying them to the USB stick will not work -- they have to be loaded by the restore program.

Link to comment
Share on other sites

1) You can only use wireless with my tablet.

 

2) Drivers are loaded using Drivers for Full System Restore folder copied to USB key and selecting add drivers during Full Client Restore. This is not the first time these drivers have NOT worked.

 

3) I realize you have to be in Legacy mode to perform a restore. I was making a statement that Secure boot doesn't work with Client Restore USB boot drive. Why does it fail authentication and Acronis TI 2014 USB boot drive does not?

 

4) ikon , is your ESP or what I refer to as a system partition FAT32?

Link to comment
Share on other sites

I'll use WHS 2011 to backup my Windows Partition on a daily basis. Restore it using Client Restore if I have a problem. (Still needs to be tested) I did test this and it worked fine. I had to use another PC on the network because the wireless network drivers for my tablet don't work.

 

1) Restored my Acronis backup to another hard drive.

2) Installed it in another PC on the network.

3) Booted from Client Restore USB Key and restored Windows Partition.

4) Used Acronis to Clone hard drive to HP Split 13 x2 PC mSATA drive.

 

I also found the MSR partition is only visible if you run diskpart and list partitions. Here is a good description. http://en.wikipedia.org/wiki/Microsoft_Reserved_Partition

 

I hope everybody learned something from this. I know I did. I checked my Dad's WHS 2011 and his HP Pavillion Laptop has the same problem. WHS 2011 is unable to backup the system partition because it's FAT32.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...