Jump to content
RESET Forums (homeservershow.com)

Mirroring the OS


Recommended Posts

The disk I tried to use had no partitions. I checked it on another computer and it was just unallocated space. Could it be that it was looking for two disks to reflect the fact the is was mirrored?

Link to post
Share on other sites
  • Replies 32
  • Created
  • Last Reply

Top Posters In This Topic

  • Carpediem

    16

  • ikon

    13

  • Joe_Miner

    3

  • jmwills

    1

That could be. I don't think I've done a restore to a mirror that was built using Disk Manager (I done plenty using BIOS mirrors). I would give 2 drives a try. You have 2 spare drives, so why not go for it? :)

Link to post
Share on other sites

Well, I got a spare hour last night and tried to restore with two disks in case the restore was trying to relect the fact that my OS was mirrored. It failed with the same error messages as previoulsy in this thread. I also tried it with one disk with the same result. This was all trying to restore from my external back up disk. I even tried chosing a different back up from the back up disk in case that was the problem but no joy. When I tried it from my internal back up disk I again got the error message from earlier. I have put both error messages below. I'm now really stuck as I don't know why this is hapeneing and the error messages are not helpful. Any help or advice from anyone would be very welcome. I'm sure it shouldn't be this hard! :unsure:

 

Error message when trying to restor from internal back up disk http://homeserversho...54_71_23762.jpg I managed to read yesterday that this may be down to the fact that the disk did not have a drive letter associated with it. I will allocate it a drive letter this weekend which may cure this message but I suspect I will get the same error as below!

 

Error message when trying to restore from external backup disk http://homeserversho...54_71_35363.jpg

Link to post
Share on other sites

Ikon, I have managed to resolve the error message I was getting trying to restore from my internal disk. The problem was that it did not have a drive letter allocated to it. Once I allocated a drive letter to it it went through the process. However, the restore still failed. So my current situation is that trying to restore from an internal back up I get this error message http://homeservershow.com/forums/uploads/gallery/album_71/gallery_5454_71_75658.jpg

 

Trying to restore from an external back up connecting a USB disk gives me this error message http://homeserversho...54_71_35363.jpg

 

So I have two sets of backups which I cannot restore from!!! This is now where my knowledge ends and I don't know what to attempt next. Any help or advice would be most welcome.Thanks. :unsure:

Link to post
Share on other sites

Ah. So your source disk didn't have a drive letter. Can't say as I've run into this before, but I guess there's a certain logic to it. Why the restores are still failing is really puzzling at this point.

 

Let's summarize:

  1. you have 2 freshly made backups of the OS drive using Windows Server Backup; 1 internal and 1 external
  2. the drive you're restoring to is larger than the original OS drive
  3. the restore fails whether you try to restore from the internal or external backup

Does that pretty much sum it up?

Link to post
Share on other sites

OK, at this point, I'm suggesting you try the 'trick' I use to do BMRs from my WHS2011 to my clients. I don't see why it should be necessary, but it might work.

 

What you need to do is connect your original OS drive and boot from it. Then, use Disk Manager to see all the partitions on the OS drive. Make a note of the size of each partition.

 

On the spare drive you're using to test the Restore, create all the partitions that are on the good OS drive. I would make each partition just slightly larger than the ones on the good OS drive, just to be safe.

 

Then, shut down, remove the good OS drive and try to restore to the spare drive again.

Link to post
Share on other sites

Ikon

Thanks for your idea. Unfortunately I tried it and it didn't work! here's what I did.All the below was replicated for trying to restore from an internal backup disk and an external one. The results were identical. The disks I was trying to restore to were mounted onto the same SATA bays as the original OS.

 

  • Noted the partitions on the OS disk
  • Created all the partitions on the OS onto 2x1TB drives I'm using to try and restore to. (made them all 10mb larger as suggested.)
  • Removed both OS drives (they are mirrored)
  • Booted from the DVD
  • Inserted one of the 1TB disks to restore to and it failed with the error message below.
  • Tried again with both 1TB didks in as my OS is mirrored and it failed with the error message below.
  • Tried just letting the restore wizard go through restoring with its defaults and it failed with the error message below
  • Tried selecting 'Only restore system drives' with 1 xTB disk to restore to and then both 1TB disks to restore to. Restore failed with the error message below.

So, no matter what I tried it just wouldn't restore. :(

I'm actually very annoyed with MS. I bought this product to provide me with some security of data and the ability to restore things if it all goes wrong or I have a disk failure. I have followed their back up plan and have two sets of back up one of which I take off site. What use are they if you can't restore from them? Defeats the entire reason for doing the back ups!! 

 

Anyway, MS rant over I would appreciated any further ideas. Is it linked to the fact that I have mirrored the OS?

I will wait to hear back. Oh yeah, this was the error message http://homeserversho...54_71_35363.jpg

Thanks

Link to post
Share on other sites

I decided to look more closely at my own configuration, so I could see if I could offer any other ideas. In the process, and although my Windows Server Backups are proceeding perfectly, I discovered I cannot restore them on my home WHS2011. Bare Metal Restore works perfectly on another WHS2011 I have set up for a relative, but not for my own.

 

My issue is that the Restore Process says it cannot find any valid images to restore. I've detailed what's going on here: http://homeservershow.com/forums/index.php?/topic/6798-bare-metal-backup-restore-of-only-os-drive-possible/

 

As I said in that thread, I'm suspicious that I'm not finding any valid images because I cannot select Bare Metal Recovery on my home WHS2011 without also having the Data Pool selected (something I can't have selected because of the size).

 

Is there any chance you also don't have BMR selected?

Link to post
Share on other sites
  • 2 weeks later...

Hello Ikon and a Happy New Year to you. Sorry about the delayed response but I was away for the festive break.

Thanks for your response above and your efforts to help me.

 

When you ask whether I have BMR selected, I'm slightly confused as to where I select this!

I set up my back ups through the Dashboard. I have looked at this configuration and I have the following selected as per the picture here  

http://homeservershow.com/forums/uploads/gallery/album_71/gallery_5454_71_7848.jpg

 

You will notice that I do not have disk D selected as there is nothing on D. As you know windows creates this partition. F is then my data folder and I select the important thinkgs to back up.

I can see no BMR option. Am I in the right place?

 

Thanks

Carpediem.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...