Jump to content
RESET Forums (homeservershow.com)
TeoCiontu

B120i controller Read Cache error

Recommended Posts

TeoCiontu

Hi Guys, 

 

I'm new here and in the server world, please help me with this. 

 

I've just bought the microserver gen8 and I have this issue. 

When I'm setting the read cache in Array Configuration Utility (pressing F5 during POST) to 64mb or 128mb it gives me this warning message:

 

"Array Controller read cache was configured for this controller, but the system was unable to allocate the requested system memory. The read cache memory is set to 0MB."

 

Did you see something like this ? 

 

Everything I did is not working. The server is up to date. 

Share this post


Link to post
Share on other sites
schoondoggy

I think you need to use the offline, bootable version of the ACU to configure the cache per page 7;

http://h20566.www2.hp.com/portal/site/hpsc/template.BINARYPORTLET/public/kb/docDisplay/resource.process/?javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken&javax.portlet.rid_ba847bafb2a2d782fcbb0710b053ce01=docDisplayResURL&javax.portlet.rst_ba847bafb2a2d782fcbb0710b053ce01=wsrp-resourceState%3DdocId%253Demr_na-c03326739-2%257CdocLocale%253D&javax.portlet.tpst=ba847bafb2a2d782fcbb0710b053ce01_ws_BI&ac.admitted=1386080409591.876444892.199480143

 

Here is the offline ACU;

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?sp4ts.oid=5194887&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3Didx%253D%257CswItem%253DMTX_3c888073127c4c65b7bd8559eb%257CswEnvOID%253D4064%257CitemLocale%253D%257CswLang%253D%257Cmode%253D%257Caction%253DdriverDocument&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

 

I have not played with it, but I think the ACU is being replaced by HSS;

http://h20566.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?sp4ts.oid=5194887&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3Didx%253D%257CswItem%253DMTX_50309f0541d14018bb674c59b8%257CswEnvOID%253D4064%257CitemLocale%253D%257CswLang%253D%257Cmode%253D%257Caction%253DdriverDocument&javax.portlet.begCacheTok=com.vignette.cachetoken&javax.portlet.endCacheTok=com.vignette.cachetoken

 

 

Thanks for posting this question.

I have not played with the cache settings either.

Share this post


Link to post
Share on other sites
schoondoggy

Just tried this. Make sure you have the latest BIOS and firmware.

The offline ACU allowed me to change the settings.

During boot the B120i still shows 0MB, but that is referring to the fact that it does not have a dedicated cache module.

If you run the diagnostic in ACU, you will see the correct read cache amount. 0-64-128

Share this post


Link to post
Share on other sites
TeoCiontu

Thank you for your reply. 

The bios and firmware are all up to date. 

I use offline ACU, and indeed it let me to change the read cache but the Warning is still there. Also the ADU report from offline ACU show 0Mb for read cache. 

Same thing with HSS. 

iLO report the same when I'm in offline mode, no read cache. 

 

But, 

 

When I am in Windows 2012 server , iLO reports the right amount of read cache that I've set in offline ACU. Also ADU from windows reports the right amount of read cache.

 

So only in offline mode ACU or HSS report this warning. 

 

I think read-cache is not related to the cache module . The read cache is taken from RAM, as far as I understood. 

 

The question is if you or anybody else with a microserver gen8 see the same Warning in offline ACU or not. 

This my last chance to see if it something normal or my little machine has an issue. 

 

My config is 1610T 

2gb ram

1 hdd WD 2Tb RED

 

Tahnk you very much for your support, 

 

teo

 

P.S. I attached some pictures: report during offline and the reports during windows 2012. 

 

Offline ACU

 

SSA-offline-read-cache-b120i-warning.png

 

ADU from offline ACU (SSA)

 

SSA-offline-read-cache-b120i-warning-ADU

 

iLO during offline ACU

 

iLO-storage-info-during-offline-ACU.png

 

iLO during Windows 2012 

 

iLO-storage-info-during-windows-2012.png

Edited by TeoCiontu

Share this post


Link to post
Share on other sites
schoondoggy

My system has 16GB of memory, I wonder if there is an issue with setting the read cache when you have 2GB of memory.

I would register this issue with HP. I have had good luck using their chat support for issues like this.

Share this post


Link to post
Share on other sites
TeoCiontu

Yes, I had the same good experience with hp chat support. The hp guy told me that he needs to search in depth for an explanation. 

I was thinking too if it is not an issue only when you have 2Gb. Actually a guy from hp forum told me that as far as he remember, he has the same error before upgrading from 2 gb to 16gb. 

 

The server is working very well and read-cache seems to be ok when the driver of B120i is loaded by the OS. 

But I want to be 100% sure that everything it is ok before the no question returning period will end. 

 

I'll keep updated after I'll get the answer from the HP engineer. 

 

Thank you, 

teo

Share this post


Link to post
Share on other sites
ikon

Boy, this would be a great time for you to have some extra, compatible RAM on hand. Oh well, hopefully HP will get back to you really soon.

Share this post


Link to post
Share on other sites
LoneWolf

NewEgg (if you're in the US) has a pretty cheap deal on a compatible 2GB module to bring you up to 4GB.

 

http://www.newegg.com/Product/Product.aspx?Item=N82E16820148761

 

It's refurb, but it's Crucial, so if there's an issue, you should be covered.  Adding a second module means you go to dual-channel for better performance too, so I'd spend the $25 to get there.

Share this post


Link to post
Share on other sites
TeoCiontu

Thx guys for the support.

As far as I understand you are not encountering this issue but in the same time you have more than 2Gb...

 

I'm not in US and here in Romania compatible ram  is over my actual budget for this NAS project. 

I'm trying to find some RAM just for testing. 

 

I've got the answer from hp guy:

 

Thank you for your time and co-operation with us in relation to issues regarding the Microserver.

After analyzing the ADU report and research on this issue, I was able to find the solution.

HP Dynamic Smart Array RAID controllers can use a configurable amount of main system memory for read caching. The default amount of memory used is 64 MB. However, this value can be set to 0, 64, or 128 MB.

 

This read cache need to set in the OFF line ACU through IP. Since we have set the cache value in online ACU, the value is not set in the OFF line ACU. Do to this we are receiving the error message in OFF line ACU. 

 

Please try setting the cache value to the same value, which you have set in the online ACU.

Please refer to the controller user guide in the below URL link (Refer to page number: 7) which talks about configuring the read cache for the controller.

 

I don't know what he is talking about because there is no setting in online ACU for the size of read cache only in offline ACU. 

They don't know their own systems or I'm missing something ? 

 

In short:
 
When I'm in offline mode, in IP (b120i driver loaded), iLO reports 0Mb Read Cache, even I've set it to 64Mb. 
 
When I'm in Windows 2012 or Windows 8 (b120i windows driver loaded) iLO reports 64Mb, exactly the size that I set it in offline ACU.
 
Therefore my conclusion is that the reporting warning is something regarding to the driver loaded during offline applications (IP, ACU, etc)
 
What do you think ?

 

Thanks again, 

 

teo

Edited by TeoCiontu

Share this post


Link to post
Share on other sites
schoondoggy

When you say offline ACU, are you booting off a ACU DVD?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...