Jump to content
RESET Forums (homeservershow.com)

Microserver G8 - fighting with performance under ESXi 5


kknn
 Share

Recommended Posts

Hello,

 

Been playing with my new Microserver for a few weeks now and i must say am puzzled with performance results.

Have installed ESX 5.1 and 5.5 and made some network performance tests, it is just awful.

Uploaded huge files to SSD datastore (ODD)  / LSI 9260-4i RAID6 datastore using ESX web client. Coulnd't reach a decent speed. (8 Mo/s)

Installed an Ubuntu VM and from there transferred files to my NAS, awful speed (6-8 Mo/s no more)

At first i thought it was a network problem (switch, cables, etc) so i decided to boot the Microserver with a Unbuntu Live CD just to make sure...and gigabit network speed was finally reached, i got around 80 Mo/s, so it is a specific ESXi problem.

Tried to play with MTU, vSwitch, etc...google everything i could...same.

 

The worst it that i remember having installed it a month ago (using another HP version ? did they update it since ?) and i didn't have any speed pb.

 

Am posting here, hoping somebody will help, thanks !

Edited by kknn
Link to comment
Share on other sites

Update :

 

A transfer to the SSD datastore takes forever but...if I download a big file from there using ESX client then its blazing fast !!! Upload is very slow / download is fast - what the hell ?

 

Found a thread : same problem, same broadcom NICs : https://communities.vmware.com/thread/427466?start=0&tstart=0

 

 

 

Config :

ESXi 5.1 and 5.5 (custom HP ESX)

Xeon 1265L v2 / 16 Go RAM

Both NICs plugged on a Netgear GS108T v1 (Jumbo frames enabled), tried with and without LACP.

STORAGE : Intel SSD using ODD (AHCI) + RAID6 using LSI 9260-4i

 

Need some advice. :blink:

Edited by kknn
Link to comment
Share on other sites

There are two items i would look at.

1. does your raid card have a battery back up and if so, did you enable write back ?

http://it-manage.com/wordpress/?p=99

 

2. What kind of virtual nics are you using, there are some performance issues with some of them

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=1001805

 

Good luck

Link to comment
Share on other sites

Thanks for your reply.

 

Like i said, i have one SDD plugged and i dont use my Raid Card yet, so this is not a battery backup problem.

I boot ESXi 5.1 and 5.5 off a USB key and the SSD disk is the main storage for now.

 

Uploading using vSphere web client to the storage takes forever but downloading from it is just very fast. Made several tests using several SSD : Crucial , Intel, same results.

So there is obviously a huge impact on a VM installed on this SSD...even using VMXNet3 virtual Nic.

 

And again if i boot the microserver using a Linux LiveCD, i get rid of these network performance issues. So it is ESXi related !

Link to comment
Share on other sites

  • 2 weeks later...

Hmm. Let's see, before HP changed my mobo (pin broken on the CPU socket) everything was perfectly fine...

I guess i'll just inject some 220V somewhere on a component and burn it and will have it replaced again...that will at least remove the serious doubt i have about this one...

Hello HP, yes am calling cuz my mobo doesn't work anymore...

 

Have nothing to lose, this mobo is useless now.

Edited by kknn
Link to comment
Share on other sites

  • 2 months later...

Well i did what i said i would do...hum. So i have a brand new power supply + motherboard and everything is fixed.

Uploading to SSD or RAID datastore is now blazing fast...so the now dead mobo was faulty (thanks HP !!).

I feel good. :rolleyes:

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...