Jump to content
RESET Forums (homeservershow.com)
CallSignMavrick

Acer H342 server restore failing

Recommended Posts

CallSignMavrick

Ok, I attempted the whsoobe file, but it failed with an error saying the home server connector couldn't be opened (presumably because the backup service isn't working)

Share this post


Link to post
Share on other sites
diehard

The whsoobe app is the Out Of Box wizard that is usually started on your PC when the connector software is installed. That's when you type in the server name and password and it asks to start Windows Update (which you can pause until later to save time while also confirming that the server has recovered properly) it will also join the PC to the server and start the backup service. Then during the reboot, it creates the shares on the D Partition

 

If for some reason this fails, you have been experiencing, it's possible to start this wizard directly on the server using whsoobe.

 

If this doesn't clear things up then I suggest you do a clean install again.

 

I found a disk of the original H342 Server Recovery Disk ver1.2 I can upload to Skydrive on Tuesday if you need it.

Share this post


Link to post
Share on other sites
CallSignMavrick

Mine is a ver. 1.2 too, but if its not too much trouble i'll gladly give yours a try as well.

 

I'll give the reinstall another go and use the whsoobe instead of proceeding on the client once I get to that point.

 

I would say that if I'm unable to get this going using the Acer disc by thanksgiving, I'll just give up and use the OEM dvd instead, as I've already proven that to work. Yes, i'll be lacking the drive lights, and system info tab on the console, but I wouldn't call that a deal breaker. Especially since I'll be building a whole new WS2012E box myself sometime next year.

 

I really do appreciate all the help and suggestions!

Share this post


Link to post
Share on other sites
CallSignMavrick

SUCCESS!!

 

I have successfully restored my Acer H342 with the original Acer restore discs after consulting with diehard earlier this evening. All the credit goes to him and his advice.

 

I will now give a brief description of the original problem, attempts I made, and a step-by-step of what finally worked for the benefit of anyone else who owns this model and may run into similar issues.

 

Original issue:

 

I have a 2 year old Acer Aspire easyStore H342 running WHS v1. Towards the end of the first year the original 2TB system drive failed. I still had the warranty, so Acer replaced it. Now, 1 year later, I began hearing similar scratching sounds from the server as I had the last time, and confirmed they were coming from the system drive. I chose to take pre-emptive action and replace the system drive with a new one, using the Acer server restore discs. I have a desktop running 64-bit Windows 7 and Windows XP Mode and a laptop running 32-bit Windows 7 and 32-bit Vista Business in a virtual pc.

 

Failed attempts:

 

I won't go over each and every step I took during my attempts, but I will list the general ideas I tried.

Running the restore from the cd in all of the above OS's failed. I copied the contents of the cd to both the desktop Windows 7 and XP Mode, and attempted to run the restore, but it failed.

 

Each time it would get past the point of entering the server name and password, to where it would install updates, and then error out. Hitting the back button only caused the error to repeat. Upon repeating this several times, the install would proceed to the next step (joining the server) and again error. Once again after repeating, it would proceed to configuring the backup, and would never proceed from there. At this point, after numerous attempts, I became convinced the Acer discs were bad.

 

I proceeded to buy the VGA dongle from here: http://www.mediasmartserver.net/forums/viewtopic.php?f=6&t=8066

I also purchased an OEM dvd of WHS v1 from ebay, and an LG SP60 USB DVD drive from a retail store.

 

Using the external dvd drive and the dongle, I installed the OEM version, only to run into a BSOD after the first reboot of the setup. At this point I bought a USB floppy drive and some floppies to install the SATA drivers (this was indicated as the issue through the BSOD error codes). I tried several different drivers, but none worked. I'll also note that I had read in an Acer manual I found online that the easyStore had an ICH7R controller. This turned out to be outdated and only applies to the H340/H341. The H342 has an ICH9R controller.

 

I eventually realized I needed to change the HDD's mode in the BIOS from AHCI to IDE. Doing this allowed the OEM install to complete properly, except for the lack of an Ethernet driver. I determined the Ethernet controller was a Marvell Yukon 88E8071. The driver can be found here: http://www.marvell.com/support/downloads/driverSearchResults.do;jsessionid=pHYLSS4MtBL0JxJQ10w37shcpmy2llhcxZ9ChxTdNrckGpSGhlTn!-1730479504

Once all updates were installed through Windows Update, I installed the Intel ICH9R SATA driver from a cd, which I burned using the file from here: https://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=17882 (specifically I downloaded the 32-bit floppy installer, f6flpy3289.zip, Version 8.9.0.1023). To install it I went into Device Manager and selected the entry under IDE devices, right clicked the component and selected Update Driver. Then chose to install from a specific location and directed to the location of the cd. Upon installing the SATA driver, I rebooted, entered the BIOS, and switched the mode of the HDD back to AHCI. Upon exiting the BIOS, the startup appeared to hang for a moment, but don't worry, it will work!

 

This left me with a WHS v1 install that was about 95% the same as my original. I was lacking only two things: the drive lights no longer functioned due to the lack of proper drivers, and I was lacking the original Acer addins on the connector software (none of which I ever really used, but if you do, you'll have to find and install them yourself).

 

I wrote the above for reference in case anyone needs to install an OEM copy to their H342, but keep in mind, it wont function 100% as before.

 

Now for the actual solution:

 

I spoke to diehard this evening, and he offered a few suggestions for getting everything working. I'll list the steps that specifically did work for me:

 

  1. Reformatted the HDD I intended to use beforehand
  2. Copied the contents of the Acer server restore disc to my 64-bit Windows 7 pc
  3. Hooked up the VGA dongle
  4. Initiated the server restore on the Win 7 pc
  5. Observed the activity on the server through the VGA dongle hookup. Only proceeded on the client side when the server had completed its tasks.
  6. After the restore completed the first stage and the server rebooted, closed the installer on the client pc
  7. Started Windows XP Mode
  8. In IE, browsed to http://servername:55000 and clicked the button for installing the server connector
  9. Followed the prompts, and made sure to select the option to download/install updates at a later time
  10. Allowed the install to proceed. This took around an hour or so to complete, but complete it did, all the way through computer backup
  11. Allowed Windows Update to download and install necessary updates.
  12. You are done. The server is functioning properly, including the drive lights.

Many thanks to all those who helped me on this matter, particularly diehard. Hopefully this guide will be useful to whomever else may run into a similar issue.

Share this post


Link to post
Share on other sites
diehard

EXCELLENT NEWS:

 

Thanks for the kind words. I'm glad that I was able to contribute to your success along with the members here.

 

I'm happy to hear that your WHSv1 Acer H342 is back up and running with all the included Acer software and drivers. Your perseverance and determination and expense paid off. Once you get all your data back onto the server, it will be easier when the time comes to move/copy your files to your new 2012 server when your ready to build that box. You can even use the Acer to backup the 2012 Server's OS and shares if you choose. 

 

Thanks for reporting back here on your progress. It's always nice to read Success stories.

 

John.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...