Jump to content
RESET Forums (homeservershow.com)

Acer H342 server restore failing


Recommended Posts

I've had this Acer easyStore H342 for about 2 years now. Almost exactly a year ago it simply died, but as I still had the warranty, I was able to send it in for repairs. Now a year later, I began experiencing similar symptoms. I began hearing a scratching sound from the server, and after some testing finally narrowed it down to the system drive. As I no longer have the warranty, I set out to fix this myself, although I had read plenty of horror stories about resetting these boxes.


On my first try, I removed all 4 of my drives, and inserted a new 2TB hard drive into the OS drive slot. I immediately ran into issues with even being able to start the recovery/reset process, but after some web-surfing I found out the Acer directions were inaccurate and after some trial and error was able to get it going.


Before I go further, I'll note that I have all my files on the server backed up to an external drive, so I am not concerned with losing anything on the server drives. I do not care about my client backups. I just want to get the OS reinstalled. I'll also note that the server restore disc I have says its version 1.2, but I don't know whether the server came with PP1 or PP2. I'm about 98% certain I installed PP3 at a later time. The first time around I was doing the restore through a Windows 7 64-bit system. I did remove the connector before starting.


Now, back to the restore. As I'm not concerned with data loss, and I had the impression that "server recovery" required that the OS already existed on the drive, I selected the server restore option. Everything went smoothly through this step. None of the drive lights were lit though. I only had the red "i" and blue network lights. The problems started once the server rebooted. On the screen where it's searching for the server on the network, I got an error saying it couldn't be found. After waiting a few minutes, I hit the back button, after which the server was found and the installed began downloading files from it.


Next, I got to the screen where I was asked to enter the server's name and I entered the same name as before. Around this point the drive lights (even the empty bays) and the "i" turned a sort of violet color. Next I got to the password screen without issues, then to the automatic updates screen. This first time around I selected the automatic updates option and hit next. On the following screen I got a load bar saying it was installing updates. It never progressed past 0% before erroring out. I hit back, only to have it load for a few seconds and then go back to the error screen. I repeated this several times, until eventually the updates showed at 51% before erroring. After further repeats, The load bar said it was joining the server, but again erroring. Once again I hit back, several times over, before the load bar filled to about 90% and stated it was configuring backups, then, again, erroring. Also at this point, the drive lights went out for a few minutes, and then the OS drive light turned blue, and the "i" turned red. From here I attempted hitting back several times, but the installer never proceeded any further. The error told me the backup service wasn't running and I should restart the system and try again. At this point I RDP'd successfully into the server and restarted. Unfortunately, this had no effect. I tried using the connector installer cd and the installer on the server, but always got an error with the backup service not starting.


Since doing all of this I have attempted the restore several times with a few variations, but with the same results. I read on another forum that this issue could be resolved by inserting additional drives in before commencing the restore. I tried multiple times with 2,3, and 4 drives, with no luck. The only variation here was that upon getting to the setup of computer backups, the drive lights for the additional drives would turn violet, while the system drive's would remain blue.

I tried using my 32-bit Windows 7 laptop, then installed a Vista Business 32-bit Virtual PC and attempted that. No luck. I also installed XP mode on my 64-bit Windows 7 desktop, but had no luck.


Throughout these attempts I also consistently observed that the OS drive had two partitions, but the D: partition was never formatted. Once I did the reformat to see if that would help, but it didn't.

I attempted to open the connector console on the server, but always got an error about the backup service not being turned on. Whenever I went to start the service, it would start and immediately stop. It was also by default set to start manually.


It's possible I may have missed some details here and there, but this is all I can remember off the top of my head. If I think of anything else I'll be sure to give an update here.


I am at my wits end with this situation. I've been working on this issue for around a week now. I've scoured the internet for any leads that could help fix this, but nothing so far has worked. If anyone can offer any suggestions, it would be greatly appreciated.

Link to comment
Share on other sites

  • Replies 24
  • Created
  • Last Reply

Top Posters In This Topic

  • diehard


  • jmwills


  • ikon


  • CallSignMavrick


Looks like something messed up. The D partition and shares will only be created after the connector is successfully installed. The server will reboot and then it will be there.

Link to comment
Share on other sites

Thanks for the reply. This whole mess is really testing my sanity lol.


It would appear to me that the only common denominator here is the recovery disc from Acer. I'm now somewhere around the 12th attempt at restoring the system, and while I have been experiencing additional problems with even getting the restore started when attempting through Windows XP Mode, the symptoms have generally remained more or less the same with every try.


As I see it my options are beginning to run out. I ordered a debug board/vga adapter, so once I receive it I can try a few more things, but honestly I'm getting to a point where I think i'm just gonna have to give up on WHS v1. From there I suppose I can use the adapter and install a different OS. I have a copy of Server 2012 Essentials (not R2), and I've heard of people having success with installing it, though I'm a little concerned about it likely being very slow, as the H342 only barely meets the minimum specs. I could also get WHS 2011 for around $50 online and have that hold me out until I can get around to building a more robust system (which I was planning on building later next year anyway). Though I'm sure it would be very hard to locate one, but suppose I were able to buy someone's recovery disc, would it work on my H342?


Other than the above, I really can't think of anything else I can do here. Well, unless someone here can offer some magic solution... Any thoughts?

Link to comment
Share on other sites

I actually managed to find a WHS v1 OEM disc online (hadn't previously had any luck on this and assumed they weren't really around anymore). The disc and the debug board should be arriving by the end of the week, at which point I'll give it a try. If I run into issues, i'll definitely get a copy of WHS 2011 and give that a whirl as well.


I also just realized that I forgot to specify that the original system drive did not actually fail, yet. It was making a distinct scratching sound and I knew it wasn't gonna be long till it died. That being said, I never went about reformatting it. As I'm waiting for a few days to make my next move, I reinserted it into the H342 and confirmed it is still working. The server is technically working as it did originally, minus the data that has since been wiped (though backed up). I'm going to keep the server powered down though until I can make another restore attempt.


Anyway, I read something last evening about someone having success with cloning their failing system drive to a new one, and as long as they made sure to copy the drive's id to the new one, and did a few changes in the registry, everything seemed to work. Now, this would really be my last ditch effort before I'd go about switching OS's. I appreciate the advice about switching to WHS 2011, but as I mentioned earlier, I'm planning to build a 2012 Essential server later next year, and until then I'd rather stick to what I'm familiar with, especially as it seems a few additional options have surfaced since yesterday.


I will certainly give an update once I've got a chance to try the above ideas out. Thank you all for the replies!

Link to comment
Share on other sites

It is true that since the original disk contains Power Pack 1 which does not support 64 bit OS when you install the connector on the PC. You have to use a Windows XP or 7 32 bit OS. Then once the server finishes it's installation and you get PP2, PP3 UR1 and UR2 through Windows Updates, you will be set. Then there will be a 64 bit connector.msi file in the \\server\Software\Home Server Connector folder.

When you get the debug cable, if you want to use a USB keyboard from the BIOS, you have to add a small jumper to the servers motherboard.

Link to comment
Share on other sites

I thought I read somewhere that Windows 7 wasn't supported until the server had updated? Anyway, I do have a laptop with 32-Bit 7 and a Virtual PC with Vista Business 32-Bit, and also XP Mode on my 64-Bit 7 desktop, so I should be good to go. The debug cable should come with the jumper, so I should be good on that too.


The only question lingering on my mind is how exactly will I boot the OS disc on the server? I have very little experience with actually creating ISO's, though I have burned existing ones into bootable media before without any trouble. It isn't possible for me to select my pc's optical drive through the network on the server's boot-up is it? I recall doing something like that in my training, but I think it was on something else than Server 2003. Furthermore, if I were to get an external USB optical drive, could I just hook that up to the server and run the disc that way? Been thinking about getting one of those anyway..

Link to comment
Share on other sites

You don't boot the server from the OS disk. The OS disk is run at your PC. You put the server into recovery mode by holding the reset pin for 5 seconds while you boot the server. That triggers the server to look on your network for the Server Recovery Disk. Then you run the program on your PC and it will search your network for the server you just put into recovery mode. When found, it will then install the OS over the network.


You don't have to burn the OS to disk if you downloaded the ISO. You can just install a program like Virtual Clone Drive that will mount the ISO and look like a DVD drive.  http://slysoft.com

Link to comment
Share on other sites

Ok, I have some updates to share.


I think you may have misunderstood me earlier. I managed to find an OEM WHS v1 disc online, meaning the install process would be quite different, right?


This is what I've done so far. The debug board has worked admirably, allowing me to get into the bios and set the boot sequence. I got an external dvd drive, which I booted from with the OEM disc inside. I got all the screens shown on this page: http://www.howtogeek.com/howto/windows/installing-windows-home-server/ , up until the server reboots. Then instead of the installation continuing, I get a BSOD with the following error codes: *** STOP: 0x0000007B (0xF789EA94, 0xC0000034, 0x00000000, 0x00000000). It's done this 3 times now. I also tried making a bootable USB drive from an image of the OEM disc, but got the same result.


The only difference I saw otherwise from the images in the link was that on the format drives screen I had both my HDD and a USB drive listed (presumably the Acer restore image).

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...