Jump to content
RESET Forums (homeservershow.com)

WHS 2011, Remote Web Access/Router Error


Recommended Posts

DeStoriesAir

Please direct me to the correct forum if there is one for this issue, I was unable to find it. I am new to the server world and the detailed portion of setting it up.

 

I built a home server and I am running WHS 2011. The server is all set up and it communicates with all the wired/wireless computers that have access to it that are on my home network. Internet works from the server as well. So in those cases it is working "perfect"

Now, I am trying to get the Remote Web Access started up and as it goes through the process then it comes up with this error:. 

"Some routers may not work properly with your server. Visit the support Web site for your router manufacturer and ensure that your router has the most recent firmware.

Some Internet service providers (ISP) block TCP ports 80 and 443 to prevent customers from remotely accessing services that are hosted on their network. For more information contact your ISP"

 

I logged into the router by going to 192.168.1.1 and put in my name and password.

I checked:

Firmware: updated

Port forwarding: turned ON

Remote Management: ON

UPnP: ON

Under the UPnP Portmap section it shows ports 80 and 443 as active.

 

So im thinking there is something else that I have to do on my router to properly set it up. Please let me know if there is more information that you would require to be diagnose it for me. I do not know enough about that portion to be able to do that.

Can I get help on doing that please. It is the last thing I need for my server network.

Thanks Justin

 

Link to post
Share on other sites

First of all TURN OFF UPnP - it is a HUGE security risk. (Not a big of of Remote Management either) You are missing Port 4125 that needs to be forwarded.

 

Forward the ports need manually through the routers interface (Web GUI).  Your particular router may not allow the traffic for Remote access to work properly form an internal (Local) IP

  • Like 1
Link to post
Share on other sites

Agreed.  Not sure which home router you are using, but mine is the old Linksys WRT54G, and its working fine for remote access.  Just find the tab in your GUI that says somethink like "port forwarding".  mine gives me a box on the left for a name, then the port ranges boxes. 

 

You will need to make 3 separate entries with the ports of (name below can be the same, I made mine WHS)

 

Name.."from 80" .."To 80"..TCP..and your server address (192.168.1.x)

 

Name.."from 443".."To 443"..TCP..and your server address (192.168.1.x)

 

Name.."From 4125".."To 4125"..TCP..and your server address (192.168.1.x)

 

This way your router knows that any "incoming" info (for remote access) that comes in on ports 80, 443, or 4125 will be forwarded to your server.

 

See if that works for you.

Link to post
Share on other sites

You should also set your server to a static IP address.

 

My ISP blocks port 80 but not 443. So I still get an error from the wizard because 80 is blocked. However, I can still access my server remotely because I setup RWA with Microsoft Live ID which uses 443 https://

 

Link to post
Share on other sites
DeStoriesAir

Sorry forgot to say that my router is a Netgear Surfboard SB5101U.

 

1. Ok so I went into my port forwarding section and added port 80,443, and 4125.

2. I turned off the UPnP like suggested.

3. I notice when I was trying to setup the 4125 it was giving me an error saying that it already is being used.

4. I then went into the Remote Management section and noticed that 4125 was in the port name. I unchecked remote management off....and I was able to add 4125 in the port forwarding section. 

5. My Remote Management address is http://72.201.220.43:4125. Doesn't seem right to turn off remote Management.

 

There is something that I am doing that is making it not work still.

I just attempted in WHS to configure the Remote web access section and now it is giving me the UPnP is not enabled on the router.

Any more ideas?

Link to post
Share on other sites
DeStoriesAir

yes i did assign the ports to the server.

 

Ok that does seem to work now. On WHS it shows up with errors.

Yes i did create a domain name as well.

 

I will have to find another thread probably for this question so maybe you guys can guide me.

 

So at home i can access my server and make changes to folders and open and close files no problem. But anyone that logs in (outside of my server) through my domain name can really only download and upload onto there computer and my server. I was hoping for the features of the outside user to be able to just access files and folders and make changes without having to upload and download anything. is this possible with WHS 2011?

Link to post
Share on other sites

Forget about the error on the Dashboard.  It is working just fine it you can access it via your domain name.

 

Just make sure you either have a static IP for the Server or a reservation set aside in the DHCP table in the router.

  • Like 1
Link to post
Share on other sites
Drashna Jaelre

First of all TURN OFF UPnP - it is a HUGE security risk. (Not a big of of Remote Management either) You are missing Port 4125 that needs to be forwarded.

 

Forward the ports need manually through the routers interface (Web GUI).  Your particular router may not allow the traffic for Remote access to work properly form an internal (Local) IP

I agree with turning off UPNP on the router. Great idea, broken implementation.

 

 

As for ports, on WHSv1, you need 80 (http, and debatable, everythign redirects to https), 443 (https) and 4125 (RD Web Proxy)

On WHS2011 you ONLY need 80 (http, again debatable) and 443 (https and RD Gatway).  Remote desktop is done via the Gateway (which is more secure anyhow) and done over port 443. There is ABSOLUTELY NO REASON TO OPEN 4125. Any recommendation to do so is from info carried over from v1, and is incorrect.

 

 

Alternatively, you can use "Shields Up" to see if the port is open (and which are, actually) https://www.grc.com/x/ne.dll?bh0bkyd2

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...