Jump to content
RESET Forums (homeservershow.com)

Server 2012 Essentials R2 Backups failing


Pete
 Share

Recommended Posts

My server is failing at backing up itself and also not backing up clients.

 

I have an Icy Dock dual bay (2.5" SSD and 250GB 3.5") in my ODD bay of my HP N54L and full compliment of 4*2TB drives all other bays. I also have a SansDigital 4 bay box hooked up via eSATA with PM enabled.

 

My drive letters are setup as follows:

 

C: - 128GB SSD OS

D: - 250GB drive

E: - 2TB drive

F: - 2TB drive

G: - 2TB drive

H: - 2TB drive

I: - Drivepool (7.8TB) {all my shared folders and client backups pointed here in server}

 

M: - 1TB SansDigital drive 1

N: - 1TB SansDigital drive 2

O: - not assigned, reserved for SansDigital drive 3

P: - not assigned, reserved for SansDigital drive 4

Q: - Drivepool (2TB) SansDigital

 

USB external drive

X: - 1.5TB (1st partition)

Y: - 1.5TB (2nd partition)

 

Right now I have no data on any of my drives other than the OS on the SSD as it is a new server.

 

Test client computer has been joined to the domain, connector software installed and shows up in the "Devices" portion in the Dashboard.

 

I have my server backup pointed at the 250GB drive, and have only the OS system files set for backup. 

 

For some reason when I pointed my server backup to my D: (250GB), it deleted the drive letter and reformated it.  Now in my Disk Management I see the 250GB drive, but no drive letter.

 

I was going to try pointing server back ups to external 3TB drive via USB, but it wanted to format my drive that already is partitioned in half and has my Home Server v1 backups on it.  So I said 'NO'.  I'm going to copy the external backups to my drivepool, then try to point the server backup to the external, and when it says to 'format' I'll say yes.

 

Link to comment
Share on other sites

  • Replies 34
  • Created
  • Last Reply

Top Posters In This Topic

  • Drashna Jaelre

    4

  • jmwills

    7

  • ikon

    5

  • Pete

    11

Just assign a Drive letter to the drive in the Disk Mgt applet..  One of the main reasons backups fail is because of bad sectors.  Scan the drive.

Link to comment
Share on other sites

Do you mean that you're using the D:\ drive for the Server Backup drive? 
If so, I'm guessing you used the "dedicated drive for backups" option. And if that is the case, then what you see is expected. It removes the drive letter, and formats the disk. And then only uses the drive for backups.

Link to comment
Share on other sites

ok, during lunch, the backup to drive D: failed again.

I just got home, verified my copies of backups from External to my Q: drivepool (good), so set server backup to external USB.

ran forced backup.  same error...

"Windows Backup failed to create the shared protection point on the source volumes. Detail error: The shadow copy provider had an error.  Check the System and Application event logs for more information"

Checking the windows application event log says "volume shadow copy service error: unexpected error......The boot file is too small to support persistent snapshots. blah blah blah, windows code follows..."

 

If I cant get backups to work on this, I'm going to have to roll back and try WHS 2011.

Link to comment
Share on other sites

Server backup or Client backups?  If Server, you will not see that drive listed in Explorer.  the only place within Windows you will see it will be in Drive Management and I believe it will show as offline.

 

Client backups will show as any other normal drive.

Link to comment
Share on other sites

Last night I had 2 client backups succeed, and saved on my I: drivepool.  Server backup pointing to the external USB drive still failing

looks like I'll have to roll back to 2011 if I can't figure out how to get server backup to work.

Link to comment
Share on other sites

yes, the external and the 250GB drives showed up in disk management prior to me running the "setup server backup" wizard.  It made me choose a location, which on separate times I chose either the 250 or the external.  It said they would have be reformatted, OK, then give it a label, then finish.  Going back to disk management, drive shows up, but drive letter has been removed.  I tried a backup, fail.  I go through all the steps, give it a new drive letter after last step. fail.

 

2012R2 E, doesn't like me.  im going to install SBS2011 E on another SSD, and see how that goes. Will that affect my Stablebit Drivepool I created under 2012R2 E? (another thread I started).

Link to comment
Share on other sites

I have been in contact with MS support for this same issue.  Basically VSS is broken in 8.1/2012 R2.  If the client is running 8.1, backups of the client will fail.  If the server is 2012 R2, server backup will fail.  Currently it is basically impossible to do an image backup of a machine running Windows 8.1 or Server 2012R2.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...