Jump to content
RESET Forums (homeservershow.com)

N54L BIOS help


Pete
 Share

Recommended Posts

Ok. I just got my new N54L and I installed 8GB RAM and the BIOS mod so I can enable port multiplier so I can use my SansDigital 4 bay external box.

 

Now, installation questions. I've installed WHS2011 onto a 64GB SSD, and S2012E on another 64GB SSD so I can play with both OS and see which route I want to go. For the above I have install disks and created bootable USB sticks as I was thinking that installing from USB would be quicker.

 

Ok. So when going to install WHS2011. I had the SSD connected, a bare USB stick with the cig.ini file and the USB stick with the install files. In the BIOS, it sees all the above devices as hard disks. I put them in order as disk 1 SSD, disk 2 USB install files, disk 3 USB cig.ini file. Going to boot priority it only gives me 2 options: SSD and network boot. So I shut down, hooked up an external DVD-ROM drive, and then I was able to choose DVD -> SSD boot. So I didn't use the USB install files, installed from DVD and it took like forever.

 

Then as I was reading the forums about S2012E and how to just put the cig.ini file on the USB with the install files, I tried that. I put the S2012E DVD in, plugged in the USB with install files and cig.ini file, set my boot to DVD -> SSD. I had disk 1 set to SSD and disk 2 as the USB stick. Anyways, as it booted up it booted from the USB. Took out the DVD as it wasn't even accessing the disk at all. Install went fine. No issues.

 

Obviously I'm missing something in the BIOS, but it's working.

 

I tried the 2nd method above with S2012E-R2 and it worked....to a point, but some where in the install it rebooted and it ran the install from the USB again (it was at the install option the next morning when I woke up). I had already put in the product key and saw it installing files the night before, so I was expecting it to be waiting for me to input the admin passwords, change time, give it a name and all that, but it was at the install option again. Is this due to the NIC issue with the N54L?

 

Also I'm having issues following the post about enabling port multiplier. I'm unsure which options to enable in the BIOS and then there is the link to download AMD chipset drives for the SB580 but I can't find the drives on the AMD drivers/support page. Ug....so much problems.

Sorry. But is there a dedicated thread to the N54L somewhere?

Link to comment
Share on other sites

Update:

 

ok I figured out how to install with USB stick. This worked on the N54L installing WHS2011, S2012E, and S2012E-R2. 2011 and 2012E were installed on 64GB SSD and R2 was installed on 128GB SSD.

 

In the BIOS under boot, set the hard disk 1 to the SSD, disk 2 will be the USB stick. Set boot priority to SSD. 2nd option doesn't matter. I didn't even hook up the DVD drive. Of course with R2 you have to disable the on board NIC. I used a USB to Ethernet dongle and it worked fine. Anyway, reboot the server. It will look at the SSD first and since it is blank it will boot off the USB stick. Once the initial files are loaded it will reboot and the SSD will continue to load. For the smaller SSD drives just put that cfg.ini file on the USB stick and it will install.

 

2011 had almost 200 files to download during windows update. 2012E was 50ish. R2 was like 5. And surprisingly, R2 has given me the least amount of trouble with the numerous rebooting during install and updates. 2011 and 2012E would get stuck somewhere and I would have to hard shut down. R2 is golden. No issues other than the on board NIC not working. It's ok I guess. I have a Rosewill dual gigabit NIC on the way for 1 slot and the other is the R640L SATA card so I can use port multiplier and use my Sans Digital 4 bay external box. Just don't have 3rd slot for USB 3.0 card. Bummer. If ever the on board NIC drivers get fixed then I can pull out the dual card and put in a USB 3 card. We'll see...

 

Thanks guys

Link to comment
Share on other sites

It would make sense that WHS2011 would have that many files to completely update.  It's running on a Server 2008 platform.

 

I've built about five 2011 servers and never had the shut down issue you describe.  I will also agree the R2 has been flawless for me.

Link to comment
Share on other sites

Thanks for the posts PJW.

 

I suspect for the R2 install you could have shut the N54L down after it started the 1st reboot and removed the USB stick, OR, if the install still needed the cig.ini file, you could have entered the BIOS as part of the 1st reboot and reset the boot order to get booted off the SSD.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...