Jump to content
RESET Forums (homeservershow.com)

USB 3.0 / USB 2.0


Poppapete
 Share

Recommended Posts

I am led to believe that USB 3.0 is backwardly compatible but I have a few devices that seem not to work with USB 3.0 . All USB drives seem to have no problems. I cannot get my Logitech unify system or my cyberpower powerpanel software to work on 3.0 .  I have tried to upgrade drivers but I am told they are all up to date. The Viewsonic touch screen also has trouble with 3.0 . I have an asus MB which uses both Intel and ASMedia controllers. I am running out of USB 2.0 ports!!!!

 

Does any one else have this problem?

Link to comment
Share on other sites

I've gotten sporadic results with non-drive devices hooked to USB 3.0 ports. I once hooked up a Jabra headset to a USB 3.0 port and while I could hear participants on the Microsoft Lync call just fine, the folks all said whenever I spoke I was really crackly. Switching to a USB 2.0 port solved the problem.

 

That said, I use only drives with USB 3.0 and never have a problem.

Link to comment
Share on other sites

Turns out all my USB3.0 stopped working altogether when I upgraded to 8.1

 

Took me 3 hours to work out it is a problem with some asus boards with USB 3.0 Boost ( which I never new I had or used).   Reloading the USB_Boost_V10403 fixed it. Thanks to ekphoto in the Microsoft Community Forums.

 

I had opened the box and checked all the USB connections, so I did a big dust clean at the same time.

 

I went into the BIOS and checked all the USB settings and learned all about USB legacy and xHCL.

 

So not a complete waste of time.

Edited by Poppapete
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...