Jump to content
RESET Forums (homeservershow.com)

EX495 lack of remote access

Mr Bill

Recommended Posts

Good day all,

I am having a challenge with my EX495. It started about three months ago and I have not been able to find a resolution to the issue.


The symptoms are that I can get to the main external web page.


That portion works properly, but as soon as I click on any of the links to access files and or access network computers, I get the following error message;


This page can't be displayed


•Look for the page with your search engine.

•Refresh the page in a few minutes.

•Make sure TLS and SSL protocols are enabled. Go to Tools > Internet Options > Advanced > Settings > Security


I have tried this locally and remotely and get the same result.

Nothing has changed that I am aware of that may have caused this.

I have verified that the following ports are open both TCP and UDP; 80, 443, 4125, and 3389.

I have looked into the event logs on the server and don’t see any issues when I attempt to connect.


Any input that you can provide to help me troubleshoot this would be greatly appreciated.



Mr. Bill

Link to comment
Share on other sites

Hmmm.... :( I don't like that.


Can you remote into the server? If so, do that, and then try browsing "http://locahost/remote/". If that doesn't work.... well.... f***... Because if it doesn't work on the server, then that means the website is corrupted/damaged. You may be able to roll back the config (right click on the server, it has a backup/restore option, IIRC, that you can revert back a few days/weeks/etc... but don't roll back to the initial config... you'll be sorry).


But chances are, if it doesn't work on the server, you may just want to do a server recovery and be done with it.

Link to comment
Share on other sites

You said you looked in the Event Log, but which log specifically? In most cases, application errors get written to the Application log. However, if you're running WHS 2011 or WS2012 Essentials, you may want to drill down into the Windows Server log too. Oftentimes errors related to the WHS 2011 / 2012 Essentials platform get written there, particularly with services such as the client computer backup service.


I would also turn off IE's "friendly HTTP error messages," which can be done in IE > Internet Options > Advanced tab. I have nothing but the utmost disdain for IE's "friendly" error messages because they hide the real error message returned by the server. "The page cannot be displayed" is way too generic.


If you're running WHS 2011 or 2012 Essentials, you can re-run the remote access setup. It will go through and make sure things are set up correctly, including ports. If you've recently installed anti-malware and/or firewall software on the server, it could block the ports. DHCP is also a tricky one--if your server uses DHCP and its IP address changes, that could mess up your port forwarding.


For my WS2012 Essentials box, I use a static IP. However, there are some folks in the WHS world who frown on using static IPs for a WHS/Essentials box; in those cases I recommend using a router that supports DHCP reservation. This allows you to tell the router's DHCP server to always assign the same IP address to a specific MAC address. You just provide the MAC of the server's network card. This way the server still uses DHCP but it will never "lose" its IP to a different machine. This, of course, makes port forwarding much easier because you never have to worry about the IP address changing.

Link to comment
Share on other sites


When RDP into the server and go to https://localhost/remote/ I get an error screen.


There is a problem with this website's security certificate.
The security certificate presented by this website was issued for a different website's address.

Security certificate problems may indicate an attempt to fool you or intercept any data you send to the server. 
We recommend that you close this webpage and do not continue to this website. 


If I connect on thru (not recommended) it connects and works properly.

So, I am thinking that it may be a certificate error.

Link to comment
Share on other sites

As Drashna says, cert errors when using localhost are common. The good news, if you can call it that, is that the website itself seems to be working, so it seems to be something related to how it's being accessed.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...