Jump to content
RESET Forums (homeservershow.com)

HP Gen8 -- Keyboard issues


nleistad
 Share

Recommended Posts

New Gen8 Microserver, attempting WSE2012 (re)setup.

 

Initial setup on pair of 80G HDs while waiting for 3TB drives to arrive. Struggled w/ getting system to recognize KB, and external USB DVD for install. Somehow, it finally worked... then 3TB drives arrived.

 

Installed new drives but can't get system to recognize KB. Have tried Logitech USB KB, HP USB KB, tried ALL USB ports (4 on back, 2 on front, 1 inside). Managed to catch an F9 for setup once, but couldn't enable external USB. Never been able to access F5 for RAID configuration.

 

I have READ no instructions just in case I'm supposed to use particular ports for KB/Mouse. Feel free to call me an id10t should it be that simple.

 

Wondered if I'd possible fat-fingered the base USB and disabled?? What is procedure to do bios reset? Attempted battery removal, but haven't googled for "shorting" jumper?

 

While I'm at work (now) and unit at home, I BELIEVE I've had issues finding USB ports that are happy w/ my Samsung USB-DVD external in regards to powering the unit; specific ports for Optical Drive?

 

Anyone noticed at which stage of boot the USB ports are powered? I can't even get an HP optical mouse to light up (tried all the ports except the internal one for mouse).

 

Old time Windows guy but last 18 years RH/CentOS Linux, some BSD... Hoping this would be easy? Maybe I'm just making hard.... Nearly to point where I'm suspicious of hardware but also familiar w/ PEBKAC, leaving me feeling a bit sheepish for even having to make this post.

 

Thanks for the help. Looking forward to meetup.

Link to comment
Share on other sites

OK, so if you disconnect everything that's non-essential (e.g. add-in cards, extra RAM, all drives) and power on, does the KB work? Is it the OEM BIOS? If the BIOS is OEM and the KB still doesn't work, I sure would begin to suspect the hardware, unless there's some G8 magic or which I'm unaware (not actually having a G8 MicroServer to play with).

Link to comment
Share on other sites

"Struggled w/ getting system to recognize KB, and external USB DVD for install. Somehow, it finally worked."

 

So this USB problem has been a issue since you took it out of the box?  If this has NOT been a issue since you took it out of the box below information MAY help.  

 

The GEN 8 Manual (The manual is the only part of the Gen 8 I could afford :) states ;

 

"For additional security, external USB functionality can be disabled through RBSU" (I am not sure if the internal USB header will be helpful as the manual also states "An internal USB connector is available for use with security key devices and USB drive keys")

 

"USB 3.0 ports are not functional before the OS loads." (You said you tried all ports but I figured at least this could narrow it down).  

 

Other Gen 8's have a "erase utility" that will put the Gen 8 back to its factory state including resetting the RBSU so unless you can go through the ILO this might be a option. 

Link to comment
Share on other sites

If you can not even get into RBSU on the console, then try to connect with iLO.  Plug another network cable into the iLO port and it will get a DHCP address.  then power cycle.   The IP address shows on the screen as the system boots.  Launch the remote console and see if you can get a functional keyboard there to do the RBSU factory defaults and system erase,

 

If no luck there, then you should open an HP support case.  I've not seen any other reports like this except or people using the USB 3.0 ports before the OS loads (which is not supported on this box).  Buy you said it's happening with all ports

Link to comment
Share on other sites

Update:

Returned MicroServer to FACTORY, took out the 2 8G sticks memory, removed HD's. Using 2G HP Smart Memory, no joy on USB ports for KB/Mouse. Accessed via the iLo method, confirmed USB on, accessed setup, still can't enable "External" USB setting in BIOS (? will check suggestions from above). Re-installed 2 WD RED 3TB drives created mirror, partitioned 80G/remainder then rebooted; external DVD recognized and WSE2012 started loading but when destination for install reached, no drives appear. ???

 

And, yes, USB seems to have been flaky since unboxing.  The first time I got it to work I tried 2, maybe 3 KB before I found one that would light the status lights when connected. Noticed last night that system never gives KB status light flashes confirming it passed the POST like I'm used to on other PCs. I tried 2 wired KB and a wireless via USB dongle KB and got no response from any. Same KBs run home systems every day. Curious. Also curious to me that while I can't access the USB KB directlyattached, external DVD was accessible via remote management.

 

Question RE system start: apply power cable, switch turns orange; press Power, turns green blinks several seconds then fan starts and runs maybe 5-6 seconds, system shuts down for maybe 20 seconds then restarts. I've swapped memory, HD's extensively attempting to get this running; Is this considered normal? I'd like to say yes (while system recognizes and records it's HW configuration), but considered power supply as possible issue RE the USB ports. Moving into way too much analysis......

 

I was tired, trying again today, time permitting.

 

Thanks for replies and ideas on where to look. Much appreciated.

Link to comment
Share on other sites

Resolution:

 

Embarrassed and red faced in my new community. Guess it just needed a ride in the car. I have a couple of dogs like that.....

 

FWIW, keyboard appears to activate somewhere between verifying installed RAM and validating redundant ROM. MAYBE  I did way too much keyboard mashing ahead of lighting status lights on KB and fouled things up.

 

Tried FIRST by waiting and using MS keyboard, lights up right where described; second attempt w/ Dell KB, keys responsive in same area but status lights seemed to be a bit later. At first didn't think there were any (scrap keyboard from office "spare" pile), then noticed NUMLock was lit a bit later.

 

Intelligent provisioning seems to be better than manual ACU. Manual config was 80G boot, 2.7T data, WSE2012 never found drives. Intelligent Provisioning w/ "RECOMMENDED" created 2T partition and is now in process of installing. Discovery on what's possible once the system completes install will be next. Possibly BIOS has 2T limit? Seems odd. This thing will probably be an install/teardown unit many many times, so that's ok.

 

I'd like to thank all again. Appreciate it if you'd make allowances for the now obvious noise w/o substance. Patience...a lesson that I need to learn repeatedly it seems.

Link to comment
Share on other sites

Well, glad to hear it's all working; that's the main thing.

 

I think the IP issues you're having are one reason people start off with a small-ish boot drive, install the OS, then add larger data drives later.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...