Jump to content
RESET Forums (homeservershow.com)

onboard G8 NICs giving me errors - Ubuntu Server


seraph
 Share

Recommended Posts

Hi all,

 

was wondering if anyone could give me a hand with my G8 NIC issues...

 

Firstly, i installed Ubuntu Server 12.04 LTS onto microSD. I was doing it standalone firstly, so no network interface was present. After that i edited the /etc/network/interfaces file to enable eth0 to receive an IP address via DHCP. However when i enabled the interface, i got a whole bunch of errors that filled my terminal up with hex codes and the following lines:

 

  • Host status block
  • NAPI info <blah>
  • transmit timed out, resetting
 
I believe it's due to the Broadcom network chip.
 
Anyway, my first thought was that 12.04 was an old kernel, and maybe I needed a newer release. I tried 13.04 but i'm having the same issue.
 
Has anyone experienced this when setting up their G8? Any ideas that i could try?
 
Thanks all,
seraph
 
Link to comment
Share on other sites

  • Replies 35
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon

    6

  • schoondoggy

    3

  • FiLiNuX

    9

  • seraph

    12

Ubuntu 12.04 is listed as a supported OS for the MS Gen8. 

I would recommend installing the OS using Intelligent Provisioning. It seem to do a very good job of picking up the correct drivers during install.

The only thing I am not sure of, is if Intelligent Provisioning will install an OS on a micro SD card.

Link to comment
Share on other sites

reinstall ubuntu server and let it detect the NIC's during install as it will then pick the best driver the installer has available for your application.

Have you tried taking the nics down then putting them up again then sending out a dhcp request? Guessing your using eth0. I doubt this will fix your issue though but stranger things have happened.

sudo ifconfig eth0 down
sudo ifconfig eth0 up
sudo dhclient eth0

Edited by JayBee
Link to comment
Share on other sites

@Jaybee -

 

sorry i wasn't terribly clear on my first email - when i installed 13.04 i let the installer choose the NIC driver and it came up with something along the lines of "unable to configure network interface".

 

i've done the following commands post editing the interfaces file, but not sent out the dhcp request post bringing the interface up in a specific command:

sudo ifdown eth0 (or em1 in 13.04)

sudo ifup eth0

 

cheers - i'll try that.

 

@schoondoggy

 

I'm not sure how to install the OS using Intelligent Provisioning but i'll look into that too. As well as looking at the service pack stuff. Thanks for the help.

 

I just find it strange that i would be the only one with these issues when i'm using the stock standard ubuntu server image. if multiple other people have installed the stock ubuntu server image without error on a g8 - does that isolate me to a fault with my particular hardware item?

Edited by seraph
Link to comment
Share on other sites

I'm not to keen on installing an OS on an sd card in the first place, write speeds are way too slow in my opinion. Do you have a spare hard drive kicking around? Try installing ubuntu server on a spinning drive and see if it works as weirder things have happened. Ubuntu server can be really picky. Can you show me what you have in your /etc/network/interfaces file?



cheers mate. 

Edited by JayBee
Link to comment
Share on other sites

at work now so hopefully be able to play with it tonight... however a dinner out may hamper my endeavours.

 

with the intelligent provisioning stuff - doing some reading in my lunch break it appears that the ability to download the "proper" drivers and perform a "correct" installation is all predicated on having a functioning network interface... not something i have at this point in time! am i incorrect in this assumption?

Link to comment
Share on other sites

You would need to have the server on a network with internet access. Intelligent Provisioning makes its own network connections back to HP, as far as I can tell. It would not attempt to use your Ubuntu install. 

Edited by schoondoggy
Link to comment
Share on other sites

I"ll keep an eye on this topic tonight as i'm in a similar time zone to you (Melbourne) so just keep posting in this thread :)

Link to comment
Share on other sites

so my /etc/network/interfaces file has the following in it:

 

auto em1

iface em1 inet dhcp

 

auto em2

iface em2 inet dhcp

 

auto lo

iface lo inet loopback

 

 

funny thing, when i plug in the network cable to the second interface port and run sudo ifup em2, it acquired an IP address via DHCP almost instantly... it seems to be just em1 that isn't happy. ideas???!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...