Jump to content
RESET Forums (homeservershow.com)
bigladuk

Help moving from N36L to Gen8

Recommended Posts

bigladuk

Can someone more experienced that me please help before I loose all my data.

 

I've been running a N36L for several years running headless Ubuntu Server and 4 disks setup as JBOD so the Raid was turned off in the BIOS

 

I've now got my new Gen 8 ( Super Excited ) and have moved the memory and disks from my old to new server and turned it on.

 

My problem ( Which I didn't consider ) is that I can't get anywhere without configuring an Array via the RAID controller which I assume will wipe my disks.....is there a way to disable the RAID controller and just have the 4 disks presented as 4 disks ? Or can I create an array and logical disks without wiping my disks ?

 

My OS is installed on disk 1 

 

Appreciate any help

 

Thanks

 

Si

Share this post


Link to post
Share on other sites
schoondoggy

Do you have a backup copy of your data? There is a possibility that Ubuntu will not like the change in chipsets.

I am not near my Gen 8 so I am doing this from memory.

During boot up you will have the option to enter Setup by pushing F9.

Select the first item in the menu, when that expands the storage controller option should be the last item on that list.

Your choices are;

B120i RAID controller

Legacy SATA

AHCI SATA

 

Choose one of the SATA choices and save and reboot. The B120i should be off.

 

You mentioned moving the memory from the N36L to the Gen8. Are the modules fast enough for the Gen 8?

Share this post


Link to post
Share on other sites
bigladuk

Thanks for that.. Turned it off now :-) For reference to anyone doing the same the option I picked was AHCI SATA

 

The Gen 8 is certified for Ubuntu and I'm running 13.04 so was thinking things should be OK.

 

So far so good anyway

 

The memory I had in my N36l was KTH-PL313E/4G ( a pair so 8GB total ) and it seems to be working fine

 

My OS is all up and working now including iLo and everything so looks OK.

 

I guess time will tell

 

Thanks again

 

Si

Share this post


Link to post
Share on other sites
FiLiNuX

"You mentioned moving the memory from the N36L to the Gen8. Are the modules fast enough for the Gen 8?"

 

We don't know the speed of the OP's memory but they will work fine if they are the standard DDR3-1333. The speed will not be the same as using all DDR3-1600 BUT the difference would be unnoticeable in most cases besides benchmarks.  

 

Just saw your reply bigladuk.  I was very excited to see the Ubuntu support information on HP's site not long ago for the Gen 8's.  I believe I even posted it here somewhere.  

 

New Gen 8 + Linux is going to be a LOT of fun!!  Im jealous.  :)

Edited by FiLiNuX

Share this post


Link to post
Share on other sites
bigladuk

Thanks Guys

 

Everything seems to up and running just fine now, I've even licensed my iLo  :-)

 

Got to wait a week or 2 for the free switch to arrive but I've not a lot of use for it tbh

 

It's a very nice bit of kit and very well screwed together. My Satellite card worked right out of the box and now I have 2 NIC's i don't require my old 4 port NIC.

 

Si

Share this post


Link to post
Share on other sites
sdtex

Have been using WHS v1 for years.  Have been researching Ubuntu server as a possible replacement.   If you have the time to further document your Gen8 build and server setup would be greatly appreciated!

Share this post


Link to post
Share on other sites
bigladuk

Hi sdtex

 

More than happy to document my setup

 

My new GEN8 is more or less the same as my old N36l server with the RAID controller disabled and 4 disks inserted ( OS on a 3TB WD Green and the other three disks being 2TB Seagates ) setup as separate and single disks. I haven't bother with any redundancy and I haven't suffered any failures since I started running my Microserver maybe 3 years ago running 24/7.

 

I upgraded the ram to be 8GB ( max in the Microserver at the time ) and this is now in the GEN8 running fine.

 

The OS is Ubuntu 13.04 headless server and was installed very simply by blowing the ISO to a USB stick, connecting a monitor the server and then booting from the USB stick. The install is all GUI based and super simple to do. NOTE I simply removed my running OS & Storage disks from the old sever and simply put them in the new server and turned it on.....everything worked first time perfectly which I think it due to me being on the latest version the GEN8 being certified thus meaning all drivers are in the Kernel :-)

 

My server is used as a Media server ( NAS ) and CCTV so I'm running Headphones ( Music manager software ), Sickbeard ( TV Manager software ) , Couchpotato ( Films Manager software ), TVHeadend ( working with a dual Satellite Turbosight TBS 6981 as a PVR ), Zoneminder ( CCTV collecting and monitoring the feeds from my 2 IP Foscam cameras ), Webmin ( for management think control panel in Windows )  and finally Virtualbox ( for my Windows VM's )

 

My old server had a 4 Port NIC into that my VM's used but as the new server has a dual port NIC I won't need that anymore.

 

My biggest problem with my old server because it was headless and no monitor attached was getting to it if it was unresponsive or in an unknown state so the iLo is a god send for me in the new one :-)

 

Just a side note to compare the old to the new in a few things. My disks are now running at around 36℃ where as before they were running at around 45℃ so I assume the airflow is better. It also boots much quicker so I guess that the processor that making a big change

 

Hope that helps :-)

 

Si

  • Like 1

Share this post


Link to post
Share on other sites
ikon

I assume you have a robust data backup plan bigladuk?

Share this post


Link to post
Share on other sites
bigladuk

Nope. Nothing is on my server that can't be re acquired plus my internet connection is 330mb fibre so easy to re download.

 

Anything critical like photos are synced to the cloud :-)

 

Sent from my HTC One using Tapatalk 4

 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...