Jump to content
RESET Forums (homeservershow.com)
Joe_Miner

Has Anyone Loaded & Run WHS-2011 on a Gen8

Recommended Posts

ikon

most SSD dont have a temp sensor so they show as over temp.

 

This is one of those little, niggling things between manufacturers that needs to get ironed out.

Share this post


Link to post
Share on other sites
pcbrew

Has anyone else seen the Bay 5 OVERHEAT issue?  My fan sounds like it's running 100% when the system boots into WHS 2011.

I thought using B120i in RAID config and not AHCI would avoid fan problems. 

Share this post


Link to post
Share on other sites
ikon

Yeah, but if, as schoondoggy suggests, your SSD doesn't have a temp sensor, the b120i may be thinking it's way over temp and trying to compensate. I'm thinking HP, and other manufacturers, need to find a way to detect when a drive is an SSD and not even try to monitor its temp.

Share this post


Link to post
Share on other sites
pcbrew

OK, anyone care to report the SSD you are using and if you get this error and have high fan speeds.

There is no way I can use the box the way it is.

Share this post


Link to post
Share on other sites
microsvr.de

@pcbrew: Toshiba Q Series 256gb reporting overheating issue in ODD slot. I have put it now into slot1 and I will report on next reboot if the issue still occurs there. Right now, I really don't remember, alas the fan seemed to quiet down a little... I am at work right now.

Share this post


Link to post
Share on other sites
pcbrew
schoondoggy

I use the 2008R2 drivers;

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareIndex.jsp?cc=us&prodNameId=5387585&prodSeriesId=5379860&swLang=8&taskId=135&swEnvOID=4064&printver=true#11332

 

Be sure to update your firmware as well, BIOS and iLo have both had updates in September.

Edited by schoondoggy

Share this post


Link to post
Share on other sites
pcbrew

@pcbrew: Toshiba Q Series 256gb reporting overheating issue in ODD slot. I have put it now into slot1 and I will report on next reboot if the issue still occurs there. Right now, I really don't remember, alas the fan seemed to quiet down a little... I am at work right now.

 

Updating to report that the 120GB PNY XLR8 SSD I picked up at Fry's makes the BIOS happy and keeps the fans at low speed.  

I just re-installed WHS 2011 on the new disk and it's humming along quietly now.

 

Also wanted to pass along this link for free WHS 2011 security SW in case anyone was not aware of this:  http://homeservershow.com/forums/index.php?/topic/4802-installing-mse-in-whs-2011-from-command-prompt/

  • Like 1

Share this post


Link to post
Share on other sites
jabberwockie

If you are installing WHS on a drive that is running on the B120i you need to configure the arrays first.

Sorry for a stupid question -  does a SDD plugged into the SATA ODD port count as running on B120i?

Edited by jabberwockie

Share this post


Link to post
Share on other sites
schoondoggy

Sorry for a stupid question -  does a SDD plugged into the SATA ODD port count as running on B120i?

Of you have the B120i enabled then yes it is.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • E3000
      By E3000
      Hello all,
       
      A few questions for those who use Type-1 Hypervisors on their Gen8 MicroServers...
       
      I am looking to try ESXi or ProxMox and have been reading a lot of the threads on here.
      Hopefully you guys can help with some harder to find answers I have been seeking.
       
      1) Which would be the better way to setup ProxMox:
           a) Hypervisor on Internal MicroSD, VMs installed on SSD in ODD Port, Data on 4x HDDs in bays.
           b) Hypervisor on Internal USB, VMs installed on SSD in ODD Port, Data on 4x HDDs in bays.
           c) Hypervisor and VMs both installed on same SSD (partitioned?) in ODD Port, Data on 4x HDDs in bays.
           d) Hypervisor on SSD using a USB-to-SATA cable on Internal USB, VMs installed on separate SSD in ODD Port, Data on 4x HDDs in bays.
       
      2) Would a 128GB SSD be a ‘waste‘ for installing a Hypervisor on? How much space is typically needed?
       
      3) How many VMs have you guys run on a Gen8 comfortably without it being sluggish?
       
      4) Everyone seems to be going RAID crazy these days. Is there any reason to use it if high-availability is not that necessary and a good backup plan is in place? What is wrong with separate disks (or singular Raid0s)?
       
      5) Does using Type-1 Hypervisors have any effect on the internal fans speed/noise? Is it possible to have 3-5 VMs running and still have the fan speed @~8% as it was when I was using 2 nested (Type-2) VMs?
       
      Sorry in advance if some of these questions are silly, common knowledge, or “depends on what you are doing in the VMs!” 😆
       
      Thanks in advance to all those that help!
    • dxzdxz1
      By dxzdxz1
      This is my first post here but I've been lurking in this forum for quite sometime now, and from what I understand, the only reason that we couldn't achieve 32gb ram on the Microserver Gen8 was because there was no 16gb unbuffered ecc ram available before.
       
      I was searching for a memory module meeting this criteria and I found this one. My question is, letting aside this ridiculous price, is there any compatibility issue that could make this ram won't work on the Microserver Gen8?
       
      Most of the threads here about memory compatibility are quite old and I didn't want to revive an old thread just to ask this, so I'm creating this one.
       
      Thanks in advance.
    • radaxian
      By radaxian
      Hi all,
       
      Here's a guide I would like to share around Windows Storage spaces and creating a 4x drive Parity pool
       
      In a nutshell I have Windows Serer 2019 and storage space parity pool running very nicely on my Gen8. Here's the configuration I used and How to copy my setup.
      (I still believe ZFS or UnRAID are far better choice as a filesystem on these limited servers, but if you need Windows like I do, then storage spaces can be an excellent alternative.)
       
      This is my "best effort" guide and by no means perfect. It does however yield excellent results for both read and write speeds.
       
      Gen8 Microserver
      16GB RAM
      CPU Stock for now (1270 V3 on it's way)
      Disks  4x 3TB WD NAS drives in front bays
      SSD - Samsung Evo 850 265
       
       
      First lesson, DONT use the Windows GUI to create the pool or Virtual disk as the GUI applies terrible defaults that you can't edit and will ruin performance. Also make sure you're on the latest version of Windows server as a LOT has changed and been improved recently.
       
       
      You must use PowerShell.
       
       
      Terms:
      PhysicalDiskRedundancy - Parity Columns - 4 (The data segments stripped to disks. Should match your 4 disks) Interleve - 256K (The amound of data written to each "column" or disk. In this case 256KB interleave gives us a 64K write to each disk) LogicalSectorSize - 4096 PhysicalSectorSize - 4096 REFS/NTFS Cluster - 64K  
       
      Overall configuration:
      4 drive file system, one bootable SSD in RAID mode.
       
      BIOS setup initial
      F9 into the BIOS and set the B120i controller into RAID mode
      F5 into the RAID manager and create 1 individual RAID0 logical drive for the SSD
      Set the SSD as the preferred boot drive (Yes in the same screen)
      Set the cluster size to 63
      Enable caching
       
      Windows install 
      Install Windows 2019 Server Standard GUI edition from ISO
      Offer up the B120i RAID drivers via a USB stick so the wizard can see the SSD RAID0 drive. Filename p033111.exe (Have them extracted)
      Windows update and patch and reboot
       
      BIOS setup post windows
      Once windows is up and running go back into the F5 RAID manager and finish the setup of the 4 front drives into 4x RAID0
      Check the SSD is still set as the preferred boot drive (Yes in the same screen)
      Set the cluster size to 63
       
      Windows config of storage spaces
      At this point you should see 4 individual drives ready to be used as a Storage pool
       
      Try to set each disk to have a cache (Not all drives support this)
      Win + X to open the side menu
      Device Manager
      Expand Disk Drives
      Right Click the "HP Logical Volume" for each drive
      Check - "Enable write caching on the device"
      (If it doesn't work don't stress, it's optional but nice to have)
       
       
      Powershell - Run as Admin
       
      Determine the physical drisks available for the pool we're about to create
      Get-PhysicalDisk | ft friendlyname, uniqueid, mediatype, size -auto  
      Your output will look something like this, so identify the 4 drives that are the same and take note of their uniqueID
       
      Mine are the bottom four drives all 3TB in size
       
      friendlyname            uniqueid                                        size
      ------------                         --------                                        ----
      SSD
      HP LOGICAL VOLUME       600508B1001C5C7A1716CCDD5A706248        250023444480
       
      HP LOGICAL VOLUME       600508B1001CAC8AFB32EE6C88C5530D       3000559427584
      HP LOGICAL VOLUME       600508B1001C51F9E0FF399C742F83A6       3000559427584
      HP LOGICAL VOLUME       600508B1001C2FA8F3E8856A2BF094A0       3000559427584
      HP LOGICAL VOLUME       600508B1001CDBCE168F371E1E5AAA23       3000559427584
       

      Rename the friendly name based on the UniqueID from above and set to "HDD type"
       
      Set-Physicaldisk -uniqueid "Your UniqueID" -newFriendlyname Disk1 -mediatype HDD
       
      You will need to run that 4 times with each UniqueID code and create a new friendly name for each drive. I called mine "Drive 1, Drive 2" etc
      Set-Physicaldisk -uniqueid "600508B1001C2FA8F3E8856A2BF094A0" -newFriendlyname Disk1 -mediatype HDD Set-Physicaldisk -uniqueid "600508B1001CDBCE168F371E1E5AAA23" -newFriendlyname Disk2 -mediatype HDD Set-Physicaldisk -uniqueid "600508B1001CAC8AFB32EE6C88C5530D" -newFriendlyname Disk3 -mediatype HDD Set-Physicaldisk -uniqueid "600508B1001C51F9E0FF399C742F83A6" -newFriendlyname Disk4 -mediatype HDD  
      Verify the disks have been set correctly
      The following example shows which physical disks are available in the primordial server and CAN be used in the new Pool. You're just checking here if the friendly name renaming worked and they are all set to HDD type. Primordial just means on your local server and available.
      Get-StoragePool -IsPrimordial $true | Get-PhysicalDisk | Where-Object CanPool -eq $True You should see your four drives with nice names that you set like "Disk1"
       
       
      Now find out your sub system name, as we need this for the next command. Just take note of it. Example "Windows Storage on <servername>"
       
      Mine is ""Windows Storage on Radaxian"
      Get-StorageSubSystem  
       
      The following example creates a new storage pool named "Pool1" that uses all available disks and sets the cluster size.
      New-StoragePool -FriendlyName Pool1 -StorageSubsystemFriendlyName "Windows Storage on Radaxian" -PhysicalDisks (Get-PhysicalDisk -CanPool $True) -LogicalSectorSizeDefault 64KB  
       
      Now create the Virtual Disk on the new pool with 4x disks and Partity set correctly. (This is critical to do via PowerShell)
      New-VirtualDisk -StoragePoolFriendlyName "Pool1" -FriendlyName "VDisk1" -ResiliencySettingName Parity -NumberOfDataCopies 1 -NumberOfColumns 4 -ProvisioningType Fixed -Interleave 256KB -UseMaximumSize Those two commands should complete without error, if they don't go back and check your syntax
       
       
       
      Go back into the Windows GUI and open this
      Server Manager\File and Storage Services\Servers
      You should see the Storage pool listed and the Virtual disk we created in the previous steps.
       
      Storage pool - Pool1
      Virtual Disk - VDisk1
       
      Select Disks in the GUI
      Identify your new VDisk1 and right click it.
      Set to Online, this will also set it to use a GPT boot record
       
      On the same screen in the below pane Volumes
      Click TASKS and select "New Volume"
      Select REFS and Sector size of 64K
      Enter a volume name like "Volume1" or whatever you want to call it
      Select a drive letter such as Z
      (You can use NTFS here for slightly better performance, but I'm sticking to REFS as it has some benefits)
       
      You'll now have a Storage pool, Virtual disk on top and a volume created with optimal settings
       
       
       
      Go back into Power Shell
      Enable power protected status if applicable (Just try it, no harm)
      (Ideally here you should have your server connected to a basic UPS to protect it from power outages)
      Set-StoragePool -FriendlyName Pool1 -IsPowerProtected $True  
      Check if the new sector sizes of Virtual disk and all relevant settings are correct
      Get-VirtualDisk | ft FriendlyName, ResiliencySettingName, NumberOfColumns, Interleave, PhysicalDiskRedundancy, LogicalSectorSize, PhysicalSectorSize Example output
      FriendlyName  ResiliencySettingName  NumberOfColumns  Interleave  PhysicalDiskRedundancy  LogicalSectorSize  PhysicalSectorSize
      VDisk1                Parity                                      4                       262144                         1                                        4096                       4096
       
       
      You're done.... enjoy the new Volume.
       
      At this point you can share out your new Volume "Z" and allow client computers to connect.
       
       
       
       
      Some other commands in Power Shell that I found useful
       
      Get more verbose disk details around sectors.
      Get-VirtualDisk -friendlyname Vdisk1 | fl  
      Get-PhysicalDisk | select FriendlyName, Manufacturer, Model, PhysicalSectorSize, LogicalSectorSize | ft  
       
      Check if TRIM is enabled. This output should be 0
      fsutil behavior query DisableDeleteNotify If TRIM is not enabled, you can set it on with these commands
      fsutil behavior set disabledeletenotify ReFS 0 fsutil behavior set disabledeletenotify NTFS 0  
       
      Check the Power Protected status and cache
      Get-StorageAdvancedProperty -PhysicalDisk (Get-PhysicalDisk)[0]  
       
      Once your data has been migrated back to your new pool from backup, make sure you run this command to "spread out the data" properly.
      This command rebalances the Spaces allocation for all of the Spaces in the pool named SQLPool.
      Optimize-StoragePool -FriendlyName "Pool1"  
       
      I'm yet to get my Xeon in the mail, but once that's installed I think the disk performance will go up even higher as the stock CPU is junk.
       
       
       
       
       
       


×
×
  • Create New...