Jump to content
RESET Forums (homeservershow.com)

N36L and Smart Array P410 - not recognized anymore


BooyaK
 Share

Recommended Posts

Hi all

 

Great forum, have picked up some great tips over the last 18 months or so..

Props to @LoneWolf, @Joe_Miner, @diehard and others for the super work done to extend the functionality even more.

 

 

Have seen a sort of related issue to this by @tangcla, but mine is more fundamental in that the P410 not being seen at POST time now - no longer getting the Smart Array Option F8 init prompt or able to launch ORCA (Option ROM Configuration for Arrays)

 

Im running a HP ProLiant MicroServer N36L (8 GB RAM) / Smart Array P410 controller with 512MB FBWC module connected to 4 x 2TB SATA drives in a RAID-5 array running Windows Server 2012. The boot SSD drive (OCZ Vertex) is running off the ODD controller in AHCI mode and also have an nVidia PCIe in the x1 slot.
 
This was intermittent at first (couple of weeks ago), but became more and more inconsistent later now to the point that it doesn't appear at all.
 
My initial thoughts were while it still was intermittent was that it may have been a firmware issue - I upgraded to v6.00 several weeks ago especially given Im running Windows Server 2012, but then downgraded back to  down to v5.70 again - as an advisory warning stated that there were issues with v6.00 with some BL blade servers
 
 
At the BIOS summary screen (just before the OS boots) it shows that the PCIe in slot 1 as RAID and using IRQ10 (however don't always see this summary either…not sure what you need to invoke this)
 
Looking at the LEDs on the card, the only active LED is the last one - DS1
According to the HP Smart Array Controllers for HP ProLiant Servers User Guide, DS1is: 
"Diagnostics Error - One of the server diagnostics utilities has detected a controller error"
 
However, can't find any more info on what this means..
 
The LEDs on the FBWC module seems to be OK (i.e. just solid green - no amber nor flashing), so this is obviously being recognised by the SA410.
 
 
Other steps taken (some while the card was intermittently functioning others once it no longer appeared):
 
- Powered down server, removed all cables and removed / reinserted adapter card
- Removed other adapter in PCIe x1 slot (nVidia Display Adapter) so just the SA410 in the PCIe x16 slot was installed
- Upgraded to latest firmware for Microserver (just in case..)
- Cleared system board CMOS with jumper
- Put SA410 into another system - same result
- Changed various BIOS settings i.e. disable LAN, change AHCI to RAID and IDE for on-board card 
- Went to new BIOS ie had TheBay and upgraded to diehard one
- Went back to stock BIOS O41
- Was also getting BSOD (or its equiv now) in WS2012 prior to its total disppearance
- Looked at disabling / enabling SATA IDE Combined mode as per @Lonewolf and @Joe_Miner tips
 
I have looked around on the HP Support Center page as well to no avail..
 
 
Summary:
So Im thinking the SA410 has locked up somehow and not totally dead - given the LEDs function as noted above?
 
If so, is there a way to reset / clear the config on the P410 somehow via some undocumented jumper (or shorting something somewhere on the adapter board)? 
 
Finally, if I replace the SA410 (I have ordered another in case) can I just replace the adapter and it will reinstate the RAID info intact i.e. pick the Logical Drive info from the disks and give you a drive config mismatch?
 
Sorry for rambling on, but wanted to put as much facts down as I could..
 
 
Again, huge thanks in advance for your help !! :-)
 
Cheers
 
Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

  • ikon

    5

  • schoondoggy

    5

  • BooyaK

    5

  • Essexraptor

    5

When the system is running can the HP configuration software see the P410 so it can run diagnostics on it?

Have you tried running the offline configuration tool?

http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=us&prodTypeId=329290&prodSeriesId=3883890&prodNameId=3984646&swEnvOID=4138&swLang=8&mode=2&taskId=135&swItem=MTX-3c888073127c4c65b7bd8559eb

Edited by schoondoggy
Link to comment
Share on other sites

Hi schoondoggy

 

Thx for the quick reply..

 

Yeah tried ACU Offline diags (via SmartStart) as well -  no controller detected - that seems to be the common issue.

 

I tried this one, but wouldn't let me burn to USB key (using HP utility 1.6 and 1.7) - I could put SmartStart and Firmware upgrade to USB though (which both didn't detect)

 

Cheers

Link to comment
Share on other sites

Wouldn't ya know it; missed that one line. I think I was looking for P410 and he said SA410. Oh well, it sure looks like it's a bad card.

Link to comment
Share on other sites

Hi again

 

Thanks all for your replies and help.. :-)

 

I have tried it without the FBWC module / capacitor pack i.e. barebones and same symptoms

 

I have downgraded back to the TheBay firmware - where I can see the BIOS summary screen and the CTRL-S Broadcom BIOS

 

But still no joy unfortunately...

 

Cheers

 

Richard

Edited by BooyaK
Link to comment
Share on other sites

I had the same issue a while back. My problem was due to a faulty SAS to HDD cable. Even when the SAS cable was disconnected while I was troubleshooting, the controller would not be seen at POST. Once I replaced the cable and reattached the drives, it all started working again... One last thing to try before replacing the controller I guess.

 

If you replace the controller, the array configuration will be read from the disks automatically.

Edited by OmniouS
Link to comment
Share on other sites

Hi

 

Thanks for the help.. Waiting for the new controller to arrive - early next week hopefully  :)

 

 

Cheers

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...