Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
pandemonium

Unable to access HP N54L FreeNAS from outside my network

Recommended Posts

ikon

You should check the IP of your server. It did bother me a little that your port 9091 forward is to another IP, but I figured that WebTorrent is somehow using its own IP.

 

Is your server using DHCP to get its IP? If so, I strongly urge you to assign it a static IP or, even better, give it a Reserved IP in your DHCP server. It is possible, since WebTorrent is working, that your server has an IP of 192.x.x.20 and not 192.x.x.7. If that's true, then there is no way for ports 22 or 443 to work, since they're forwarding to an IP that is not the server's.

Share this post


Link to post
Share on other sites
pandemonium

Hey guys! Some good news finally!

 

First - Thank you for the link... I've downloaded the guide and have had a brief look at it... it does look interestingly detailed!

Second - I used my phone's personal hotspot to connect and was able to get through to all 3 port forwards successfully!! How cool is that?? The router's setup via GUI, the nas's setup via GUI and SFTP via Cyberduck. Yehay! I'm soooo happy! Thank you for your good advices and patience... I can totally understand noob questions can get under your skin pretty quickly.

 

 

You should check the IP of your server. It did bother me a little that your port 9091 forward is to another IP, but I figured that WebTorrent is somehow using its own IP.

The N54L's ip is 192.x.x.7 and the GUI for the Transmission (Torrents) plugin is 192.x.x.20. Yes, the plugin does use its own IP. Not sure why... its just supposed to... probably been setup as such.


 

Is your server using DHCP to get its IP? If so, I strongly urge you to assign it a static IP or, even better, give it a Reserved IP in your DHCP server. It is possible, since WebTorrent is working, that your server has an IP of 192.x.x.20 and not 192.x.x.7. If that's true, then there is no way for ports 22 or 443 to work, since they're forwarding to an IP that is not the server's.

No, the NAS has its own static ip (x.x.x.7).

Yes, its also reserved as a DHCP ip on the router.

No, as I explained above, the plugin is supposed to have its own separate ip... in my case x.x.x.20.

 

Awesome!! I am so beside myself right now! It works... it actually bloody works! Yesss!

 

Ah well... I can sleep easy now!  :rolleyes: Once again, thank you for sticking it through with me - you've no idea how much it meant to be able to ask someone a question and get an answer back. Thank you, thank you, thank you! Remember, the beer's in the fridge...

Share this post


Link to post
Share on other sites
ikon

yw.

  • Like 1

Share this post


Link to post
Share on other sites
FiLiNuX

I am VERY happy it works!!  

 

If you are at all like me (and most on here I feel) then there will be many more "learning" experiences while adding on more functionality to your already AMAZING SERVER!!!  In my short time in forums here It seems to me that EVERYONE learns not just the person asking the questions. 

 

"Transmission (Torrents) plugin is 192.x.x.20. Yes, the plugin does use its own IP Not sure why."

 

Remember back to setting up your machine that Transmission (the torrent client) IS RUNNING IN A JAIL  (no not because its been naughty downloading copyrighted material :).  

 

The SIMPLEST way to describe a Free BSD Jail to someone is that Jail is just like a virtual machine and as such it requires its own IP address. (If it is to be networked in anyway).

 

You are very welcome! 

  • Like 1

Share this post


Link to post
Share on other sites
stangri

I'm not familiar with that particular model (if it can't run OpenWRT I stay away from it), but I'm pretty sure it's your router or maybe even your provider. I've heard about providers blocking incoming requests to 80/22 ports (to prevent people from running servers on home computers or to block old malware on users' computers). Try changing the WebUI port from 80 to say 8080 and sftp port from 22 to 2222 in FreeNAS and adjust the port forwarding settings in your router accordingly. Or, if you can, just do the forwarding this way:

WANIP:8080 --> FreeNAS:80

WANIP:2222 --> FreeNAS:22

 

Let me know if that helps.

Share this post


Link to post
Share on other sites
ikon

OpenWRT?? Yikes, you're hardcore stangri! OpenWRT isn't something I would recommend to anyone but truly hardcore bit twiddlers.

Share this post


Link to post
Share on other sites
stangri

Actually I found the transition from Tomato/DD-WRT very mellow. OpenWRT does come with the Web UI for most routers and there's plenty of information online about tweaking it.

Share this post


Link to post
Share on other sites
ikon

I find Tomato the easiest to help other people to use, especially over the phone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...