Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
pandemonium

Unable to access HP N54L FreeNAS from outside my network

Recommended Posts

pandemonium

Hello again everybody,

 

I've come across yet another perplexing problem which I thought I should raise in a new thread, lest I muddied the waters on the other thread. Learning from previous errors... here's all relevant information up front.

 

Current Setup: HP N54L, 16Gb RAM, 5x1Tb HDDs, RAIDZ2, BIOS mod done (by reseller), assume IP=192.1.1.7

Router setup: VirginMedia Superhub, Ports 22, 80, 9091, 8080 open, assume IP=192.1.1.1, Assume static IP = 80.80.80.123

From my local network...

  • I'm able to ping to HP N54L internally from my lan
  • I'm able to SFTP to HPN54L (port 22) using Cyberduck/Filezilla
  • I'm able to access the gui interface to change settings on the (port 80 I think is the default port) using HTTPS
  • I'm able to access the 9091 Transmission plugins page to upload torrents
  • I'm able to access the GUI for changing settings on my router

From my work network (far far away in yonder land...!)... or even via my iPhone/iPad...

  • I'm able to ping home to my HP N54L with a reasonable avg time of 44ms
  • I'm able to access my router's GUI settings (port 8080)
  • I'm able to access the Transmission Plugin's GUII (Port 9091) on the HP N54L
  • I'm NOT able to SFTP to HPN54L (times out every time)
  • I'm NOT able to access the GUI interface to change settings (neither HTTP nor HTTPS work - both time out)

What I have confirmed so far:

  • Double checked that HTTPS and correct static ip are set
  • Double checked that gateway is correctly defined
  • Double checked SSH is correctly defined
  • Double checked that SSH is switched on in Services
  • Reinstalled FreeNAS from scratch 3 times!! Same result each time!

I seem to be getting through to my N54L, past my router - the Transmission webpage proves this. But, for some reason, my N54L won't accept SSH or HTTPS connections. Further, the fact that I've re-installed FreeNAS 3 times proves that either I'm not setting something at all, or, incorrectly setting something up each time - I just don't know what.

 

Over the weekend, I went through my BIOS to change the HDD speed from 1.5Gbps to 3.0Gbps... I don't think I changed anything else... but, I can't bet my house keys on this. Its only after changing the BIOS, that all external access to my network via SSH/GUI interface isn't possible.

 

Is there anything in the BIOS that I could have changed which would lead to this?

Is there anything in the setup that I could have screwed up?

How can I reset my bios to the default settings and start all over again?

 

Please help...!

Share this post


Link to post
Share on other sites
ikon

HTTPS uses port 443, not 80. It has to be forwarded in your router to your server.

 

Not sure why SFTP isn't working: port 22 is correct. Have you checked the port mapping in your router? Just having it open isn't enough; it has to be forwarded to your server.

 

You can PING your server from outside your LAN???? Really? I highly doubt that -- it should be in a Private Range, which is not PINGable from the Internet.

  • Like 1

Share this post


Link to post
Share on other sites
pandemonium

Thanks ikon...

 

HTTPS uses port 443, not 80. It has to be forwarded in your router to your server.

I didn't have to forward the 443 port last week... yet I was still able to access the SFTP, Settings GUI interface and Transmission GUI interface on my N54L from work using https://80.80.80.123 with only 22, 80 and 9091 forwarded.

I've got 22, 80, 443 and 9091 forwarded on my router currently. I'm still unable to access the web gui interface.

 

Not sure why SFTP isn't working: port 22 is correct. Have you checked the port mapping in your router? Just having it open isn't enough; it has to be forwarded to your server.

I've got ports 22, 80, 9091 forwarded on the router. 8080 is open for remote access to the router itself.

 

You can PING your server from outside your LAN???? Really? I highly doubt that -- it should be in a Private Range, which is not PINGable from the Internet.

My apologies... I think I've used the wrong terminology. I can ping my static address from work. Not the 192.1.1.7 address directly. So, in other words, I'm able to ping 80.80.80.123.

Edited by pandemonium

Share this post


Link to post
Share on other sites
FiLiNuX

Hi Pandemonium,

 

This may be a SUPER over simple suggestion but on your FTP software (that you are using from outside your LAN) do you have the protocol set to SFTP? (if this is a option on what you are using). 

 

BTW, you are the INFORMATIVE POST MASTER!!! :)  

 

You can also check SSHD for information about failed login attempts and more.  I really don't think its anything to do with BIOS.  There is usually a "restore default settings" option  or something similar in about every BIOS out there.  I am not running the mod BIOS on my MicroServer so I cant tell  you exactly where its at (IE: I am to lazy at the moment to google a picture of it :)

Edited by FiLiNuX
  • Like 1

Share this post


Link to post
Share on other sites
pandemonium

Hey FiLiNuX,

 

From work, I use Filezilla (Windows) and from home I use Cyberduck(OSX). And yes, the SFTP is chosen on both. I remember doing that because I read it in one of the tutorials out there.

 

Well, I got told off for not providing enough information last time... I suppose, if I were in your shoes, I'd be frustrated too for not being able to offer the right solution or being misled due to facts not being mentioned. Better to err on the safe side, I reckon.

 

Perhaps I may have missed the BIOS reset. I can't seem to find it on google either. Quest continues... Just too many variables over the weekend! I'd be happy if I were able to negate each one by one. I'll keep searching :)... thanks for your suggestions though.

Edited by pandemonium

Share this post


Link to post
Share on other sites
ikon

Hey, no problem pandemonium. Please don't take any comments as criticism; they're not meant that way, at all.

 

Just for ease of reference, what you call your 'static address' is what most people refer to as a 'WAN address' or 'WAN IP'. It's the address given to you by your ISP from their pool of addresses. I did figure out what you meant; it's just more common to call it a WAN IP.

 

It's really surprising that you could HTTPS into your server in the past without having port 443 forwarded in your router. The only thing I can think of that might make that possible would be UPnP, but you haven't mentioned it so I assume you're not using it. Without UPnP, you should have to forward port 443 to your server in order to access the server's secure web page from the Internet.

 

Is it possible for you to post a screen capture of your router's port forwarding page, so we can see how it's set up?

 

BTW, it's possible that your employer is blocking some of these protocols, which could explain why they don't work. BUT, I find it highly unlikely that your employer would block port 443; it's just used too much for everyday internet browsing. Have you tried using any of these protocols from any place other than work?

  • Like 1

Share this post


Link to post
Share on other sites
FiLiNuX

Sorry I wasnt more help bro.  Sometimes the EZ things get overlooked.  My comment about you being the informative post master was a compliment for putting together a perfect post / question.  A post like that shows a lot ESPECIALLY that you have worked on this & tried on your own.  Its the kind of post that makes (and helps) people want to help.  I cant stand it when someone posts a question and you can tell they have put ZERO effort into finding the answer themselves.   

 

 I did look in the Micro Server Maintenance Guide (its a PDF provided by HP and its full of useful stuff.  I would be happy to get it to you if your interested) and found the setting for "resetting" the BIOS.  I know you have the modded BIOS (I have never used it) but from what I have read about what the mod changes this should not be different.  

 

On the "Exit" tab select "Load optimal defaults" and it should "reset" the BIOS.  The manual says this "Loads the factory-default settings for all Setup fields."  Make sure you save the settings.  Also a good idea to look and note what the settings are at now for comparison / reference. 

  • Like 1

Share this post


Link to post
Share on other sites
pandemonium

Hi ikon/filinux,

 

All good here... I know you mean well. I honestly appreciate your help HUGELY - if you guys come by J26 on M1 by Nottingham, do give me a shout - the best in the bar awaits you! That's a promise.

 

WAN IP it is from now on :). And I haven't used/setup UPnP. I did look on my router and its enabled. Router's port forwarding settings attached. I've taken port 80 off a while back. Port 443 was forwarded after I read your message earlier this evening. Could indeed be the IT department at work closing down wormholes now... I don't know. I intend to take my laptop to work tomorrow and use my phone's hotspot to test when I get a few min free. I'll also dig up more info on what changes the IT guys have done over the weekend - it may well be this is the culprit and nothing is wrong in fact... just the access has been cut off! Please God... make this true!

 

Also, thank you so much for the Maint Guide. If you could kindly pass me a link, I'll grab it as well and go through it. Also, thanks for looking the BIOS reset process as well. I'll try it out tomorrow evening - been too many late nights so far! I know what to look for now in the BIOS... I just didn't realise it meant "RESET"... trust them to make it crystal clear huh... :)

 

Thank you both once again! Very much obliged for your help.

Screen Shot 2013-07-31 at 23.54.16.png

Share this post


Link to post
Share on other sites
ikon

I take it your server is at 192.x.x.7. If so, your port forwards look OK, at least for SSH & HTTPS.

 

Is the phone you're talking about your own, or one you can only use at work? If it's yours, and has Internet sharing (as you seem to imply), then you shouldn't have to wait til you get to work to try it out. You could do it from your own living room at any time. I have used my Windows Phone to test out port forwarding on my gateway. :)

  • Like 1

Share this post


Link to post
Share on other sites
pandemonium

I take it your server is at 192.x.x.7. If so, your port forwards look OK, at least for SSH & HTTPS.

I thought so too, and the fact that 9091 is forwarded correctly, proves it too. And everything did work till last weekend... I've changed nothing on the router for almost 2 weeks (except take 80 off and enable 443 last night).

 

Is the phone you're talking about your own, or one you can only use at work? If it's yours, and has Internet sharing (as you seem to imply), then you shouldn't have to wait til you get to work to try it out. You could do it from your own living room at any time. I have used my Windows Phone to test out port forwarding on my gateway. :)

On hindsight, why didn't I think of that before?  :wacko: I did try disconnecting the phone from my wifi and going 3G to test it though - which didn't work. I should also have done what you said... doh! Clever... huh!?! Anyway... its morning when you wake up, as they say. Will do that shortly & update.

 

Thanks once again.

Edited by pandemonium

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...