Jump to content
RESET Forums (homeservershow.com)

Acer Easystore H340 2nd failed drive


Recommended Posts

cluelessav

Hello all. I wanted to know if anyone thought that this was just bad luck or a problem with my Acer Easystore itself. A few months back I had a failed drive. I replaced the drive with a new one and the new drive failed again. I am just finding it hard to believe that the new drive would fail again so quickly. Can a drive bay have a problem that is causing the drive to fail? I am not really sure how to go about fixing the problem. I would hate to buy another drive and a few months down the road the same thing happens. The other thing that is troubling me with this whole thing is that if I remove the drive the light is not blinking red as though it is missing. Shouldn't it blink red regardless if there was a failed drive or not if the bay is empty? When I remove the other 2 drives the lights blink red until I put them back in. Maybe I am over thinking this, but I am just at a loss. Any help or suggestions would be greatly appreciated.

 

Thanks

Anthony

Link to post
Share on other sites

I haven't run my H340 for a while, but IIRC, yes, the light should blink (although I think or it more as purple or magenta than red).

 

That said, it is not at all hard to believe that a new drive could fail after a few months. It's actually quite common. It's the reason I always run any drives I'm about to put into service, new or not, through SpinRite. It's not perfect, but SR really helps me filter out drives that are likely to fail in the near future.

 

I would RMA the bad drive; get the manufacturer to replace it.

Link to post
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in



Sign In Now
×
×
  • Create New...