Jump to content
RESET Forums (homeservershow.com)
Sign in to follow this  
awraynor

CrashPlan Memory Usage

Recommended Posts

awraynor

I have been having trouble with CrashPlan for weeks but not investigating the problem.

Finally I e-mailed them due to the application analyzing files and not performing backups.

It was already using a GB of memory and they advised me to increase it to 2048MB.

 

So far it doesn't seem to fix anything and I am going to e-mail them again. I have never had 

a sync or online backup program take more than 100MB. The CrashPlan engine alone is using

a GB and the desktop app is using 125MB.

 

Am I alone or is this typical of everyone else?

Share this post


Link to post
Share on other sites
awraynor

And is there a way to delete a post as my topics frequently get double posted?

Share this post


Link to post
Share on other sites
ikon

Yes, you can delete posts. There is normally a button to the left of the MultiQuote and Quote buttons.

Share this post


Link to post
Share on other sites
Jason

I've experienced same issues with CrashPlan. Have yet to found a better, more economical service but their app is resource intensive. Fortunately my server has 16 GB RAM.

Share this post


Link to post
Share on other sites
awraynor

Yes, you can delete posts. There is normally a button to the left of the MultiQuote and Quote buttons.

I mean the entire topic, not a post within the topic. I wrote the post, hit submit and it is double posted. 

 

I've experienced same issues with CrashPlan. Have yet to found a better, more economical service but their app is resource intensive. Fortunately my server has 16 GB RAM.

 

They had me change the .ini file to where it was allowed 2GB of RAM which actually made it actually work and use 100MB less memory.

I was thinking about giving Bitcasa a try, just waiting for them to float another coupon where it is $69 for the year. Out of beta they had a coupon which

made it only $49 for a year, but I missed that.

Share this post


Link to post
Share on other sites
Jason

Would you mind sharing the exact .ini change? Would like to try it on my WS2012E box. Thanks.

Share this post


Link to post
Share on other sites
jmwills

Yes...there are many .ini files

Share this post


Link to post
Share on other sites
awraynor

I didn't uninstall and reinstall. I simply did the .ini edit and restarted, that worked.

 

 

Hello Anthony,

Thank you for sending your logs! It appears that the CrashPlan backup engine is running out of memory. I see that you've already increased the memory allocated to the CrashPlan backup engine to 1024, which should be sufficient to handle the size of your file selection and archive. Here's what I'd like you to do:

Running Notepad or any other text-editor as an Admin, edit the CrashPlan engine's CrashPlanService.ini file to allow it to use more java memory:

1- Stop the backup engine: http://support.crashplan.com/doku.php/how_to/stop_and_start_engine

2- Locate the Notepad program, right-click and Launch as Administrator

3- Go to File > Open, and navigate to C:\Program Files\CrashPlan\CrashPlanService.ini (note that you will have to change the option from .txt files to all files in the file selection screen in order to see the CrashPlanService.ini)

4- Find the following line in the file:

-Xmx512m

5- Edit to something larger such as 2048. E.g.:

-Xmx2048m

This sets the maximum amount of memory that CrashPlan can use. CrashPlan will not use that much until it needs it.

Since you've already increased the memory to 1024 and are still getting OutOfMemory errors, I would recommend setting it to 2048.

6- Start the backup engine.

Please let me know if you have any questions.

Share this post


Link to post
Share on other sites
jmwills

That makes perfect sense, except for needed two gigs of RAM....yikes.  I would also advise making a copy of the original file before editing.

Share this post


Link to post
Share on other sites
ikon

I would also advise making a copy of the original file before editing.

 

Good point. That's been so automatic for me for so long I often forget to even mention it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  



×
×
  • Create New...