Jump to content
RESET Forums (homeservershow.com)

Anyone successfully install Server 2012 R2 Essentials on a Microserver N36L,N40L,N54L ?


diehard
 Share

Recommended Posts

I enabled the builtin nic and it booted into windows but immediatly froze.

Ah, I had to boot into safe mode. Then went into Device Manager to change the nic drivers. But without success. I could not find the correct driver even from Broadcom.

Link to comment
Share on other sites

Has anyone escalated this to either HP or Microsoft?  I don't have a dog in this fight right now.

Link to comment
Share on other sites

  • 2 weeks later...

Been reading through this thread and from what I gather with the N40L's on board NIC there is no way to have a working Server 2012 R2 installation?

 

Anyone made any headway on this at all?  :(

Link to comment
Share on other sites

I'm still waiting for someone to post their log files.

If I get time, I'll bring my production N54L offline and do a test install to get the logs myself.

Link to comment
Share on other sites

So have just installed Server 2012 R2 Datacenter on my N40L with the on board NIC disabled, I loaded Mr_Smartepants' NIC driver at setup. Booted to desktop OK. Enabled the NIC in BIOS and it's booted to desktop, I can see the NIC in device manager but NIC is showing as disabled in Control panel. When I try and enable it it instantly switches back to disabled state.

 

Nothing logged in Event logs either.

I'll keep digging.

Edited by jpsj
Link to comment
Share on other sites

Can one of you with a stalled/failed install upload the following files:

\Windows\setup*.log

\Windows\Logs\DISM\dism.log

 

Maybe we can find the cause in there.

So you're saying these logs don't exist on your system?

Link to comment
Share on other sites

So you're saying these logs don't exist on your system?

 

I didn't get a failed/stalled install but can still upload the logs if you wish?

Link to comment
Share on other sites

I just wanted to post that I have windows 2012 server std running on my server.  I did not have to disable my nic.  Just did a clean install and it worked.  I have a N54.  Maybe it has an newer nic card in them?  

Link to comment
Share on other sites

I just wanted to post that I have windows 2012 server std running on my server.  I did not have to disable my nic.  Just did a clean install and it worked.  I have a N54.  Maybe it has an newer nic card in them?  

 

Good News!  With or without the Mod-BIOS?

 

We are talking about Server 2012 R2 Preview?

Edited by Joe_Miner
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Similar Content

    • oldwhs12
      By oldwhs12
      I have been running the WHS1 pack 3 for many years.  Unfortunately it is no longer working.  I got a Proliant microserver Gen10 hoping it will run it but was unable to install the software.  The software should run on most older PCs?

      Does anyone have the WHS1 running on the Gen10?  Also my WHS1 iso is Pack 1.  If I manage to install the Pack 1 can I find on the web the upgrade to pack 3?  Would I be forever stuck at Pack 1?  Any advice would be appreciated.

    • AVsonyfan
      By AVsonyfan
      All credit to schoondoggy for his original idea. A shame I am on the wrong side of the Atlantic to order an SDM kit as the import duties make it an expensive option, or would have if they were still available. I had to look around to see what alternatives I could find... and managed to find the bits needed on Amazon!
       
      I must admit I am rather pleased with the end result of this project and may repeat it on the other Gen8 MicroServer. The outcome is a server with a mirrored system drive on the internal B120i, and the main drive bays connected to an HP P222 card providing a RAID-10 data volume. This is pretty much my ideal setup for a stable resilient but small server.
       
      Sabrent 3.5" to x2 SSD Internal Mounting Kit (BK-HDCC)
      Amazon UK - https://amzn.to/32qEVou
      Amazon US - https://amzn.to/3h8Blom
      The kit comes with all the cabling you need and all the required screws to mount the drives and bracket.
      Two types of power splitter cables are included along with two SATA cables. The bracket holds two SSDs and provides a small gap between them.
       
      I mounted the bracket next to the PSU but leaving a 2-3mm gap to allow for some airflow past the SSDs in case they get warmed by the P222.
       
      Tips:
      Put some insulating tape along the underneath of the upper chassis rail next to the PSU and drilled three small holes.
      I used two strips on to stop the drill bit from walking across the metal. Drill with a 2mm first then a 2.5mm bit. This leaves enough metal for screws to thread in.
      Check and measure each hole against the bracket as you go so that they line up. Bracket is then fixed in place using the provided screws (see photo).
       
       
      The final part of the puzzle is another Mini-SAS to SATA cable the same as the one connected to the internal drive bays.
      This is an SFF-8087 Mini-SAS [male] connector to 4 SATA [female] header cables. The 50cm cable from Jyopto works great and not too much spare to lose within the system.
      Amazon UK - https://amzn.to/2CXAzgb
      I could not find it on Amazon US site but there was one from CableCreations that same length.
       
      Just need to add your choice of SSDs and cable up to B120i port.  I went with Samsung 860 Pro SSDs for the longer rated lifespan of write cycles.
       
       
      I decided to forget about an internal DVD/RW drive and opted for an external HP F2B56AA slimline drive that can be plugged into the USB of either system.
      Amazon UK - https://amzn.to/2EgSSxD
      Amazon US - https://amzn.to/326uFmL
       
       
      Sabrent also make a really good quality 2.5" to 3.5" bay converter adapter (BK-PCBS) that I have used in the EX490/X510 to convert from HDD to SSD system drives.
      Amazon UK - https://amzn.to/3jbYBmT
      Amazon US - https://amzn.to/335kXQz
       
      Hopefully this information will prove useful to some looking to update their MicroServer.
       
       
       
       

    • E3000
      By E3000
      Does anyone know if it is possible to get Agentless Management Service (AMS) running on Debian/Ubuntu Linux? It is always showing as Not Available in the iLO page and I have only ever seen this active in Windows.
    • E3000
      By E3000
      Hey guys,
       
      Has anyone around here been successful in setting up Proxmox on a Gen8 using a HBA for storage?
    • E3000
      By E3000
      Hey guys,
       
      As of June 2020, what are the latest versions of firmware for HP Microserver Gen8 to be installed on the system itself? Also do any other components have updatable firmware/os-independent software?
       
      So far my list is as follows:
      BIOS - J06 (04/04/2019) iLO 4 - v2.73 (11/02/2020) Intelligent Provisioning - v1.71 (20/02/2019)  
      and I guess the following could also be added (although both out of date):
      Smart Update Manager (HP SUM) - v8.1.0 (21/12/2017) Service Pack for ProLiant (06/11/2017)  
      Date formated as DD/MM/YYYY.
       
      I believe all the B120i Smart Storage stuff is part of Intelligent Provisioning.
×
×
  • Create New...