Jump to content
RESET Forums (homeservershow.com)

First Timer: N54L Windows Installation Woes


RossBrettell
 Share

Recommended Posts

Hi,

 

Having a few issues with my recent purchase and seems like a good place to ask for advice. Lots of knowledgable people here!

 

I've flashed the BIOS with the most recent information found here:

 

http://homeservershow.com/hp-proliant-n40l-microserver-build-and-bios-modification-revisited.html

 

Everything appears to have worked wonderfully and I have access to the additional settings in the BIOS.

 

I've also moved the stock 250GB HDD that came with the rig into the ODD slot. I've connected the HDD via a latching SATA cable to the ODD connector on the MOBO.

When I try and install Windows of any variety from bootable USB I get the error:

 

Unable to create system partition or find existing partition...

 

I've tried using diskpart to clean the drive, I've tried returning settings back to standard in the BIOS, I've tried removing the SAS connector for the 4 bays and still no luck. The drive appears in the BIOS and diskpart shows it during installation etc.

If I remove the bootable USB from the server, it tells me that I can't install to the disk as it has an unsupported version of NTFS on it, which can't be the case if it is brand new.

If I plug the USB back in, I get the same partition based error.

 

It appears that (like most other research shows) it has something to do with the computer not liking other drives. How do I get around it in this particular scenario?

 

What am I missing? Any help appreciated!

Edited by RossBrettell
Link to comment
Share on other sites

Welcome Ross.

I have no experience with this particular device, but one point in your post stood out.

Try connecting the HDD to another SATA port on the Mobo and see if that works.

Link to comment
Share on other sites

I'm with Renny.  That would help you rule out a bad SATA cable, bad USB drive, or a bad BIOS config.

Did you follow the instructions on the link you provided to build the USB installer and change the BIOS settings from IDE to AHCI?  

Installing the BIOS-mod is only 1 step of about 20 to get everything right on the N54l.

I have my install notes somewhere, I'll need to post them once I find them.

 

Here is Joe's instructions for installing WHS2011 on the 5th drive.

http://homeservershow.com/forums/index.php?/topic/4259-installing-whs2011-on-a-small-ssd-in-a-microserver/

 

I found that I had to make a folder on the USB drive root directory named $WinPEDriver$ and copy the AHCI drivers there before my install would work.

Link to comment
Share on other sites

Hi RossBrettell & welcome to the Forums!


You shouldn’t be having this problem.  I’ve installed OS’s onto the 250GB Stock HDD (VB0250EAVER) with no issue more times than I can count -- with and without -- the BIOS-MOD.  Most recently written about Here.  Here's an earlier install after the BIOS-MOD.


Have you installed OS’s onto other machines successfully with the Flash Drive’s you are using?  I’ve done all of my installs with either my ISO’s burned to DVD’s or using the Retail Installation DVD’s and using a portable USB DVD drive.  (I have lots of blank DVD’s and very few Flash Drives)  But I know quite a number of people have done their installs with Flash drives. 


Try doing your install with the VB0250EAVER in the first slot of the main 4 drive bay.



 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...