Jump to content
RESET Forums (homeservershow.com)
mehtaman

Slow network speeds on N54L

Recommended Posts

mehtaman

Hi,

 

I have recently set up a N54L with Windows Server 2012 Essentials.

 

Something within WS2012E appears to be slowing down my download/upload
speeds.

 

I have updated the NIC with the latest HP drive (19 Feb 2013).


There is no Anti-Virus installed, Windows Firewall is on but I have set an
Inbound and Outbound rule to allow all traffic.


The standard ports are open on the router e.g. domain.remotewebaccess.com works fine.


I have run a LAN Test (5MB File) and Speed Test from the server, then placed the Ethernet
cable into my laptop and run the same test, results below:

 

Server LAN Test and Speed Test:

Untitled_zpscd985524.jpgspeed_zps8f39cbc7.png


 

Laptop LAN Test (excuse the custom theme colour) and Speed Test:

 

Untitled_zps0947e277.pngCapture_zps4ce795a0.png

 

Any suggestions on what I can test / configure to improve the speeds?

 

Thank You

Share this post


Link to post
Share on other sites
mehtaman

Fixed after a few hours of tweaking settings - set the NIC card speed to Auto instead of 100/Full

Share this post


Link to post
Share on other sites
ikon

LOL. I guess the message is "lesson learned" :)  I've been in your situation. With all the auto-negotiation that takes place with network gear these days, it's often best to just leave things on auto -- let the gear figure it out....  Thanks for posting about it.

Share this post


Link to post
Share on other sites
jem101

Now oddly enough, not long ago the 'accepted' method was not to use auto-negotiation on the grounds that it never really worked properly and it was best to manually set the speed and duplex on everything yourself.

 

John

Share this post


Link to post
Share on other sites
ikon

True enough. I used to set everything manually. Then, one day, we got an 8-port Netgear router for a small project and it wouldn't work any other way except with all attached computers set to Auto. That was a number of years ago and it seems things have just gone more and more that way. At this point, the first thing I do is set everything to Auto. IF that doesn't work (which is very seldom these days) I will play with the settings.

 

On the rare occasion it doesn't work on Auto, it seems the most frequent issue is the duplex setting. That issue should completely resolve itself over the next few years as everything moves to gigabit (because there is no half-duplex with gigabit and faster).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...