Jump to content
RESET Forums (homeservershow.com)

Remote web access to second WHS 2011?


Recommended Posts

  • Replies 63
  • Created
  • Last Reply

Top Posters In This Topic

  • jmwills

    23

  • ikon

    22

  • Shoop

    17

  • jem101

    2

Top Posters In This Topic

Popular Posts

I think you can ignore what I said about binding the IIS ports on the second server.  The first server should be as a default value.   Scenario:   HS #1 @ 192.168.1.101   Forward incoming Ports 80

It's not so much changing the ports as it's having to remember that this particular instance of IIS uses different ports. It's another admin item to keep track of.

Link to post
Share on other sites
jmwills

Agreed.....and this is where having your own DNS server can solve some of this.

Link to post
Share on other sites

First, I would like to thank everyone for their help.

 

I have a linksys E4200 version2.

 

Wow, this is more complicated then I thought.  I was hoping it would be a simple solution. Not sure if I want to go in and edit the bindings or not.

Link to post
Share on other sites
jmwills

That's the only step you are missing.....it's totally reversible.  It's a learning process

Link to post
Share on other sites

It's not so bad as it seems ATM. In fact, it looks like you won't even need to do port translation, just straight forwarding. I'll look into it a bit more and post again tomorrow.

Link to post
Share on other sites

Okay, I looked at the IIS Manager briefly and it doesn't look all that difficult (thanks to jmwills for the directions).

 

I did notice that I have the following:

 

            port                         binary info

Http       80                     

HTTP                                       *:65510:

HTTPS                                     *:65510:

HTTPS                                     *:443:

 

 

So I need to change the Http 80 to 8080 and the HTTPS *:443: to *:8443:? 

After that I need to create a windows firewall rule (which I may need some help on)  for the change.

 

On the router i no longer need to forward 80, 443, 4125 to 8080, 8443, 8125?  The external and internal ports for the second server should both be 8080, 8443, 8125?

Link to post
Share on other sites
jmwills

Whatever the alternate port mapping you are using , that's what you change it to.  If you are using 8080 instead of 80, then the bindings get changed to 8080.  If you use 8443 instead of 443, then you change that.

 

The ports have to be forwarded in the router or the traffic will get get dropped.  If you use 8080 instead of 80, forward 8080 as port 80 to the second IP address. and the same for the alternate for 443.....

 

http://homeservershow.com/forums/index.php?/gallery/album/60-2nd-server-on-lan/

 

Firewall:

 

Control Panel>Firewall>Advanced Settings>Inbound Rules.  Look in the Right hand Side where the Action Pane is and select New Rule:

 

Select Port and Click Next.  Take the default TCP and Specific local Ports.  In that box enter 8080, 8443 (if those are the alternate ports being used), Click Next and Allow the Connection>click Next>Give the Rule a Name such as "2nd Home Server on LAN" and hit finish.

 

You should be good to go.

Link to post
Share on other sites

The ports have to be forwarded in the router or the traffic will get get dropped.  If you use 8080 instead of 80, forward 8080 as port 80 to the second IP address. and the same for the alternate for 443.....

 

I think this could be misinterpreted to mean to forward 8080 to 80, when I think you mean to forward 8080 in place of 80. If the bindings are changed in IIS on the 2nd server to 8080 and 8443 then the source and destination ports on the router should be the same: i.e. 8080 to 8080 and 8443 to 8443. IOW shoop, you have it right.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...