Sign in to follow this  
Followers 0
Shoop

Remote web access to second WHS 2011?

64 posts in this topic

I tried to log into the second server from work and it did not work. I tried using both domains with the extension :5555 and wouldn't work.

 

  I went into the dashboard> server settings> remote web access on the second server and noticed it said the router is not working. So, I went into the router and changed the port forwarding to my second server with the :5555 extension to my first server and it works but the first server then losses remote web access.

 

The problem seems to be the router not alloing port forwarding on both servers simultaneously.   In this case, the router is not allowing port forwarding to the second server which in turn allows the server to communicate with the domain name setup through microsoft.

 

I hope this makes sense. 

Edited by Shoop

Share this post


Link to post
Share on other sites

The router is working fine....this is a know error in the WHS dashboard when you manually configure port forwarding.

 

On the second WHS server, you are going to have to change the port bindings in IIS to match the port you are trying to use on the second server.

Share this post


Link to post
Share on other sites

Do you know of a good tutorial you could recommend?  Would I just add the ":5555" extension to fix the problem?

Share this post


Link to post
Share on other sites

Add to what?

Share this post


Link to post
Share on other sites

Sorry, my knowledge on this is very minimal.  When I go in and change the port bindings do I just add the :5555?  Or do I need to reassign the 2nd server to another port all together?

Share this post


Link to post
Share on other sites

The router is working fine....this is a know error in the WHS dashboard when you manually configure port forwarding.

 

On the second WHS server, you are going to have to change the port bindings in IIS to match the port you are trying to use on the second server.

 

You've confused me on this. If I set up 2 ports my router, let's say:

 

https://mydomain.com:5555 ==> 192.168.0.111:443 (WHS2011 #1) and

https://mydomain.com:6666 ==> 192.168.0.222:443 (WHS2011 #2)

 

are you saying it won't work because of some issue in the DashBoard? How would either WHS2011 even know it was receiving redirected packets?

Share this post


Link to post
Share on other sites

That's the easy way to do it....the error he is talking about is the "Router Not Working".  That's an erroneous message because you didn't use UPnP.

Share this post


Link to post
Share on other sites

shoop, you need to ignore the DashBoard errors. The DashBoard Remote Web Access wizard requires UPnP in order to configure your router for you automatically. This is a dangerous thing to do.

By setting up your router manually, as we were discussing earlier, you should be able to get this working for both servers. I've never had 2 WHS on the same LAN, but I can't see any reason why the port forwarding would fail.

EDIT: I just tested HTTP and HTTPS access to my WHS2011 my tethering to my phone and I got a WHS login screen on both of them. As I said, I don't have a 2nd WHS2011 box set up, but I'm quite confident, if I did, I could set up 2 more port forwards and have them work just as well to the 2nd WHS2011. Besides avoiding the perils of UPnP, this is another advantage of manual port forwarding.

Share this post


Link to post
Share on other sites

I think you can ignore what I said about binding the IIS ports on the second server.  The first server should be as a default value.

 

Scenario:

 

HS #1 @ 192.168.1.101   Forward incoming Ports 80-443-4125 to 192.168.1.101

 

HS #2 @ 192.168.1.102   Forward Incoming Ports 8080, 8443 & 8125 to 80-443-4125 to 192.168.1.102  where 8080,8443 and 8125 are appended to the IP Address to reach the second server.  (8080 would be the alternate Port for 80, 8443 for 443, and 8125 for 4125)

 

Ignore the dashboard warning.

 

Try by using your external IP address first such as http://17.125.65.130:8443  where 17.125.65.130 would be your current WAN Address

1 person likes this

Share this post


Link to post
Share on other sites

Yep. We're saying the same thing. The only caveat, of course, is that it will be necessary to add the port number to the end of the URL when trying to access the 2nd WHS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0