Jump to content
RESET Forums (homeservershow.com)

WHS V1 and main drive failing...


TheGuy
 Share

Recommended Posts

OK folks,

 

I have a WHS V1 with all updates on it. (PP3)

I can no longer access the WHS console.

I can Remote into it.

From initial view it would seem that either my C or D portions is failing... I am currently running SpinRite on it.

Backup service no longer working.

 

If it recovers, great..  if it does not recover...no big lost, my files are all safe in another location.  And the backup's are safe as well.

 

But,

 

I would like to recover this box if possible... just for the challenge.  I would then like to use another drive (new) as it's main C:/D: drive 2TB instead of the current 1TB.

 

So the questions are:

 

1.) If my main drive has failed, what can I recover and how?

2.) Can I save the backup?

3.) Can I save the files in storage? on D:  Yes they were all duplicated.

4.) What should I do first?...Second...etc... 

 

This is my original TranquilPC SQA-5H 1x1TB + 4 x 2TB drives.  the 1TB system drive seems to be going bad..or is bad.

 

PS:  I did search this forum, but not finding the cookbook with the full recipe.

 

thank you for the help.

Link to comment
Share on other sites

  • Replies 30
  • Created
  • Last Reply

Top Posters In This Topic

  • diehard

    7

  • TheGuy

    11

  • jmwills

    1

  • ikon

    10

Top Posters In This Topic

Since all folders are duplicated, then that means that any files on the D: partition of the system drive are also on an other drive. Also WHS usually copies the PC backup database off the system drive once a second drive is added to the pool.

 

So you should be able to just shut down the server. Replace the system drive with the 2TB drive. Boot into recovery mode and Select Server Recovery not Factory Reset.

 

Once that's going, uninstall the connector software because that's PP3 version and your server recovery will fail to complete. If your WHS disks are from PP1 then you need to install the connector on a 32bit PC. (PP2 added 64 bit connector).

 

Once the server is finished recovering, install the connector and log into the server with http://servername:55000 to start the OOBE which gets Windows Updates and installs the connector. Keep checking for Windows Updates until you see it's past PP3.

 

Then recreate the Users with the same names as before and their data should show up.

 

The PC backup service should start and you should see the backups.

 

Good Luck.

Link to comment
Share on other sites

  • 3 weeks later...

well it did not work... I can no longer start my WHS v1 console ... but I can RDP into the server...and I still have access to my Shared folders...  but I cannot get the console to open up...  I get an error that the backup service is not working....

 

any comments?

Link to comment
Share on other sites

I ran chkdsk and Spinrite and all came out ok...  but there seems to be some bits out of wack...

Link to comment
Share on other sites

Out of curiosity, how did you run CHKDSK? If it was by running it directly on the server, via a reboot, I would suggest doing it again with the drive attached to another computer as a secondary drive. It may not help, but it's easy to do and I've seen it work.

Link to comment
Share on other sites

I ran chkdsk and Spinrite and all came out ok...  but there seems to be some bits out of wack...

Yes, that's possible. Open the Console and go to Setting.  Backup Tab, then Repair. See if it comes back ok or if it deleted some stuff. If it's repaired then the Health Status icon should turn green.

 

If that doesn't work then remote into the server and go to D:\folders\{00008086-058D-4C89-AB57-A7F909A47AB4} and cut the file commit.dat and paste it somewhere else safe. Then reboot the server or go into Services and restart the "Windows Home Server Computer Backup" service. If that doesn't work, copy back that file so your back to where you started.

 

If your having issues opening the Console on the PC, then open it from a RDC on the server. If the PC Console is an issue, then you might have a different Console version. Let us know.

Link to comment
Share on other sites

Ok, just completed the chkdsk from another computer... all OK.  " Your drive was successfully scanned / windows successfully scanned the drive. No errors were found. "  Then I opened a DOS with Admin level and did another Chkdsk and all came out OK.   Put the drive back in my WHS V1 and rebooted....  got service error (Backup service not running)  Still unable to open the CONSOLE.  MUST RDP into Server or in my case I have connected a monitor, keyboard and mouse to it directly. (yes it's a TranquilPC SQA-5H WHS V1 - original; had it for years... bought one of the first one out.)

 

OK, tried the D:\folders....thing...nothing different... still cannot start the Console.

 

I have WHS V1 with PP3 installed and ALL of the updates...

 

Tried to manually start the WHS computer Backup service... it will not start.

 

got into Remote desktop and tried starting Console... got error:

Windows Home Server Computer Backup

whsbackup.exe szAppVer: 6.0.2423.0 offset 000635d7

WHS computer backup service is not running...blah blah blah...

 

Yet, my shared files are available....

and I can Remote into the server...

just no backup's of current PC's  and cannot open the Console.

Link to comment
Share on other sites

chkdsk results:

 

Windows has scanned the file system and found no problems.
No further action is required.

 955779142 KB total disk space.
 883201060 KB in 933190 files.
    524176 KB in 67961 indexes.
         4 KB in bad sectors.
   1401018 KB in use by the system.
     65536 KB occupied by the log file.
  70652884 KB available on disk.

      4096 bytes in each allocation unit.
 238944785 total allocation units on disk.
  17663221 allocation units available on disk.

Link to comment
Share on other sites

A Recovery Installation may be your only option at this point. Be careful: I don't know if you've done this before but you have to be careful not to accidentally do a Restore Installation (can't recall the exact name but it's basically a completely fresh install that wipes out everything).

 

A Recovery Installation will keep your data intact. However, I believe it will wipe out your backups. diehard, please confirm :) I also believe I got around this issue by copying the backup files to another computer before doing a the installation and then copying them back afterwards. I'm not 100% sure cause I haven't run v1 for a couple of years.

 

As always before doing anything major to a system, make sure you have a good backup of your data.

 

diehard, do you agree about doing a Recovery Install at this point?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...