Jump to content
RESET Forums (homeservershow.com)

trying to restore from old backups copied into backup folders


mjb523
 Share

Recommended Posts

I've been a lurker for a while but now I need to pose my own question to the experts.

 

A computer failed after a backup and while it was getting fixed the server hard drive failed and I had to replace it - this is why it is so important - the backed up data is on my server disk but is unusable by me now.

 

I've read the how to on copying old backups to new replacement drives in the Microsoft Windows Home Server Home Computer Backup Technical Brief. After I delete the current files and copy over the old into the folder and restart the service my HP Media Smart software requires me to run a repair on the backups before restarting the backup service. I do this and it says it was successful on all 3 computers that I have backed up.

 

When I go to the computers and backup tab and look at the machines listed it only shows one of the machines as having been backed up. When I click the computer I need to restore and click view backups it does not show any backups available. Does anyone have experience in this area? I seem to be coming up empty on this topic via search and hoped you could help. thank you.

 

Michael

 

 

Link to comment
Share on other sites

  1. from the tone of your post I take it you don't have any other backup: i.e. you're not running a 3-2-1 backup scenario. Is this correct?

     

  2. I hope you haven't disposed of either of the failed drives yet. It may still be possible to rescue data from them.

     

  3. can you give more details about the 2 failed drives: how they 'failed'; the symptoms, error messages, etc.?

     

  4. if you haven't done so yet, please make complete backups of all the rest of your client computers. You should really implement a 3-2-1 strategy:

     

          * at LEAST 3 copies of all data

          * on 2 different forms of media (HDD, tape, DVD, etc.)

          * at LEAST 1 copy of all data offsite (either physical or cloud)

     

  5. These are the MINIMUMS of a good backup strategy. I personally have 4 to 5 copies of everything.

     

  6. As far a rescuing the data is concerned, if it's really important to you, you could spend $90 and buy SpinRite. As with all things IT, there is no guarantee SpinRite can rescue your data, but it does often work.
Link to comment
Share on other sites

Thank you for the reply. The failed machine drive is not available as it was sent back to the manufacturer and replaced with a new drive. The failed drives in my server are still functional and work well enough to get the data off (but they do not function in the server). I have multiple copies of the WHS backup folders that were on those drives but the way WHS backs up is the problem.

 

I replaced the failed drive on the server then copied the old backup data into the proper backup folder {00008086-058D-4C89-AB57-A7F909A47AB4}. They just aren't showing up to restore on 2 of the 3 machines. I don't know how to get them to recognize. I run the repair and it says they are good but they just are not there.

Link to comment
Share on other sites

I have to apologise: I forgot to ask if you're running WHSv1 or WHS2011. I'm guessing it's WHSv1, but it's important to be sure.

 

How many drives failed in the server? In the OP you mention 'the server drive" but just now you said drives. Just want to be clear. How many drives in the server? Did the OS drive fail?

 

If only the OS drive has failed, perhaps you can clone it to another drive and then try a recovery install.

Link to comment
Share on other sites

It's v1 (or at least this is the topic category), so there should only be one drive.

Link to comment
Share on other sites

V1. 

 

The storage drive was wonky enough it hung the server up. Since I was replacing one old drive I went ahead and replaced both storage and the OS drive as it was the original. I did a full server rebuild from scratch. Copied all my data over. Followed the Technical Brief instructions on Restoring a Backup Database but those old backup databases don't show under the computer names that were backed up. 

Link to comment
Share on other sites

One OS drive.  The backups are there, but the NetBIOS names will have changed, as far as the server is concerned, as the SID of the client will have changed.  My guess the key will be how to match them to one another.

Link to comment
Share on other sites

Is it possible to try cloning the original OS drive and then do a Recovery Install? That way the SID shouldn't change and the you might have a better chance of using the backups. I'm not sure if the Recovery Install will wipe the backups, but it might, so it's good you have backups of the backup files.

 

I think it would be good for diehard and/or Drashna to chime in on this one.

Link to comment
Share on other sites

  • 4 months later...

I've got a similar problem.  Using WHS V1 (the 2003 version - running on an old PC).

 

I had backed up the D:\folders folder (all 3 of them, just in case) to an external USB drive after stopping PDL and WHSbackup, per the Microsoft document.

 

Well...my system drive failed after 3 years (it was just a single 1.5GB drive in an old PC). 

 

So...I went out, bought a replacement drive (was 1.5GB - bought a 2GB {tried a 3GB drive first - WHS with 2003 won't see it - so then got a 2GB drive instead) - installed WHS, restored the backup from the external drive per the document - all was fine - the database came back and the backups were there.

 

That new drive failed (mumble mumble) - got a replacement 2GB drive.  Followed the same steps (install WHS, stop services, copy the folder, start services)...but now the database isn't showing the old backups!  I've done a database repair - still not seeing them.  There are about 6 computer backups stored in the database - and the repair option shows the guid/hex being repaired.

 

I don't remember the exact install steps - but I'm wondering if the WHS database depends upon the OS auto-update working?  I.e. maybe the backup of the database is a different version from what windows update applies (hoping!).  I haven't allowed auto-update to update the system...so I'm wondering if that is causing the problem.

 

I'm really open to any suggestions...for the time being, I'm copying my primary computer's data (800GB) to that 3GB drive I have (Windows 7 64bit).

 

Thank you!

 

P.S.  This is the batch script I've been using - called "do-robo.bat" stored at the root of D: (along with robocopy.exe) - R: is the external drive I copy the data to

 

@echo off
setlocal

 

set SRCDIR=d:\folders
set SRCDIR2=D:\shares
set DESTDIR1=r:\Backup-WHS
set DESTDIR2=r:\Backup-Shares

if not exist %DESTDIR1%\. mkdir %DESTDIR1%
if not exist %DESTDIR2%\. mkdir %DESTDIR2%

set YYYY=%date:~-4%
set MM=%date:~4,2%
set DD=%date:~7,2%

set LOGFILE=ROBOLOG-%YYYY%-%MM%-%DD%.txt

 

echo About to robocopy %SRCDIR% and %SRCDIR2% to %DESTDIR%
echo log file is:  %LOGFILE%
pause

net stop pdl
net stop whsbackup

copy %0 %DESTDIR2%
copy robocopy.exe %DESTDIR2%

robocopy %SRCDIR2% %DESTDIR2% /s /e /r:3 /w:3 /log+:%LOGFILE% /np /tee /MIR

robocopy %SRCDIR% %DESTDIR1% /s /e /r:3 /w:3 /log+:%LOGFILE% /np /tee /MIR

echo About to start WHS backup services
pause
net start whsbackup
net start pdl

endlocal

Edited by KenB
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...