Jump to content
RESET Forums (homeservershow.com)

The restore process did not succeed


steve053
 Share

Recommended Posts

I installed WS2012E on an HP microserver, installed the connector on my Acer netbook running Win7Pro and created a manual backup.  I set up daily backups to occur between 1 and 5 a.m.  The daily backup worked.  My next step is trying to restore a file or folder on the netbook.  I loaded the dashboard and selected 'Restore files or folders for the computer'.  After a few minutes I received the message: 'the restore process did not succeed'.

 

I checked and the windows server client computer backup provider service is running on the client and server.  Both are set to 'automatic'.

 

Items to note:

- I used tinkerguy's write-up to join my existing workgroup rather than the domain (http://homeservershow.com/forums/index.php?/topic/4423-install-connector-and-skip-domain-join/?p=46213)

- I changed the DNS setting in the netbook from the server to my router's ip address

- After installing the connector windows update prompted me to install dot net 4.5

- When I sign into the Launchpad I receive a number of error messages:

  • The server appears to be offline.  Do you want to sign in to offline mode:
  • Alert Viewer Error: Alert notices are not available in the Alert Viewer due to an error, or incomplete action, or a service has stopped working.
  • Your computer is not connected to the health service provided by your server

 

Backups are great, but if I can't access the files then why bother.  Grumble, grumble, grumble.........

 

Thanks for the help. 

 

Link to comment
Share on other sites

What's the point? Excellent question. I'm not running WSE2012 yet, but I know restoring of individual files & folders is a problem with WHS2011 also. That's why I don't use it for that.

 

What I do use WHS Backup for is to back up the system drives of Client Computers so I can do Bare Metal Restores when needed. Data backup is taken care of by RoboCopy and scripting.

 

Here's a link to some photos of my server/backup setup:

http://homeservershow.com/forums/index.php?/topic/1899-whs-2011-storage-strategy/page__st__140#entry47628

 

And here's a link to my backup strategy:

http://homeservershow.com/forums/index.php?/topic/4788-what-i-hope-to-acheive-with-your-help/page__p__51373#entry51373

 

And, finally, a link to my RoboCopy scripts (you know, in case you might want to alter your strategy ;)):

http://homeservershow.com/forums/index.php?/topic/5197-robocopy-backup-scripts/

Link to comment
Share on other sites

Once again, thank you for your help ikon.

 

I saw your backup pictures a few weeks ago when I first stumbled onto this site - very cool.  Relying on me to pack and unpack drives daily would result in a months old data that wouldn't be useful if ever needed.  Kudos to you for pulling it off.

 

Since WHS v1 worked out of the box for individual file/folder recovery (at least for me) I wasn't expecting issues.  I'm suspicous that there is a connector error due to the dot net upgrade.  The backups completed proior to my upgrading dot net.  I think I'll uninstall the connector, delete all backups and start from the beginning.

 

I appreciate you sharing the scripts.  They have been downloaded and saved.  I really don't want to go that route, but will if needed.

 

Am sure I'll have more questions as I muddle through my migration.

 

Steve

Link to comment
Share on other sites

I would try just uninstalling & reinstalling the Connector, without deleting all the backups. If you rejoin a computer to the server without changing its parameters it should retain all its backups. You should receive a prompt saying that there is already a computer with that name & asking if you want to proceed anyway.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...