Jump to content
RESET Forums (homeservershow.com)

Upgrading disks in an AMD mobo RAID mirror on N40L

Gary Pickard

Recommended Posts



I currently have my N40L set up with an OS (WHS2011) SSD on the optical drive SATA port (having used the bios hack).


I then have 2 x 2TB drives in the other 4 drive bays.  These are set up as 2 simple mirrors using the AMD RAID on the mobo (never again from what I am reading - software next time around).


I am now getting to the point where I could do with a bit more space and would like to swap out one set of drives for 3TB drives (again to be placed in a mirror).


Has anyone done this already?  Is there a painless (least painful) way to do it?


I am hoping that I can pull one of the 2TB drives, add a new 3TB drive in its place, wait for it to get synced up, then swap the other 2TB drive for a 3TB.  I have done this before with an old Netgear ReadyNAS Duo, however, from reading around the forums and some Googling I get the impression it is not going to be that easy.


It also looks like I cannot just pull both 2TBs, pop in the 3TBs and copy over the data from one of 2TBs (perhaps using the eSATA port).  I understand that the data is not going to be readible by WHS2011 but is locked on an AMD RAID format.


Any help gratefully received.




PS I have seen a few notes about the bios hack disabling the mobo RAID.  Not sure what is happening on my machine but the AMD software is very happy and nothing looks out of order and the machine has been up and running for 12 months+.

Edited by Gary Pickard
Link to comment
Share on other sites

  • Replies 26
  • Created
  • Last Reply

Top Posters In This Topic

  • Drashna Jaelre


  • ikon


  • LoneWolf


  • Gary Pickard


The safest and easiest way is to create the new array and copy the contents over. You will probably run into issues using the method you described primarily because the 3T have to partitioned as GPT not MBR. I would not attempt the process you are describing. Even if it worked (which is doubtful) it would take forever to do the process and would require that you resize the partition once you are complete. I would suggest using a RAID card to make motherboard agnostic and increase the performance in the process.

Link to comment
Share on other sites

^^ What he said, plus I think you would run into another issue. If you pull one 2 TB drive from a mirror and replace it with a 3 TB, the mirror is going to carve the 3 TB into a 2 TB partition and leave 1 TB unused. Adding the 2nd 3 TB HDD won't fix that either. I'm not 100% certain, but I'm not at all sure you would be able to expand the mirror after the resync.


IOW, you would have a 2 TB mirror made up of 3 TB HDDs. I suspect the possibility of expanding the mirror after resyncing would depend on the specific RAID controller/software.

Link to comment
Share on other sites

Thanks for the feedback, I was hoping to avoid using a RAID card and just go with software RAID to keep away from proprietor y formats


How about:


1.  Hanging the new 3TB (once nicely NTFS formatted) off the eSATA and copying over the mirrored data


2.  Breaking the mirror in the AMD app (hopefully not too painful)


3.  Pulling both 2TBs


4.  Adding in the 3TB to one bay making sure no side effects


5.  Then popping in the other 3TB and starting software mirroring in WHS2011 (or use Drivepool)


If this worked I would then unwind the AMD mirroring on the on the 2 x 2TBs in similar style using one of the now spare 2TBs

Link to comment
Share on other sites

I think that plan makes a lot more sense. I would go with something like DrivePool or DriveBender over using WHS2011 mirroring, because they leave the drives readable on other systems without having to use special tools.

Link to comment
Share on other sites

I haven't done it with a Microserver, but the last time I did a RAID-1 migration, I used Symantec Ghost Corporate.(now Ghost SolutionSuite).  The newest versions use a WinPE environment and would support loading Windows drivers during disc creation.  However, it's a commercial solution.


I think the first part of Gary's solution is a good one --break the current RAID mirror.  It's probably possible to do in a RAID-1 without data loss on the primary drive.


Then, I'd clone the primary 2TB drive  that was the primary to a 3TB with, say, Clonezilla.  Then extend the partition to 3TB within Windows.  Then, add the second 3TB and create a new mirror. 


I'd review which new mirroring method is the best; the AMD method might be just fine.  If the AMD RAID-1 method avoids using dynamic disks, I'd probably stick with it compared to a software RAID in Windows which may require that (I've had quirks with Dynamic Disks over the years that lead me to avoid it when possible).

Edited by LoneWolf
Link to comment
Share on other sites

Pretty much what I was thinking - I have Acronis True Image so was going to use their boot image to clone the RAID drives on to the new 3TB drive


Now just to find a decent offer on some WD Reds - they seem to be stubbornly sticking at £115 compared to something like the Greens which keep dropping to around £90

Link to comment
Share on other sites

(I've had quirks with Dynamic Disks over the years that lead me to avoid it when possible).


I recently had an experience with Dynamic Disks, trying to move a disk from 1 system to another. When I first booted up, I was able to see the disk in Disk Manager, import it, and copy the data off. Then I shut the system down.


After working on the data for a while on another system, I decided to look at the data on the original disk again, to be sure I had it all. When I booted up I found I no longer could access the drive. This was, to say the least, puzzling.


After researching it online for a while, I found a Microsoft article that basically said it's a flaw in the Windows OS. I don't have a link to the article handy, but it basically boiled down to  this: you get one chance to see the drive. On the 1st boot the drive can be seen; on the second it no longer can. There were some suggestions in the article for fixing it, but none of them worked for me.

Link to comment
Share on other sites

I think that's actually by design.... enough to recover data and not much more.


Sent from my HTC One S



Link to comment
Share on other sites

MS does acknowledge it as a bug, and they offer several ideas to get around it; they just didn't work for me. And think about it: you can boot the system and import the drive(s), but they become inaccessible after another reboot - does that really make any sense?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...