Jump to content
RESET Forums (homeservershow.com)

Problems with Remote Desktop Connection to Client PC


revengineer
 Share

Recommended Posts

That was my plan for him.  Primary would be 127.0.0.1 and the Secondary would be the router.  You could go as far as editing the Hosts File.

Link to comment
Share on other sites

You're right..I was thinking on the server as loopback....and the clients pointing to the server.

Link to comment
Share on other sites

Use the netstat -ano command on your computers when testing the RDP and see what ports are involved.  Especially if you get a successful session for RDP.  Then you can make some comparisons as far as failure and success are concerned.  I do this sort of stuff for a living and have found this command to be very useful.  If there are any regularities you can then begin to do some specific troubleshooting.

Link to comment
Share on other sites

Thanks for the additional responses. Maybe there is hope for me; you guys know a lot more about DNS than I do. I am at work right now and have to think through my questions to ask you. I will do that on the weekend and get back to you.

 

joem: I used netstat yesterday to verify that RDP was running on port 3389 on my machine and it does. There is no doubt that this is a DNS issue because RDP from my wife's PC to my PC works; so in general RDP is working. Also from the WS2012E I can RDP to my PC if I use the IP address or "name.local" or "name.". Just simply "name" will not work so that the connect button from the RWA goes nowhere. Therefore the real question is: why can my wife's PC  resolve my PC using  "name" but the WS2012E cannot. This may be related to the fact that my wife's PC uses DHCP to get the setting from the smoothwall, while my WS2012E is statically configured (so that it has an IP address even in case of emergency when smoothwall is down).
Link to comment
Share on other sites

Alright, victory, figured it out. The key finding was my inability of resolving host names on the server with nslookup. Instead of showing my smoothwall DNS first, it had listed ::1, which is the equivalent of 127.0.0.1 in IPv6. Interestingly, IE had no problems resolving web sites like google.com. Digging deeper into the network settings, I found that the IPv6 DNS was not set to automatic, but ::1 instead. I am 100% sure that it was not me who did that. Once the IPv6 DNS was set back to automatic, the system was able to resolve my PC by name and RDP works now.

Link to comment
Share on other sites

ahhhh, to heck with it, just turn off IP6. I do, and I haven't found anything I cannot do.

That is certainly an option, not like it is needed. And most of my routing equipment, including smooth wall, and does not support it yet.

Link to comment
Share on other sites

It's going to be quite a while before IP6 becomes commonplace inside residences, so I disable it on all my home PCs/Servers/etc. By the time it does become commonplace at home there will be a whole new generation of software, so we're good to go without IP6 until then.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...