Jump to content
RESET Forums (homeservershow.com)

Problems with Remote Desktop Connection to Client PC


revengineer
 Share

Recommended Posts

Hi,

I am slowly working my way through the list of remaining issues with WS2012E. Today's issue of choice is my inability to connect to my client PCs from work via RDP. Here are some things that work and some that don't:

 

1. Remote Web Access to my server works fine and so does connecting to the server via RDP by clicking on the connect button in the web interface.

 

2. I installed Lights-out and I can successfully wake up my client PCs remotely including away from home.

 

3. Inside my LAN I can connect to any client PC via RDP by clicking on the connect button in the Remote Access Web interface.

 

4. What does not work is 3. above when away from home. That is, when I am at work, I can remotely wake the PCs but connecting to them via RDP times out, but I do not know why.

 

As far as I understood, with WS2012E I do no longer need to forward port 3389 in the router. Is this correct?

 

If anyone can help with this issue, that would be fantastic. Thx in advance.

 

Link to comment
Share on other sites

Have you tried it from anywhere else besides work? Maybe they are blocking something?

No I have not and that's a good point. All I know is that the RDP connection to the server works but RDP connections to client PC do not. I know that my employer is blocking almost everything including port 3389. For this reason I could never connect to my WHS v1 via RDP. But WS2012E is supposed to tunnel this travel through port 443, which seems to work fine with server connection. I wonder what is different about the client connection?

Link to comment
Share on other sites

Isn't the client OS going to be an issue here? It sounds like Microsoft is enhancing security and helping people avoid firewall issues (such as from work) by using the HTTPS port, which is very unlikely to be blocked. But, if the client OS isn't set up to understand RDP coming in over port 443, isn't it going to fail?

 

I don't have WSE2012 running so I haven't tried this. Am I missing something about this issue?

Link to comment
Share on other sites

It seems unlikely that 3389 would have to be forwarded to the clients but I would set it up for the server to test and if nothing changes, remove it.

 

I'd block it too, if I were the employer.  Just saying.

Link to comment
Share on other sites

After poking around today and trying some of the suggestions above, I found that I was completely barking up the wrong tree. The problem is already on the LAN side. It turns out the only affected PC is my own. Here more symptoms:

 

1. From my PC I can RDP to the server using its name or ip address

2. From the server I can RDP to my PC by ip address but NOT by name (this is the real problem). However, I can use "name.local" or simply "name." (the dot is crucial here).

3. From my wife's PC I can RDP to my PC both by ip address AND by name.

 

So the problem really seems to be a DNS issue, which goes back to my smoothwall firewall. Since I have opted not to use the WS2012E as my DNS (because the whole internet in the house goes down when I reboot the server), I am not expecting much help here.

Link to comment
Share on other sites

How often do you reboot the server?  You could put multiple DNS entries for each client with the primary coming from the Server and a secondary coming from the router.

Link to comment
Share on other sites

jmwills, what do you think of the idea of setting client PCs to use the WSE2012 server as Primary DNS and either the Smoothwall or his ISP's DNS as Secondary?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...