Jump to content
RESET Forums (homeservershow.com)
jamesac

Newbie Help with Buffering!

Recommended Posts

jamesac

Hi there

 

i have been a lurker for a while and thought i would sign up to see if someone can shed any light on a problem i am having

 

my current set consists of a HP N40L with 5 x 4tb Seagate drives in, No RAID, just NTFS partitions and folders for movies etc.

 

i have three little nettop boxes running openelec xbmc and have been running fine for the past 2/3 years , however i have a problem.

 

i have recently upgraded to the HP box from 4 x Dlink DNS343 nas boxes filled with 2tb drives. I moved all the data from these and re added the library locations in XBMC, however im finding that 1080p content is buffering every now and then on films which i had no problem with when they were on the nas box (RAID 5)

 

the data is m2ts uncompressed format so a film is normally 15gb+

 

ive not changed anything in my network (gigabit all the way through) and ive noticed the transfer rate is much quicker on the HP box.

 

The only setting i can think of, is that Jumbo frames were enabled in the boxes but i cannot enable for the network card in the N40L, (running window server 2008)

 

would anyone have any ideas what could be causing the problem. I also have buffering issues trying to play a Mt2s file on my laptop but i can confirm the files played fine before i moved them.

 

hope you can help as i tried to make the transition "wife freindly" so she didnt even notice but she wants to know what i have been messing with now the files dont play smoothly!

 

BTW standard AVIs play fine

 

 

 

Share this post


Link to post
Share on other sites
cskenney

I am assuming you have already verified that the Microserver is linked to the network using a Gigabit connection and has not fallen back to 100 Mbps because of a bad cable, etc.?

 

Have you done any benchmark testing between the laptop and server to verify transfer speed and consistency?  You could watch the windows task manager Networking graphs while playing one of the Mt2s files and see what the transfer rate is doing over time.  You could compare this throughput to actually copying a large file from your laptop to the server (or server to laptop) and see what the transfer rate is.

Share this post


Link to post
Share on other sites
jmwills

Change cables?

Share this post


Link to post
Share on other sites
jamesac

hi, i have been using the same cable, however changed this for a new one and continued to have the problem, the data transfer rate i am getting from copying a file from the server to my laptop averages out at 90mB per second, an 8gb file took 1 minute 40 seconds to copy. this file plays fine without buffering from my laptop (SSD drive) the network utilisation is between 70 - 85% when it is being transferred

 

i still have a couple of the nas boxes which are currently for sale on ebay so i put a 250gb drive i had lying about in the box, booted it, copied the same 8gb file onto the box (took considerably longer to transfer on there 6mins+, they have been wiped to factory default and have jumbo frames turned off.

 

however this plays fine on my xbmc with no buffering plugged into the same cable, same switch port etc

 

the task manager shows a small increase when playing the movie but this does not go over 15% but the network varies from 1.5% to 5% utilisation. however this drops to 0% on the network ulitisation monitor then the movie buffers. this happens every minute or so.

 

BTW its deffo connected at 1gbps

 

I do not want to rule out the NIC as it copies very quickly, it seems 'streaming' the data is the issue but it was and still is fine with the NAS boxes

 

im going to run ubuntu off a pen to see if it is the OS causing this but i doubt it, i know its not the drive as it happens from multiple drives.

Share this post


Link to post
Share on other sites
ikon

You're troubleshooting looks good to me so far - you're changing as few things as possible at 1 time it seems, which is key.

 

I think you're on the right track. Let us know how the Ubuntu test goes. Eliminating the OS would be a big step forward.

Share this post


Link to post
Share on other sites
cskenney

I have messed around with XBMC with my Raspberry PI.  It seems I remember seeing that different methods for accessing the files (SMB, NFS, etc) can cause varying results.  The problem was stuttering on the RPi but maybe it is a similar issue?  How were you accessing the files off the NAS?  Samba?

Share this post


Link to post
Share on other sites
jamesac

Hi, yes there are different ways of accessing the files through xbmc, i normally use SMB on the DNS and the HP box,

 

XBMC itself is not the problem as nothing has changed since i swapped "file storage" unit and to confirm that, it plays fine when the file is on the DNS.

 

i tried it with ubuntu (ended up installing as i needed to install samba etc)

 

this has the same results although it was not buffering as much, it was still present.

 

My next step is to buy another NIC and put that in the n40l, its connecting via gigabit but something is causing a bottleneck.

 

The processor and ram is higher than the nas box albeit they ran a very small firmware as appose to a full blown server OS.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...