Jump to content
RESET Forums (homeservershow.com)
LoneWolf

ProLiant Microserver Remote Access Card Firmware Update

Recommended Posts

ikon

Do you connect 2 Ethernet wires to your Microserver, one to the built in NIC and the other to the Remote Access Card?

 

That would be the normal routine. The RAC port is really just for that; remote access.

Share this post


Link to post
Share on other sites
riahc3

Note:  I was unable to update my Remote Access Card through its web UI, forcing me to use the SoC flash utility on a bootable USB key with FreeDOS.  The WebUI method would start to show updating, and just sit on that screen and never finish.

Could you explain this a bit better? What exactly is the "SoC flash utility" and how can you set it up?

 

I know how to make a simple bootable USB key but the rest...

 

Never mind. I was opening the wrong file and when I downloaded and open the correct file, I see the utility is included :)

Edited by riahc3

Share this post


Link to post
Share on other sites
sebus05

The good news -the BIOS updates the security certificate on the card, and there's a few bug fixes.  The bad news -there really isn't anything new in the way of features or interface changes.  I do hope it improves on the stability of the RAC (which wasn't perfect), and I hope I can eventually get port forwarding set up so I can access the RAC from outside my LAN, as I've been having issues getting that working, but that could be an unrelated issue.

 

Well, do not know about BIOS, but firmware upgrade to 1.4 certainly does NOT update certificate.

 

Of course I can get one generated from my own EnterpriseCA, but 1.4 seems to have the same bug like 1.2 where all I get while trying to upload generated .cer is error: "Certificate upload failed"

 

Anybody had any success with certificate?

 

sebus

 

edit:

--------

 

One needs to download Base 64 encoded from CA (DER encoded does not work)

Edited by sebus05

Share this post


Link to post
Share on other sites
Taffeys

Well, do not know about BIOS, but firmware upgrade to 1.4 certainly does NOT update certificate.

Is there a new RAC firmware 1.4? I have 1.3 but my N54L is now out-of-warranty and cannot find this new firmware.

Share this post


Link to post
Share on other sites
ikon

Perhaps you're getting caught by the recent change by HP to require an active support contract in order to have the right to download firmware updates??

Share this post


Link to post
Share on other sites
Taffeys

Perhaps you're getting caught by the recent change by HP to require an active support contract in order to have the right to download firmware updates??

Very possible... that's why I asked sebus05. My RAC seems to work OK, but sometimes not, with 1.3 and if and when I get my T20 built-out and IF AMT 9.0 works on it I'll turn the N54L into a HTPC and dump the RAC anyway.

Edited by Taffeys

Share this post


Link to post
Share on other sites
sebus05

No idea, I have no contract & just browsed drivers page for the Microserver

 

Returns download for firmware at HP FTP site

 

Windows install is impossible, had to do it from USB bootable DOS stick

 

sebus

Edited by sebus05

Share this post


Link to post
Share on other sites
Taffeys

No idea, I have no contract & just browsed drivers page for the Microserver

 

Returns download for firmware at HP FTP site

 

Windows install is impossible, had to do it from USB bootable DOS stick

 

sebus

Thanks sebus05! I searched the drivers page too but never found this RAC firmware update. Maybe I couldn't find it because I was logged-in to the HP support system.

 

Anyway, I updated the RAC firmware through the RAC Web GUI as I was typing this, it worked fine. I did the USB DOS boot update when I upgraded to 1.3 (I don't run Windows on my N54L).

Startech apparently had one, but it appears to be discontinued, and was PCI.  Unlikely you'll find it.

 

http://www.startech.com/PCI-Server-Remote-Control-Internal-IP-KVM-Card~SV1110IPPCI

 

I found this card in the US from some obscure vendor, asking price is ~$590US  :o

Share this post


Link to post
Share on other sites
sebus05
 
(I don't run Windows on my N54L).

Tried all sorts of OSs on this machine, but nothing makes it as usable as Server 2012 R2. And that comes from person that would rather run SLES 11.x normally.

Edited by sebus05
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now



×
×
  • Create New...