Jump to content
RESET Forums (homeservershow.com)

My migration from WS2011 to WS2012E using workgroups


garyT
 Share

Recommended Posts

I have decided to migrate from windows server 2011 to windows server 2012 essentials. My existing system is a Mediasmart ex495 server running windows server 2011. My new server will run windows server 2012 essentials on home built new hardware. I have got a lot out of these forums and the podcasts (Home Server Show & BYOB); so, I thought I would give a bit back in case others might find my experience useful.

 

My existing Windows 2011 system is:

  • EX495 (4GB memory)
  • 120 GB system drive
  • 3 2TB WD green drives (not raided configuration)
  • A sans digital raid box with 5 2TB WD green drives
  • There are 3 networked WD live boxes used to play back media from shares on the server (not streamed)
  • 3 Denon receivers used to play music from shares
  • There are 5 networked PCs running windows 7 pro being backed up by the windows 2011 server

The sans digital box is dedicated to storing the backups for the 5 PCs. The 3 2TB drives hold movies, TV, music, pictures, and some shared files. These drives are backed up using sync toy over the gigabit network to a second set of 3 2TB drives stored in an enclosure connected to one of the networked PCs. The system has been working well for the past year or so with little or no attention needed. The only problem that I had recently is that I was starting to run out of room on the 3 2TB drives. This gave me an excuse to try windows server 2012 essentials on some new hardware. By doing this I could “play” with the new system for a while without disrupting the family’s use of the existing system.

 

I purchased the following hardware for the WSE setup:

  • Lian Li itx case with space for internal 6 HD + DVD
  • Asus P8Z77-I deluxe
  • 16 GB memory
  • I5-3570K cpu
  • Intel 250 GB SSD for OS
  • 5 3TB WD red drives (set up as individual disks; not raided)
  • 600 watt corsair PSU
  • San Digital TR5M+B 5 bay raid enclosure; filled it with 5 3TB WD reds
  • HighPoint Rocket 640L card with 4 internal 6.0 Gb/s SATA ports

I realize that the new server setup is over-kill hardware wise but I wanted a bit of future proofing and if I ran into too many setup issues, I could repurpose the system for something else. I left the 5 3TB HDs as individual disks for simplicity sake. If I have a failure, I can put in a new disk and replace its files from backup. I don’t trust storage spaces from a reliability and performance perspective at this time.  I suppose that I could have raided them but at this point I have plenty of space and raiding is one less thing to do/look after although I would not rule it out in the future.

 

I put windows server 2012 essentials on a bootable USB stick and did the install using a keyboard and LCD monitor connected to the new server. I entered “MyDomain” as the domain name and “MyDomainServer” as the computer name. The install stopped part way through complaining about not having a network connection. I inserted the ASUS disk that came with the motherboard to try to install it but when I tried to run the ASUS setup program from the disk, the o/s complained that the programs on the ASUS disk were not supported by the operating system (windows server 2012 essentials). Since the install would not proceed without the Intel NIC driver being installed, I fled to Google where I discovered that I needed to down load the driver files, edit one of the install files, turn off driver signing, install the driver, and then turn driver signing back on as per:

 

http://www.ivobeerens.nl/2012/08/08/enable-the-intel-82579v-nic-in-windows-server-2012/

 

Well that was an unexpected pain in the … but it worked. The installation finished and all looked well except that the 350 MB partition was not on my system SSD drive but on one of the 3TB drives. After Googling that issue, the resolution that I found was that windows 8 likes to install the 350 MB partition on disk 0 (sorry I cannot recall the link) and the suggestion was to disconnect all drives except the O/S one when doing the install. I tried reconnecting my SSD to the controller in the disk 0 position and reinstalled. I still ended up with the 350 MB partition on one of the 3TB drives. I then went into power shell and used diskpart to remove all partitions from all 3TB drives, rebooted and reinstalled from the USB key. I selected custom install and on the screen where you select the disk under drive options I chose to delete anything on the selected (SSD) disk. Once I did this it formatted and installed but stopped again because of the missing Intel NIC driver. Once I corrected this as above all was well and the 350 MB partition was then on the SSD.

 

I then noticed in device manager that I had “Marvel Console” and “BCM20702A0” as “other” devices without drivers. I found a driver for the “Marvel” on the Asus web site that cleared up that problem but the other one is a Broadcom Bluetooth driver issue. The current solution to that one is more onerous than it is worth to me at this point to rectify. Since I do not need Bluetooth for the server, I will wait until a simpler solution is available.

 

http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2networking/thread/1ea7b245-684e-4fd0-8784-44fa08ce3ebd/

 

I am quite surprised by how many windows 8 driver issues that I had.

 

The 5 networked PCs and existing windows 2011 server currently use a common workgroup and are not joined to a domain and I do not intend to connect them to a domain as I see no upside in it for me. Things are working fine the way they are (if it isn’t broke …). The user accounts on the PCs are already set up and I don’t see any need to manage them centrally. Family members mostly use their own PC under their own account and most of their data is stored locally on their own PC.

 

I created user accounts on the server with the same name and passwords that were used on the 5 PCs. I created server folders using the dashboard, set permissions, and then loaded some data into the server folders for testing.  I set up the sans digital box as the location for the server backup which makes its drive letter disappear although I found that I can reassign it is disk manager. When I went to one of my networked PCs, I noticed that the new server did not show up on the network. I then checked the “Computer Browser” service on WSE and found that it was not running; so, I enabled it and rebooted. My windows server 20111 has its registry entry set such that it has priority in providing the Master Browser. See the following:

 

http://forum.wegotserved.com/index.php/topic/20171-how-to-allow-whs-2011-to-be-master-browser/

 

http://www.windowsitpro.com/article/john-savills-windows-faqs/what-criteria-are-used-to-decide-which-machine-will-be-the-master-browser

 

I now noticed that the windows 2012 server showed up as “MyDomainServer” in the network on the other PCs but when I tried to access any file on the new server, the PCs wanted a user name and password to connect to WSE. Also, I noticed that my WD live boxes did not see the new server named “MyDomainServer” on the network. Through some trial and error, I found out that if I changed the workgroup name on my 5 network computers and the 3 WD live boxes to match the domain name (“MyDomain”) of the windows server 2012 elements machine, the PCs and the WD live boxes were able to see “MyDomainServer” on the network and connect and use files from the new server just as they did from my Windows 2011 server. That is, the computers did not ask for a password to access the files but the WD boxes did (as they do with WS 2011 but this is a one-time thing).

 

The problem now was that although the WD live boxes could see the WSE they could not see the windows 2011 server; so, I had to change the workgroup name on the windows 2011 server to “MyDomain” as well. This procedure is documented here:

 

http://social.technet.microsoft.com/wiki/contents/articles/4127.how-to-change-a-workgroup-name-on-windows-home-server-2011-and-windows-storage-server-2011-r2-essentials-en-us.aspx

 

All devices, 5 PCs, 2 servers (2011 & 2012), and 3 WD live boxes now work together fine and you would not know there is a domain. I also have an Xbox that I very seldom use… have not tried it yet with the new server but it is not a high priority.

 

I finished setting up folders on the windows server 2012 essentials box and tried to install sync toy to use for transferring files from the windows 2011 box. It would not install without .NET 3.5. I downloaded it and tried to install it but the O/S complained (don’t recall the exact message). I eventually found out that it was already on the machine but needed to be enabled (installed?) through one of the management consoles. I just had to select it there and say O.K.

 

Once sync toy was installed, I started transferring files from the windows 2011 box. It was working so I left it running. The server went unresponsive when I was transferring my 3rd folder pair. I started sync toy again and went through another few folder pairs before the unresponsiveness happened again. I thought it might be related to the smb signing issue so I disabled it as per:

 

http://mctexpert.blogspot.ca/2011/02/disable-smb-signing.html

 

After doing this, I transferred the last few folders just by drag and drop in explorer and have had no further freezing issues but I have not had any need to run sync toy again; so, I cannot say for sure if the freezing was related to sync toy or the smb signing or a combination of them. Transfer speeds are 100+ MB/sec. Windows server 2011 would start off at 110+ but usually dropped to 70-80+. I did not check WSE speeds before disabling signing.

 

At this point everything is working quite well. The windows server 2012 essentials responds faster to the WD live boxes when changing directories than the windows 2011 server does. If everything continues to run o.k., after a while I will set up PC backups on the windows server 2012 essentials using the registry hack on the client PCs so that they do not join the domain.

 

http://social.technet.microsoft.com/Forums/en-US/winserveressentials/thread/aa40963c-7235-40f7-85f5-8f8d030a7c13

 

I will also move the sans digital box from the windows 2011 server over to the windows server 2012 essentials and I will move the client computer backups folder over to this sans digital box. This will give me 2 sans digital boxes on the new server. One will be for backups of the 5 PCs; the other is for the server backups. I will use a separate USB3 3TB drive for my “cloud” backup. I will use sync toy to copy priority files like pictures, some documents, perhaps some music to it. This drive will be rotated out to a safety deposit box periodically.

 

Total power draw for the two servers & two sans digital boxes that are connected to a 24 port Giga-bit switch and 500VA UPS is 210 watts.

 

Again,

Thanks for the podcasts guys… I really enjoy them

Gary T

Link to comment
Share on other sites

  • Replies 30
  • Created
  • Last Reply

Top Posters In This Topic

  • jmwills

    6

  • ikon

    7

  • Renny

    3

  • garyT

    9

Top Posters In This Topic

Posted Images

Thanks for the post. Interesting experiences you had, and equally interesting solutions. While I don't share the same aversion to domains as you, I think there may be info I can use.

Link to comment
Share on other sites

I was just about to pose the question here as to how to get the server to show up as  a network device, so thanks for that as well as a great post which I am sure others will find helpful.

Link to comment
Share on other sites

I was just about to pose the question here as to how to get the server to show up as  a network device, so thanks for that as well as a great post which I am sure others will find helpful.

The server is on the same LAN segment so you should be able to see it if you turn on network discovery.

Link to comment
Share on other sites

"The server is on the same LAN segment so you should be able to see it if you turn on network discovery."

 

On the server?

 

I just enable the Master Browser service on the server and now it shows up to all devices and PCs

Link to comment
Share on other sites

"The server is on the same LAN segment so you should be able to see it if you turn on network discovery."

 

On the server?

 

I just enable the Master Browser service on the server and now it shows up to all devices and PCs

On the client.

Link to comment
Share on other sites

From the metro screen go to Administrative tools

Click on services

Scroll to "Computer Browser"

Enable the service to run automatically,

If you are only running one server you're good to go.

 

Service appears to be disabled by default



On the client.

Had network discovery on, on the clients but server did not show up in explorer

I think this is a side effect of being in  workgroup as opposed to a domain.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...