Jump to content
RESET Forums (homeservershow.com)

Issue with RWA after switching to Pfsense router


tojoski
 Share

Recommended Posts

This has been driving me crazy for days...

 

RWA was working fine on my old WRT54G which was running Shibby Tomato, but after setting up a pfsense router I'm having the strangest issue...

 

WHS2011 is grabbing my internal IP (10.1.1.5) and updating that to my external xxx.homeserver,com domain.

 

So when I'm away from home, I can ping xxx.homeserver.com and it tries to resolve 10.1.1.5..

 

The ports are forwarded, and I can access the RWA if I directly access the public IP at home, although it complains about the certificate..

 

I tried to set the domain back up in the server settings, but it fails several of the steps..End result after it finishes is the same, ping xxx.homeserver.com or nslookup xxx.homeserver.com from an external IP and it resolves the internal IP (10.1.1.5)

 

One thing I did notice was that it seems Pfsense is blocking ping even though the ports 80 and 443 are forwarded.. I actually like this.. but maybe it's causing an issue?

 

There's no issue accessing the internet from the server, its using the Pfsense router for DNS, which is in turn forwarding DNS to OpenDNS.

Link to comment
Share on other sites

Let me address just the PING issue for the moment. PING is a utility that uses ICMP to test if a TCP/IP device is online. ICMP doesn't use port 80 or 443; it uses port 7.

Link to comment
Share on other sites

There was a thread about a month ago concerning Open DNS and switching to pfSense or Untangle. Search the forums.

Link to comment
Share on other sites

Well I think I finally found the culprit...to any who may run into this in the future, the solution is to exempt the homeserver's IP from the outgoing squid cache.

 

We'll see but after I made that change it updated the public IP..

pf1.JPG

Link to comment
Share on other sites

Also worth noting, if you turn on "Nat Reflection" in the NAT port mappings, then you will be able to resolve the public IP from within your home network.

 

I had to do this in order to use the "My Home Server" app on my Windows Phone from within my local network.

pf2.JPG

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...