Jump to content
RESET Forums (homeservershow.com)

Remote Music Player not working (Black / Blank) app


cw-kid
 Share

Recommended Posts

Hi

 

Having some issues with the WHS 2011 RWA Music Player. If I click to play an album the Silverlight app pops up in a new window but I just get a loading circle for a short while then a black screen and nothing happens.

 

I just did the below and deleted the MediaStreamingAdmin Media Player database and it started recreated a new file, as soon as some albums reappeared in the RWA Music area again I tried to play one and it worked OK.

 

However now that the database file has gotten larger, currently 105MB and still growing, (The DB file I deleted was 180MB) if I try to play an album now its not working again and just goes to a black screen. Seems like it can't cope with large music libraries.

 

Any ideas?

 

Thanks

 

1)Please try server reboot.

2)After reboot, turn off media streaming from server dashboard.

3)Stop the "windows media player network sharing service"

4)Rename the "currentdatabase_" file in C:\Users\MediaStreamingAdmin\AppData\Local\Microsoft\Media Player

5)Start the "windows media player network sharing service"

6)Turn on media streaming from server dashboard.Immediately, the database file is recreated.

 

Here's what it looks like, its the same in IE or Chrome. Internally on the LAN or via the WAN externally.

 

RWA-Music-App.jpg?psid=1

Link to comment
Share on other sites

Well the CurrentDatabase_372.wmdb file finished rebuilding, its now 170MB, I rebooted the WHS, now when I try to play an album via RWA the Music Player popup window / app just quits out and closes itself after a while. The thing just doesnt work.

Edited by cw-kid
Link to comment
Share on other sites

"The thing just doesnt work" - I told you: Dingo's kidneys. A great big pile of them.

 

Oh - and good luck. You'll need it.

Link to comment
Share on other sites

I registered my MSDN Support Contract yesterday, tried to submit a support incident online but it wouldn't let me proceed, said something about WHS 2011 not being part of my subscription, yet I can download product keys for it OK. Will have to call them on the phone I think to put in a support incident request.

Link to comment
Share on other sites

I am seeing this error more and more now, seems I have to reboot the WHS to clear the Media Library error.

 

RWA-MediaLibrary-Error.jpg?psid=1

 

Edit: Was stuck with that error for a while, I just refreshed the RWA webpage and now the media library items are accessible again. I have 16425 songs in my Music Library btw.

Edited by cw-kid
Link to comment
Share on other sites

Just what do you have against Dingo kidneys anyway? I'm sure the Dingos appreciate having them :)

I've got nothing against them when, as you say, they are in the Dingos. I blame Douglas Adams for the thought. :)

 

I am seeing this error more and more now, seems I have to reboot the WHS to clear the Media Library error.

 

Edit: Was stuck with that error for a while, I just refreshed the RWA webpage and now the media library items are accessible again. I have 16425 songs in my Music Library btw.

 

I expect that Microsoft will say that 16,425 songs is about 16,000 songs too many for the Media Library to work. Take a look at the last issue dealt with on their KB support page here:

 

http://social.technet.microsoft.com/wiki/contents/articles/4287.media-streaming-known-issue-and-workaround-with-windows-home-server-2011-and-windows-storage-server-2008-r2-essentials-en-us.aspx

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...