Jump to content
RESET Forums (homeservershow.com)

WHS v1 Need Help w/ Java!


byronomo
 Share

Recommended Posts

Ok here is the situation:

 

1)My v1 Box (EX475) has been working relatively trouble-free for a couple of years now.

2)A couple of weeks ago, I saw an alert about security vulnerabilities of "Java".

3)I disabled/uninstalled Java on all of my PCs.

4)I checked my WHS and was surprised to see Java listed among the programs (I hadn't noticed it before). I assumed that I might've somehow installed it on Day 1 of my WHS (back in 2008), which was the last time that I even accessed the web browser on WHS, so I uninstalled the program immediately.

 

I now realize that I've "broken" the Remote Access interface for my WHS (which I use to share photos with friends/family as well as Remote Access) because it is this Java which controls that functionality.

 

How can I restore this version of Java to get everything back to working as it was?

 

Do I need to do a "repair install" or is there somewhere that I can download/re-install the EX475 version of Java?

 

Thanks in advance for anyone able to help!

Link to comment
Share on other sites

  • Replies 22
  • Created
  • Last Reply

Top Posters In This Topic

  • Drashna Jaelre

    2

  • ImTheTypeOfGuy

    4

  • byronomo

    10

  • ikon

    6

Top Posters In This Topic

I've read elsewhere (old threads on other sites) that there is a particular version of Java that works with the MSS EX475. Installing a different or later version of Java results in limited or no functionality of the Webshare/Remote Access.

Link to comment
Share on other sites

I wasn't clear.....in haste, i said "this version" or "the EX475 version" rather than being more clear. Sorry about that. :-)

 

I use that Webshare a lot and am getting a bit frantic about restoring it.

 

I'm not sure which exact version it is, but I think that it might be a custom version that they released in conjunction with HP....

Link to comment
Share on other sites

OK, I'm not saying there isn't a specific version of Java for WHSv1, but I can't see how it would be specific to the EX475. Before you get all tangled up trying to locate some old version, have you even tried installing the current version? I think I would try that before doing a Recovery Install.

Link to comment
Share on other sites

yes sir...i have tried installing the current version and it doesn't work (in terms of making the Webshare/Remote Access available). If my understanding is correct from some snippets of info I've gleaned from trolling through google, the version is at least specific to HP boxes (and possibly specific to WHICH HP box you have). It doesn't appear to be totally "off the shelf" Java, but rather a somewhat customized implementation. Again, all of that is *IF* my understanding of snippets is correct.

Link to comment
Share on other sites

Thank you....I'd found that but still haven't gotten it to work....I'm trying ot figure out if it is a matter of figuring out which version works or figuring out the precise location (i.e. directory) where WHS is expecting to find it. Have been going through iterations of the 2, but none have worked yet.

 

I wish there was a way for me to "roll back" my WHS! :-)

 

Should a server recovery fix this? if so, what will it "break"?

Link to comment
Share on other sites

A Server Recovery should put your server back to the original distribution it had when you got it. You'll just have to be careful about the updates after that. Specifically, I saw posts to the effect that update 2.5 broke WebShare for some people.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...