Jump to content
RESET Forums (homeservershow.com)

Programs seem to unload/stop after I leave Remote Desktop


Joshua B
 Share

Recommended Posts

Hi guys. Here's a weird one. It seems that programs including uTorrent, SABnzbd, and maybe Sick Beard are closing down after I close out of remote desktop. It's apparent because when I use Remote Desktop to access my V1 server, I can see these programs loading into the system tray. I can also see that, for example, no progress has been made on my uTorrent downloads. While I'm in Remote Desktop, I can see everything humming along. Any idea what this could be about?

 

Thanks!

Josh

Edited by Joshua B
Link to comment
Share on other sites

Are you Logging Off or just Disconnecting - clicking the X on the window to close it? Logging Off will close the session, and any programs that were running; Disconnecting will leave your session running, including the programs that were running. BTW, you should get a notice that Disconnecting will leave your programs running.

Link to comment
Share on other sites

I'm just closing the X on the window. Remote Desktop does look a bit different. Perhaps I'm missing a toolbar? I wouldn't know how else to exit. How should I close out?

 

By the way, I get no notice when I click the X and the windows disappears.

Edited by Joshua B
Link to comment
Share on other sites

Here's the notification I get on my WHS2011 server when I disconnect RDP. I don't recall 100%, cause I'm old, but I think it was pretty much the same with V1:

 

gallery_502_13_12207.jpg

Link to comment
Share on other sites

Hi JM. I only use the Administrator account when logging in with Remote Desktop Connection. I use this method to install programs. I appreciate any thoughts you might have for me.

 

Just looked at WHS V1's start menu and I notice the programs I mentioned above are not in:

C:\Documents and Settings\Administrator\Start Menu\Programs\Startup

 

But they are in:

C:\Documents and Settings\All Users\Start Menu\Programs\Startup

Edited by Joshua B
Link to comment
Share on other sites

The fact that the shortcuts aren't in the Start Menus shouldn't matter. Once you've got the program running, it should stay running after you Disconnect

Link to comment
Share on other sites

Python is on the "iffy" side about network connections... response weirdly... And as sabnzbd and sickbeard are python packages....

 

Also, I'd recommend installing sabnzbd as a service. it supports it natively, actually (at least the windows app does)

http://wiki.sabnzbd.org/sabnzbd-as-a-windows-service

 

And on WHSv1, I used the pre-compiled binary for sickbeard, and added to that to the task scheduler. Worked best that way. No "weird" issues.

Link to comment
Share on other sites

If you drop the .exe in the startup folder for that user, all should be good. I believe it is a command prompted app. I just close the connection and mine runs with no issues.

Link to comment
Share on other sites

Thanks guys. I noticed that other people were having trouble with SickBeard on WHS too. There doesn't seem to be a good way to install this as a service. I did install SABnzbd as a service and that worked. Finally, after thinking about the extra time to configure these programs when they're updated to new versions, I decided instead to just install them and use them on my Windows 7 HTPC and remote desktop in to work with them. So much less headache. So these are no longer installed on my WHS.

 

Luckily other programs like Subsonic (for my Android and PC streaming needs) and StreamToMe (for Apple devices streaming) continue to work great on WHS V1.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...