Jump to content
RESET Forums (homeservershow.com)

Corrupted System Profile WHS-2011


TheGuy
 Share

Recommended Posts

hey folks, I woke up this morning with an error on my WHS-2011 box. Anyone know how I can fix this...and don't mention the word backup. ;)

 

------------

 

Error:

Location is not avalable

c:\Windows\system32\config\systemprofile\Desktop refers to a location that is unavailable. It could be on a hard drive on this computer, or on a network. check to make sure that the disk is properly inserted, or that you are connected to the Internet or your network, and then try again. If it still cannot be located, the information might have been moved to a different location.

 

ok

-----------------------

 

Yet the server is working, my services are ALL working and I can connect to it via directly (keyboard and monitor attached). but I get a black screen with this error and my desktop is simply not there.

 

My server manager shows everything fine, disk,etc... CHKDSK is fine...

 

The only error in all of the logs is from the file service with the error:

----------------

Volume Shadow Copy Service error: Unexpected error calling routine ConvertStringSidToSid(S-1-5-21-1767215204-380954103-2472445705-500.bak). hr = 0x80070539, The security ID structure is invalid.

.

Operation:

OnIdentify event

Gathering Writer Data

Context:

Execution Context: Shadow Copy Optimization Writer

Writer Class Id: {4dc3bdd4-ab48-4d07-adb0-3bee2926fd7f}

Writer Name: Shadow Copy Optimization Writer

Writer Instance ID: {38f87122-f3ec-4f03-92ee-33d194ddd52c}

---------------------------

 

when I first log-on via Remote Desktop as the Administrator I get "Preparing your Desktop"; then a black background and not much there except the error msg.

 

I get a pop-up stating:

 

User Profile Service:

You have been logged on with the default profile for the system. Please see the event log for details or contact your system administrator. ( My system administrator was useless in this case..as I am him)

 

For the other users I had defined, I now get the msg that they are not authorized for remote access.

 

so folks... how can I get it all back...

 

 

from a remote pc I am able to get from my LAUNCHPAD access the Shared folders, etc... but not to the Dashboard [ERROR: Unable to connect to Remote Web Access] and backup works...

 

go figure..

Link to comment
Share on other sites

How about we try a restore from a backup? Wait, you do have backups running, right?

 

Oh no, now you've done it; he said not the mention the 'B' word. :)

Link to comment
Share on other sites

How about we try a restore from a backup? Wait, you do have backups running, right?

 

One would have thought this would be easy...just bring back the system from a backup...been there done that.

 

Well for some strange reason, the backup is providing me the exact same issue...ohhh backup's has not been my friend, as it would seem that the last 3 weeks of backup all have this same issue... so much for not paying attention to my WHS-2011 version for the last 2 months.

 

and no I did not have this piece off site... everything else I do,,, but for whatever reason this piece went without being properly safeguarded, My mistake...but for now, one that still has me perplexed. :unsure:

 

thank you :D

Link to comment
Share on other sites

Can you create a new account with Admin Rights?

 

I was wondering that too but, if he can't get a desktop with his current admin account, how is he going to be able to create a new account. I ran into this once. After having to reinstall the system, I decided to never have less than 2 admin accounts on my servers.

 

Is there any way to add an account remotely (something in the back of my mind says it's possible)?.

Link to comment
Share on other sites

Can you create a new account with Admin Rights?

 

I can log-on with my original Administrator account. but get no usual desktop... I ran a checkdsk (it rebooted) and all is OK. yet I still do not have my desktops. I can get into my dashboard and everything seems to be working fine.

 

I can backup and restore...

 

but still the same issue.

 

time to re-install?

Link to comment
Share on other sites

What you can try doing is to download and install the remote server admin tools (RSAT) from Microsoft onto a Windows 7 pro PC. Once installed it should let you remote administer the server and create a new admin account. Since you don't have to remote desktop onto the server itself, it won't matter if the original admin desktop folder has gone corrupt. Once you have a new admin account on the server, RDP onto the server using this new account and then probably you may be able to see what has happened to the original account.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...