Jump to content
RESET Forums (homeservershow.com)

Easiest method to boot computer remotely?


red0151
 Share

Recommended Posts

Hi Everyone, first I would like to thank everyone for the contributions to the threads on this site :) . I didn't know much about the HP Microserver until i started using this forum and now after reading various posts I have a awesome setup that meets all my needs but one.

 

My Current setup is that I have installed WHS 2011 on my N40L HP Microserver, I access the server remotely using ThinRDP which I find very easy to use. I am also using a netgear N600 Wireless Dual Band Router WNDR3400.

 

I currently need someway to boot my server remotely. I can shutdown my server no problem remotely - but I dont like leaving it on for long periods of time for various reasons so I need a way boot up the system remotely without having to pay for any extra hardware ideally. I have looked into the following methods but none have yet met my requirements.

  • I know lights out is available which is an add on to the dashboard which allows to boot and shutdown the server at different times, the only problem with this is that I dont know when I might need to access my server before hand.
  • Someone told me that if I put the system into sleep mode then attempted to login using ThinRDP then it would wake the computer (I have no idea if this is true). I looked into this method but it seems that the Microserver only support Hibernate through CMD. I tried to hibernate the computer and login using ThinRDP but it did not come out of hibernation.
  • Finally I looked into Wake on LAN (WOL) - I followed various guides and setup port forwarding (for ports 7 & 9) and such and had Wake on LAN working for a short while, I was quite excited about it until I realised that WOL only worked for a short amount of time after the server had been switched off (around 10 mins). From what I googled this is apparently a common problem; some people say it is a fault in Windows while others say it is a router limitation - and that a router can only store addresses in its cache for a short period after a device has been switched off.

I look forward to hearing any advice to adjusting the above methods or hearing any other ways that might result in me being able to but the the server remotely. Thanks in advance.

Link to comment
Share on other sites

  • Replies 25
  • Created
  • Last Reply

Top Posters In This Topic

  • cskenney

    4

  • jmwills

    3

  • ikon

    7

  • red0151

    8

Top Posters In This Topic

Have you looked at the HP Microserver Remote Access Card? If I read through the manual there is a section on power control. I don't have any experience with this card but I think there are others in this forum that do. Perhaps they can help answer your question.

 

Here is a link to the manual.

 

Link to the card on Newegg.

Link to comment
Share on other sites

A couple of things:

  1. I don't see how it could be the fault of Windows. Once a system goes to sleep, it becomes a NIC/BIOS function to wake it up, not the OS. IIRC, the system has to be put into either Sleep Mode S1 or S3. I don't recall that a system can be woken up remotely from S5.
  2. I'm puzzled at the statements that it could be the router. Once a port is forwarded on a router it typically is always forwarded. It really shouldn't matter if the router's cache has expired (which is what people are talking about when they say a routers cache can't remember addresses longer than 10 min.).

One thing you can do is check your server's BIOS to ensure that Sleep Mode is set to S1 or S3. There can also be other settings in the BIOS that can affect waking up from Sleep Mode. I recall that Dell systems in particular had a second setting that could really mess things up.

 

Also, you can have a look at this page: http://wakeonlan.me/ and see if it provides any insight.

Link to comment
Share on other sites

Have you looked at the HP Microserver Remote Access Card? If I read through the manual there is a section on power control. I don't have any experience with this card but I think there are others in this forum that do. Perhaps they can help answer your question.

 

Here is a link to the manual.

 

Link to the card on Newegg.

 

I just went into my bios to view the IPMI Configuration and then I realised that I don't have this option and I don't have a Remote Access Card.

 

Sorry I thought I mentioned above that I would like to boot the Micro Server without any additional hardware if it can be done. I can't really afford to drop £60 at the moment coming up to christmas and all.

 

Thanks for your input anyway.

Link to comment
Share on other sites

Based on the information in this thread http://www.bios-mods.com/forum/Thread-HP-Proliant-Microserver-AMI-BIOS-MOD you can not use S3 or S5 sleep mode. Only thing available is S4 Hibernate. However, in the above thread there is mention that WOL should work and that some people have it working in Windows. I will look around some more (and might even experiment with my system too).

Link to comment
Share on other sites

Based on the information in this thread http://www.bios-mods...er-AMI-BIOS-MOD you can not use S3 or S5 sleep mode. Only thing available is S4 Hibernate. However, in the above thread there is mention that WOL should work and that some people have it working in Windows. I will look around some more (and might even experiment with my system too).

 

Thanks I appreciate you looking into this.

Link to comment
Share on other sites

A couple of things:

  1. I don't see how it could be the fault of Windows. Once a system goes to sleep, it becomes a NIC/BIOS function to wake it up, not the OS. IIRC, the system has to be put into either Sleep Mode S1 or S3. I don't recall that a system can be woken up remotely from S5.
  2. I'm puzzled at the statements that it could be the router. Once a port is forwarded on a router it typically is always forwarded. It really shouldn't matter if the router's cache has expired (which is what people are talking about when they say a routers cache can't remember addresses longer than 10 min.).

One thing you can do is check your server's BIOS to ensure that Sleep Mode is set to S1 or S3. There can also be other settings in the BIOS that can affect waking up from Sleep Mode. I recall that Dell systems in particular had a second setting that could really mess things up.

 

Also, you can have a look at this page: http://wakeonlan.me/ and see if it provides any insight.

 

 

I originally thought it would not be a fault with windows, but some people on some forums seems to think it is.

 

I have been looking into my router settings for WOL and i can't find any specific option relating to WOL. I have forwarded ports 7 and 9 for my servers IP address (Which is static). It does work but only after a short time after the system has been shut down. I have been using a small app on my android (GalaxyS3) to do this, i have also tried other apps on my laptop to the same affect.

 

Some people metioned you need a broadcast option on your router but I cant seems to find any mention of this within the admin settings either.

Link to comment
Share on other sites

If you read that link I posted you'll see that you need to set the internal forwarded IP to the broadcast address for your LAN. For example, if you use the ubquitous 192.168.x.x range, you would set the address to something like 192.168.x.255. You have to replace the 'x' with the number for your LAN: e.g. 192.168.0.255 or 192.168.1.255; you get the idea I'm sure.

 

You would configure your WoL app on your Galaxy to send the MAC address of the computer you want to wake up to the Internet WAN address your router got from your ISP, on the appropriate port of course. When your router sees a packet on the port, it will forward the packet to the broadcast address of your LAN, which means all computers on your LAN will see the packet. The computer with the matching MAC address should wake up.

 

Be aware, not all routers will permit forwarding to broadcast addresses. Also, if possible, I would configure the WoL app to use a non-standard port above 1024, to reduce security concerns. You would have to configure your router to forward to the proper port on your LAN.

Link to comment
Share on other sites

If you read that link I posted you'll see that you need to set the internal forwarded IP to the broadcast address for your LAN. For example, if you use the ubquitous 192.168.x.x range, you would set the address to something like 192.168.x.255. You have to replace the 'x' with the number for your LAN: e.g. 192.168.0.255 or 192.168.1.255; you get the idea I'm sure.

 

You would configure your WoL app on your Galaxy to send the MAC address of the computer you want to wake up to the Internet WAN address your router got from your ISP, on the appropriate port of course. When your router sees a packet on the port, it will forward the packet to the broadcast address of your LAN, which means all computers on your LAN will see the packet. The computer with the matching MAC address should wake up.

 

Be aware, not all routers will permit forwarding to broadcast addresses. Also, if possible, I would configure the WoL app to use a non-standard port above 1024, to reduce security concerns. You would have to configure your router to forward to the proper port on your LAN.

 

Hi, yes I did see the link you posted and thank you for clarifying. Unforunatly it looks like i can't forward to my broadcast address as every time I go to the Port Forwarding/Triggering tab and I type it in I get the following message 'Server IP address cannot be routers LAN IP address'

 

Is there any easy workaround?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...