Jump to content
RESET Forums (homeservershow.com)

loads of ata interface fatal errors


digininja
 Share

Recommended Posts

I've got my N40L flashed with the new BIOS, following the instructions from diehard, and have a laptop drive acting as the OS for a Proxmox install. The other day I connected to the console and saw a load of these messages:

 

ata6.00: exception Emask 0x10 SAct 0x1 SErr 0x280100 action 0x6 frozen
ata6.00: irq_stat 0x08000000, interface fatal error
ata6: SError: { UnrecovData 10B8B BadCRC }
ata6.00: failed command: READ FPDMA QUEUED
ata6.00: cmd 60/b0:00:10:4e:a5/00:00:01:00:00/40 tag 0 ncq 90112 in
	 res 40/00:00:10:4e:a5/00:00:01:00:00/40 Emask 0x10 (ATA bus error)
ata6.00: status: { DRDY }
ata6: hard resetting link
ata6: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
ata6.00: configured for UDMA/33
ata6: EH complete

 

ata6 being the laptop drive. I assumed the drive was failing so swapped it for another but I'm now getting the same messages with the new one so it isn't the drive.

 

The original drive was a 3Gbps drive but this one is just 1.5, the BIOS is set to auto detect so the speed shouldn't matter.

 

Has anyone else seen this or know how to fix it?

Edited by digininja
Link to comment
Share on other sites

Yes, I noticed the problem first on the 3Gbps drive which is why I swapped it for the 1.5 drive assuming it was the drive which was failing.

Link to comment
Share on other sites

I think it would be best for other N40L owners to step in. I have used various SATA settings on a variety of motherboards during testing/experimenting over the years, but not the N40L specifically.

Link to comment
Share on other sites

My first place to look was always the SATA timings. I don't know if the N40L mod BIOS gives you access to them. Another thing is write-back cache. Try enabling/disabling it and see what happens.

 

Take notes. :)

Link to comment
Share on other sites

Finally found time to have a look and there isn't much to configure, nothing about timings. Write-back cache is disabled and from the warning I don't fancy enabling it.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...