Jump to content
RESET Forums (homeservershow.com)

WS2012E box has internet access but cannot ping or browse internet?


Jason
 Share

Recommended Posts

My WS2012E box is set with static IP 192.168.0.100, Subnet mask 255.255.255.0 and Gateway 192.168.0.1 (my router) but is unable to browse internet web sites.

 

I've confirmed every other machine on my LAN is able to browse the web when using static or DHCP with gateway 192.168.0.1.

 

IE Enhanced Security Configuration on the WS2012E is disabled.

 

What could possibly cause this?

Link to comment
Share on other sites

  • Replies 56
  • Created
  • Last Reply

Top Posters In This Topic

  • Drashna Jaelre

    11

  • jmwills

    11

  • ikon

    17

  • Jason

    16

Top Posters In This Topic

Posted Images

Well, the MS server engineers do have a phrase for those who want to browse the web from their WS boxes, "It's a Server, not a Surfboard!". :D

 

Seriously though, you can't browse any sites?

Link to comment
Share on other sites

What are the DNS settings? You may need to add one from the outside world, such as Google which is either:

 

8.8.8.8 or 8.8.4.4

 

I do think there were some DNS servers down on Saturday morning or some routes were timing out.

Link to comment
Share on other sites

I agree with what jmwills is asking you, check your DNS. By default, WS2012E points the DNS to itself because of the DNS server roles that are installed. I would not point the server's DNS to Google for continued use. If you wish to use Google's DNS for your network, then set this in your router. Point the server's IPv4 DNS to your router's address, which looks like, in your case, will be 192.168.0.1.

Edited by JerryW
Link to comment
Share on other sites

I agree with what jmwills is asking you, check your DNS. By default, WS2012E points the DNS to itself because of the DNS server roles that are installed. I would not point the server's DNS to Google for continued use. If you wish to use Google's DNS for your network, then set this in your router. Point the server's IPv4 DNS to your router's address, which looks like, in your case, will be 192.168.0.1.

 

I've confirmed my WS2012E is set to obtain IP automatically and obtain DNS automatically. Else if I point the WS2012E DNS to 192.168.0.1 (my gateway) the same issue occurs.

 

However if I set a static IP in my router of 192.168.0.99, 192.168.0.199, 192.168.0.143, etc., the WS2012E can access the internet without issue. I first noticed this when my WS2012E box wasn't performing scheduled downloads. It will accept incoming RDP connections from other PCs on my LAN to 192.168.0.100, but it cannot ping google, etc. I have my router set to use my ISP's DNS servers which work fine for every other PC on my LAN.

Link to comment
Share on other sites

I've confirmed my WS2012E is set to obtain IP automatically and obtain DNS automatically. Else if I point the WS2012E DNS to 192.168.0.1 (my gateway) the same issue occurs.

 

However if I set a static IP in my router of 192.168.0.99, 192.168.0.199, 192.168.0.143, etc., the WS2012E can access the internet without issue. I first noticed this when my WS2012E box wasn't performing scheduled downloads. It will accept incoming RDP connections from other PCs on my LAN to 192.168.0.100, but it cannot ping google, etc. I have my router set to use my ISP's DNS servers which work fine for every other PC on my LAN.

 

If you have everything set to DHCP, what IP information is your server showing?

Link to comment
Share on other sites

The WS2012E machine assumed an IP of 192.168.0.200 which is the first IP address available in my DHCP server range of 192.168.0.200-254. Whereas the first static IP used by my HTPC is 192.168.0.101.

 

Oddly enough, I've had this WS2012E machine set to 192.168.0.100 for quite sometime until recently it stopped working. Am guessing it has something to do with pfsense 2.0.1 but cannot quite pinpoint it.

Link to comment
Share on other sites

Change the scope settings of the DHCP server and verify the lease assignments. I would also put in one of the Google DNS entries into the pfSense box.

Link to comment
Share on other sites

I also suspected it's a DNS issue. That's why I asked if you could browse any sites at all. If you could browse even one site by name, then it would point to something other than DNS.

 

Here's how I have mine set up.

 

My server is the DNS source for my LAN. It's also the DHCP server. My server points to my router as its DNS source. My router points to my ISP's DNS servers.

 

The reason for having my server be the DNS source for my LAN is so that all the client computers on my LAN can find each other by name - my server is the authoratative source for my LAN. Of course, I still want to be able to browse the web, so my server needs to have a source for sites it doesn't know about. That's why I point my server to my router, since it has DNS capability. My router also needs to have a source for sites it doesn't know about, so it automatically gets my ISP's DNS server addresses via DHCP. From there, it's my ISP's responsibility. :)

 

I could, of course, put the addresses of my ISP's DNS servers into my server, but that would mean I would have to maintain the settings if my ISP changes the addresses. Since my router always gets the addresses of my ISP's DNS servers via DHCP, it makes sense to point my server to my router.

Link to comment
Share on other sites

ikon, if I follow correctly -- here's my current setup:

 

pfsense box IP: 192.168.0.1

LAN DHCP range is: 192.168.0.200-245

I've remove all static DHCP leases

 

In WS2012E, the NIC is setup to obtain the IP automatically and obtain DNS automatically. Generally my WS2012E box is getting the first available IP of 192.168.0.200.

 

Oddly enough, when I ping the IP of 192.168.0.200 AND 192.168.0.100, they both point back to my WS2012E box. All the while I didn't even realize it was holding onto 192.168.0.100. I didn't think it was possible for 1 NIC to have 2 IP addresses assigned to it.

 

Would you suggest I set my WS2012E NIC as

 

IP: 192.168.0.100

subnet: 255.255.255.0

gateway: 192.168.0.1 (my pfsense box)

 

DNS: 192.168.0.1 (my pfesense box)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...